Upgrading Ubuntu Desktop to 23.10 Corrupts the VM

Discussion in 'Linux Virtual Machine' started by HalilD1, Dec 3, 2023.

  1. HalilD1

    HalilD1

    Messages:
    1
    Upgrading Ubuntu Desktop from 23.04 to 23.10 results in the corruption of the boot disk and the attached screen appears. Does anyone know a solution to correct this ? I am running the latest version of Parallels Desktop for Mac Pro Edition on a Sonoma M2 Air.
    Screenshot 2023-12-03 at 11.54.57.png
     
    AaronR16 likes this.
  2. DM_3

    DM_3 Bit poster

    Messages:
    1
    Same here. It seems upgrade to 23.04 worked fine, but then it suggested going to 23.10 and after successful completion and reboot I got the same screen. When you go into boot manager it lists one old kernel (from my previous ubuntu) that does not boot and falls back on this screen.
     

    Attached Files:

  3. AaronR16

    AaronR16 Bit poster

    Messages:
    1
    I have attempted to get this upgrade to work for months and finally got it to work. Somewhat similar to you, I am using Sonoma on an M1 Mac book Pro. I'm using the arm64 variant so perhaps this might help. Try installing "grub-efi-arm64" in 23.04 if not already installed.

    I wondered about an EFI boot error I had seen for some time but ignored because everything otherwise seemed to be working fine, but I felt perhaps it was relevant to this issue. I discovered that 'grub-efi-arm64' was not installed in 23.04 - after installing and rebooting I no longer saw the EFI boot error

    I tried another upgrade to 23.10, and this time, it worked and booted. (and has booted multiple times since - I had to check :)
     
  4. jhbarker

    jhbarker Bit poster

    Messages:
    8
    i have this problem too. This has happened previously when I try to upgrade by Ubuntu install . .
     
  5. HarriL3

    HarriL3 Bit poster

    Messages:
    3
    Thank you, @AaronR16; by installing "grub-efi-arm64," I solved my problem with 23.04 -> 23.10 and finally got 24.04 working.
     

Share This Page