Uploading maps to Garmin GPS using USB fails.

Discussion in 'Windows Guest OS Discussion' started by jdedecker, Sep 2, 2007.

  1. jdedecker

    jdedecker

    Messages:
    4
    Hello,

    after upgrading to Parallels 3.0 I am now unable to upload maps to my Garmin GPS. My Garmin GPS is detected without problems but the upload process is aborted at around 11% with the message: "There was an error communicating with your device.". I already retried several times. I even installed Mapsource on a fresh Windows XP installation - no luck there. Some version information about the involved programs:
    - Windows XP with SP2
    - Parallels 3.0 build 4560
    - Mapsource 6.12.4

    Before upgrading to Parallels 3.0 I did not have this problem.

    Any suggestions to resolve this problem?

    Thank you.
     
  2. fbronner

    fbronner

    Messages:
    384
    Which Garmin GPS? I use a Quest and it works, I also have the latest drivers from the Garmin web site.
     
  3. jdedecker

    jdedecker

    Messages:
    4
    It's a Garmin GPSmap 60CSX. The drivers I am using are the ones included with the Mapsource application.

    Thanks.
     
  4. fbronner

    fbronner

    Messages:
    384
  5. Nodawurri

    Nodawurri

    Messages:
    5
    Can anyone PLEASE help me ... PLEASE ... PLEASE ...
    I have a MacBook Pro 2.16Ghz and have been trying to load my Garmin GPS software "Mapsource Trip and Waypoint Manager" (PC software) onto it using this latest Parallels Desktop 3.0 for Mac.
    Part way through the Installshield Wizard, I receive a message that:
    "Setup has detected an Existing MapSource installation.
    All Mapsource products share the same application environment. Your existing MapSource installation will be modified to incorporate this product.
    You may switch between products by selecting them from the Product Selection Box on the MapSource toolbar."
    OK.
    Then, as the Wizard prepares to install, I receive the following error message:
    !
    "Same version of detailed maps already installed.
    Setup will now exit."
    OK
    When I click on the Mapsource icon on the Parallels desktop, I get an error message:
    X
    "There is a problem with the MapSource registry.
    Please re-install MapSource and start it again."
    OK
    I have tried removing all Garmin and MapSource software using the Add or Remove Programs to 'clear' the Parallels environment of any "already installed" MapSource bits and pieces, but still I get the same messages eveytime I try and re-instal the software from the CD.
    Last week, I successfully got this same MapSource software to run on my friends G4 Mac using "Virtual PC" (up till then, I had only ever used it on my PC) - but there seems to be a glitch with Parallels and Garmin's MapSource ... ?
    I noticed that users on this forum have successfully loaded Trip & Waypoint Manager, so hopefully someone can help me (the Parallels Support Team told me to get the answer from the forum ... ?!)
    Can anyone PLEASE suggest what I could try so that I can run this software ?
     
  6. ggilley

    ggilley

    Messages:
    2
    I am having this same problem. Uploading maps to my GPS60CSx fails. This is extremely frustrating as this is the ONLY reason I bought parallels!

    And yes, I did run their web updater and even went back and re-installed the USB drivers.
     
  7. Nodawurri

    Nodawurri

    Messages:
    5
    Hi ggilley,
    Frustrating ay!
    I got this SPECTACULAR support from Garmin's Tech Support and it fixed my MapSource woes ...
    Good luck & cheers.

    1. Go to the start menu in windows
    2. Select the settings and then select the control panel.
    3. In the control panel double click on the icon for ADD/REMOVE
    PROGRAMS.
    4. Select MapSource in the uninstall window. The software will ask to
    if you wish to uninstall all the components, answer YES to this
    option.
    5. Next go to my computer and open the "c" drive, there you will see
    a Garmin folder delete it.
    6. Next go to Start and click on Run, type in %temp% and click ok,
    this will bring you to your temp files, go to edit and click on select
    all, then go to file and click on delete, once the files start being
    deleted, there may be some that will give you an option to select yes or
    no, select no you don't want to delete it, some may simply say that the
    file can not be deleted that is ok because those are needed files, once
    you click on ok in that pop up the process will stop, you can start it
    again by clicking on the file second in the list and then by holding
    down the shift key and scrolling to the end of the list click on the
    last file, this will select all the files accept the first one that
    stopped the process. Keep repeating these steps until the temp files
    have been cleaned out accept the ones that need to stay.
    7. Select the Start key to the run option. In the run window type in <
    regedit > and enter. In the registry editor, you need to be very
    careful and please follow these steps precisely.
    a. Select the (+) next to the folder stating HKEY_CURRENT_USER
    b. In this view select the (+) next to SOFTWARE, when you click on
    this it will open your registry further.
    c. In the SOFTWARE view you will see a series of folders, one will be
    GARMIN. Highlight the word GARMIN and press the delete key. It will
    ask for confirmation of deletion. Make sure that the word GARMIN is the
    only key highlighted. Press on the (-) signs to contract the
    expansion.
    d. Repeat the same process for HKEY_LOCAL_MACHINE. It may not be in
    this registry.
    8. Shut down your system as normal and then let the system set for about
    30 seconds and then start up your computer.
    9. Before re-installing the software please disable or turn off any
    security programs; i.e. Norton, McAfee, Spyware, and or Zone Alarm.
    10. Reinstall the software. It will ask for the destination folder, if
    the setting is the C:\Program Files and so forth, click on the browse
    option and type in a different destination folder. C:\Garmin. This
    folder will not exist, but the option to create it will follow. Select
    OK.
    11. Reboot after finishing your installation allowing the software to
    rest in the destination folder.
    12. After you reinstall, I recommend that you upgrade your operating
    software to the latest version of the MapSource operating system, i.e.
    update Mapsource or the nroute program to the latest version from our
    web site, by going to updates and downloads, then click on mapping
    programs, and click on the option needed.

    MAPSOURCE: http://www.garmin.com/support/download_details.jsp?id=209
     
  8. ggilley

    ggilley

    Messages:
    2
    Yeah, this is the normal support story. Can't be our fault. Wipe your machine clean and re-install everything.

    Well, I did it and it made not difference. It fails.

    I did the same install procedure on a real windows machine and it works fine.

    Parallels needs to fix their bug.
     
  9. jammertal

    jammertal

    Messages:
    7
    I agree with ggilley. It is a bug in Parallels, because one release ago, there wer no problems.
     
  10. gegervision

    gegervision

    Messages:
    185
    I use the OSX version of Garmin Updater and it works perfectly. Why is everyone only relying on the Windows version when the OSX version is available and works fine?
     
  11. Morrie

    Morrie

    Messages:
    19
    What OS X verson of Garmin updater? MapSource isn't supported on OS X.
     
  12. AlanGrafen

    AlanGrafen

    Messages:
    2
    Technique for uploading maps to GPSMAP 60CSx using USB

    After weeks of frustrations of the kinds described above, I found a way that works reliably for me. Here it is:

    Put the unit into Mass Storage Mode
    MapSource recognises this as a device, so you can upload the maps

    Its that simple!

    Maybe it works because the USB drivers for hard disks have error correction that the Garmin drivers lack.

    I got the idea from this site, which also has a couple of other really neat tricks. My only contribution was to use Mass Storage Mode to make the microSD card act as a hard disk, instead of using an SD adaptor.

    I'm using a MacBook Pro with Parallels 3 (Build 5160), OS X v 10.4.11, version 3.3 of the 60CSx firmware, and a SanDisk 1Gb card (but not, of course, the "Ultra II" type that is supposed not to work).

    I've tested this only on one computer and one GPS unit, but its probably worth a try!

    Alan
     
  13. AlanGrafen

    AlanGrafen

    Messages:
    2
  14. Morrie

    Morrie

    Messages:
    19
    Maybe I'll try this and report what happens. In my frustration I was forced to download a trial version of the competition (VMWare) and it had no problem at all downloading a 1.7 Gb map set to my Garmin. I'd like to stay with Parallels, especially since I already bought it, but ability to use the Garmin software is a make-or-break issue for me.
     
  15. WanderingTexan

    WanderingTexan

    Messages:
    2
    Success!

    THANK YOU AlanGrafen!

    After several frustrating days of installing/updating/uninstalling/reinstalling MapSource, I tried the USB Mass Storage trick after reading Alan's tip here and it worked like a charm for me.

    I could load my home map (Colorado) and the Utah desert -- about 33MB total -- but anything beyond that would fail every time. After I put my unit (Vista HCx) into USB Mass Storage Mode, I got 328MB of maps to load like a champ and without any errors. To get there on the Vista: Menu-->Setup-->Interface, then click USB Mass Storage.

    Just for fun, I'm going to try and load the whole North America cities DVD onto my SD card and see if it works. I'll report back after I find the time to try it.
     
  16. WanderingTexan

    WanderingTexan

    Messages:
    2
    I was able to load the entire DVD to my device using the Mass Storage mode. I'm a little confused as to why it takes close to two hours to transfer 1.75 Gigs of data, but at least I got it to work!
     
  17. snak-pak

    snak-pak

    Messages:
    24
    crashes on Parallels 2.5

    I am getting hard resets of Windows (blue screen of death or black screen of death) when I use my Garmin GPS unit. I have a Garmin eTrex Vista Cx and it simply doesn't work. The unit says it is in USB Mass Storage mode but it still doesn't work.

    I am using the latest version of Parallels 2.5 on OS X Leopard, and it crashes with Garmin software all the time. Does it work any different/better on Parallels 3.0? Apparently this application works just fine on VMWare... I'm going to download and try that now [sigh].

    Since I have to pay for the upgrade to Parallels 3, and my Garmin GPS may still not work, it's not much difference in price to just buy VMWare... sad but true.
     

Share This Page