Urgent: USB device not working after update of P8 to build 8.0.18345

Discussion in 'Windows Guest OS Discussion' started by spachner, Nov 28, 2012.

  1. choochoo

    choochoo

    Messages:
    1
    I had the same problem. My USB dictaphone was working perfectly fine on XP guest machine until upgrade. It also works in VMware fusionn 5 too. I downloaded the old version and reinstalled it and now everything is back working.
     
  2. BayardC

    BayardC Bit Poster

    Messages:
    21
    I was off the 'Net over the weekend due to a broken broadband drop cable between the street and our house,
    so I wasn't able to try the new Parallels 8 kit to which someone kindly posted a link.

    Alexdaft - I think your problem might be related to this general USB device non-start issue, although you may need
    to check the settings presented in the Mac OS X toolbar for Parallels (when you have Parallels up and running
    and 'focused') because it's possible that Parallels doesn't know that it's supposed to present the WebCAM to
    your guest OS (Windows, or whatever). I spent a fair amount of time clicking and unclicking my Serial/USB
    (FTDI chip-based) adapter and my USB Sound Card over the weekend. Parallels and/or Windows (and Mac OS X?)
    might think that the WebCam is a USB device (and might well be, even if it's just in silicon, with no cables ) :).

    However, I was able to do a modicum of testing offline using the previously downloaded Parallels 7 kit to which
    I posted a link earlier, and discovered that although my FTDI/serial line and USB Sound Card "worked" (in that
    my applications were able to function properly in their individual roles), I did notice that I did not have any
    "Windows sounds".

    Normally, Windows 7 would see two audio devices - the built-in one in the iMac as presented to it by Parallels 7,
    plus the USB Sound Card. I had Windows 7 configured to route the normal Windows 7 emissions ("Ding", etc.)
    back through Parallels to the iMac hardware, and the USB Sound Card was reserved for use solely by my
    applications, thereby ensuring that Windows 7 sounds did *NOT* go through the USB. (This is a critical
    requirement - I'm using the USB Sound Card, a Signalink USB, as an interface to my amateur ["ham"] radio
    equipment and the applications perform DSP magic to create "tones" that transmit digital data through the
    audio/microphone circuits of my transceiver - transmitting a Microsoft "ding" in the middle of that is a "no-no"!).

    However, now Windows 7 refuses to "see" the Parallels-routed iMac hardware and thinks there is only one
    sound card on the system - the USB one. Obviously, I had to then turn off all Windows Sounds from within
    one of the various Windows 7 system management GUIs.

    This is beginning to feel like a sausage-squeezing exercise, whereby what's squirting out the ends can be pushed
    back in at the expense of other stuff squirting out the sides. I'm going to try the Parallels 8 kit now (after I
    finish my backups, thank you...) and see if there's been any improvement over the weekend, but given the
    track record of Parallels "support", I'm not optimistic.
     
  3. Wilford

    Wilford Bit Poster

    Messages:
    9
    Clearly there is something wrong with the last update from Parallels Desktop 8, regarding the sound issue. Everything worked again when using an earlier update.

    It's important that the tech guys at Parallel finds a solution to this problem. What's the point of having this forum if no one at Parallels is monitoring and take the proper action, when needed?
     
  4. tblack

    tblack Bit Poster

    Messages:
    94
    Problem solved (sort of)

    I followed Spachner's link and reinstalled build *314 without any problems.
     
  5. JaredE

    JaredE Bit Poster

    Messages:
    13
    just for the record

    Another Parallels user here who upgraded to 8.0.18345 and not longer able to share webcam inside the virtual machine. Am rolling back to the previous version as mentioned above...

    Update: webcam sharing working after rolling back to previous version.
     
    Last edited: Dec 3, 2012
  6. Stefan P

    Stefan P Bit Poster

    Messages:
    31
    I still get the buggy version offered by P8, although I selected "skip this version". Seems that we and our problems are not taken seriously.

    spachner
     
  7. Hooman

    Hooman Bit Poster

    Messages:
    2
    I had same issue with black webcam.. rolling back to previous version of P8 worked.

    Thanks for the tip
     
  8. albertjo

    albertjo

    Messages:
    1
    New version

    I used the link I installed the earlier version and all works fine.
    Thanks
     
  9. >>> Message has been deleted by the user <<<
     
  10. Steve12

    Steve12

    Messages:
    1
    I should have read this forum before updating to the "latest and greatest" version. Now I'll have to revert to the previous version if I want my FTDI-chip based cables to work.
     
  11. Alexdaft

    Alexdaft

    Messages:
    4
    Somebody knows if the problem is fixed with the new version 8.0.18354?
     
  12. BayardC

    BayardC Bit Poster

    Messages:
    21
    The various articles in the forum are helpful, but unless you subscribe to e-mail updates pertaining to a specific
    Knowledge Base article, you might not be notified (directly) of the availability of an update.

    I got an e-mail this morning (0246 on 6 Dec 12) pertaining to Article 115234 and it pointed me to:
    http://kb.parallels.com/en/111603
    which describes how to find updates. (Article 115234's title is "Built-in Mac camera does not work in Parallels Desktop 8")

    I then shut down my Windows 7 VM, and Parallels 7, made a copy of my Windows7.pvm directory, then
    downloaded and installed ParallelsDesktop-8.0.18354.823166.dmg. Unfortunately, I wasn't in the room when it
    finished the installation and booted Windows 7, but when I came back, I had to "reattach" my FTDI Serial/USB
    adapter and my USB Sound Card (because I had deliberately configured them to stay on the "computer" instead
    of automatically allowing Windows to grab them), but when I did (using the menu bar for Parallels Desktop ->
    Devices -> USB), Windows 7 actually gave its normal chirp (? grunt? whatever that sound is ?!?) to signify a change.
    It hadn't done THAT in a while, either !!

    Bottom line - all of my issues *appear* to have been resolved with 8.0.18354.823166 as far as I can tell *so*far*.

    Now to gobble up another ~35GB of disk space with another spare copy of this .pvm folder/directory/package/whatever.
     
  13. Wilford

    Wilford Bit Poster

    Messages:
    9
    It seems that the problem is solved. Installed the latest update, and everything works :)
     
  14. Plungestep

    Plungestep Bit Poster

    Messages:
    3
    Same issue here. Two USB devices stopped functioning which were FTDI USB2Serial adapters. I'll try rolling back and hope that they solve this quickly! Please add this type of check to your product testing before releasing any more updates!
     
  15. Roman Fattakhovv

    Roman Fattakhovv Parallels Developers

    Messages:
    17
    Please update Parallels Desktop 8 to the latest build; the USB issue was fixed
     
  16. spachner

    spachner Bit Poster

    Messages:
    12
    I can also confirm that last version of P8 (Build 8.0.18354 (Revision 823166; Tue, 04 Dec 2012)) fixed the USB problem. Go for it!

    regards

    spachner
     
  17. YanaYana

    YanaYana

    Messages:
    1,666
    Hello guys, sorry for discovering this post so late. For future reference - you can always go back to the previous version - all your downloads are in ~/Library/Parallels/Downloads. you can open folder using Terminal
     
  18. tblack

    tblack Bit Poster

    Messages:
    94
    Working again

    My problem was that Windows ceased to recognise my USB mike. Since I use Dragon Naturally Speaking every day for work, this was a disaster.

    For what it's worth, build 8.0.18354.823166 which I installed yesterday is working fine. The problem seems to have been fixed.

    Tom
     
  19. YanaYana

    YanaYana

    Messages:
    1,666
    Thanks for confirmation everything is working fine now.
     
  20. BayardC

    BayardC Bit Poster

    Messages:
    21
    One thing that I found, after some poking and prodding, was that I had to not only shutdown
    Windows 7, but also "Quit" Parallels Desktop, in order to make sure that certain device
    assignments persisted and that Windows would behave itself properly (i.e., not use my external
    USB "sound card" as the system sound card, and allow that sound card to do both input and output).

    However, once I figured that out, as well as following YanaYana's suggestions, things have
    been working well with 8.0.18354 (Revision 823166; December 4, 2012).

    Hopefully, there won't be any further regressions with P8 and W7 !
     

Share This Page