USB 2 - Epson R2400 printer

Discussion in 'Parallels Desktop for Mac' started by bigbob, Mar 9, 2007.

  1. bigbob

    bigbob

    Messages:
    35
    Using iMac 20" pentium processor - Parallels V 3188 XP Pro - 2 gig ram - My Mac works find using the printer usb2 . It has never worked on the Windows side. I have tried everything. After calling tech support yes and talking to a life person. He tried several things to make printer work with out success, recommend buying a print server. Which I ran out a bought. Last night I spent 1 1/2 hrs on phone with tech support for the print server. They said the print server will not work with your printer... I Returned the server this AM. Several people advised me to go back to BootCamp... Need Help.. I am a photographer and need the driver and profiles that come with the printer. ( monitor match printer).. bob
     
  2. DaveB

    DaveB

    Messages:
    33
    Bob-
    You may want to read all the previous threads that deal with printing including the Sticky at the top of the Forum listing!

    David
     
  3. sidssp

    sidssp

    Messages:
    182
    On another thread, one user claimed that he got R2400 to work by using Bonjour and the latest EPSON driver. You might want to check with EPSON web site to make sure you are using the latest driver. I have a R800. No matter what I did, I couldn't get the EPSON driver to work. Maybe it is just too old.
     
  4. rhsant

    rhsant

    Messages:
    6
    I'm having lots of problems with this too. I'm a photographer trying to use qimage on the windows side - I need to be able to set the Epson print driver for different types of media. I looked at the sticky and did a forum search - none of the tricks worked. Any help would be greatly appreciated!

    Thanks,

    Rich
     
  5. mkstevo

    mkstevo

    Messages:
    40
    Have you tried this ??

    It worked for me , using the stated Epson 680 ( USB ) and an Epson DX4800 scanner/printer combo though I have yet to try using the scanner side , printing is fine .

    >quote<
    Managed to get printing working in Windows XP . Printer ( Epson Stylus Color 680 ) connected to Mac on USB .

    The way I did it was to set up a new 'CUPS' printer , this then appears in Windows as a network printer , install the Windows XP printer drivers ( Epson Stylus Color 680 ESC/P2 ) and hey presto !

    To set up a 'CUPS' printer , on the Mac open a web browser ( any ) and enter the address http://127.0.0.1:631 . The new printer should be given a unique ( but short - less than 8 characters ) name - ep680 for example . Make sure that when setting up your CUPS printer that you set it up as having a make of 'Raw ' ( NOT Epson ) and set the driver for it in CUPS as Raw too .

    If you can't make sense of my instructions , Google for CUPS , OSX and 127.0.0.1:631 should turn up some better written instructions . Sorry mine are not better but I've only just escaped from the Microsoft prison and am returned to the status of beginner again !
     
  6. DaveB

    DaveB

    Messages:
    33
    Epson R2400

    Rich-
    I've had Parallels since before v1970. Back in those dark days the only way for me to connect with my R2400 was thru the generic driver. Along the way I've tried a Linksys router, a linksys print server and "all" the suggestions in the threads on this forum. Some versions it would work (the connection) some it wouldn't. With RC3 and the current v2.5, I've been able to connect using Apples recent Extreme with the USB port. As in previous attempts, I have first set up the printer in OS X, then made sure to share it. Then, I've loaded the windows drivers in XP. Then I've installed the printer using the latest Bonjour for Windows. The VM machine recognizes the printer as an Epson R2400 and uses the driver and printer interface as designed. However, neither the OS X session nor the VM session will not recognize the Utility program for the printer. If I want to check the ink levels or run any of the other utility tests, I have to connect the printer directly to a USB port in the OS X system. This I am assuming is an issue with the Epson supplied drivers and not OS X. Otherwise, in Parallels, I can print to the R2400 using Office 2007, Nikon Capture NX and Lightroom. The latter two programs are for photo printing, AND that uses all of the driver interface options for the R2400.

    So, download the latest driver, and good luck.

    By the way, I'm NOT downloading another version of Parallels until something happens to this connection :)

    Dave
     
  7. bigbob

    bigbob

    Messages:
    35
    Thanks for all the info. There sure are some great people on this site. Thanks again Bob
     
  8. rhsant

    rhsant

    Messages:
    6
    Hi everyone -

    Thanks for the help! I'm going to try mkstevo's way first so I hopefully don't have to buy an Extreme.

    Quick question - when I'm trying to set up the CUPS printer, the 2nd screen I get is "device for R2400," for which, I assume, I put "usb," since Parallels only allows usb access (can I use firewire?).

    The next page is where I get stumped - it asks me for a device URI - what do I use?

    I then assume I use "Raw" for the model/driver, and then "raw/queue(en)" for the model?

    Thanks again for both of your help - like Bob said, there are great people on this site.

    Regards,

    Rich
     
  9. rhsant

    rhsant

    Messages:
    6
    Just a heads up for all those following this thread - sidssp has posted the step-by-step instructions to set up the CUPS workaround - and it seems to work great! See http://forums.parallels.com/thread9900.html

    Rich
     

Share This Page