USB "busy"

Discussion in 'Parallels Desktop for Mac' started by zbolts, Sep 18, 2006.

  1. zbolts

    zbolts

    Messages:
    4
    I'm glad to have a place to share my good annd not so good experiences with people who might be able to help me....


    I wasted most of my Sunday (no football) trying to install new Motorola phone software to my black MacPro. I got the program to load in Parallels. No problem. But when I tried to connect my phone via USB it just didn't work after many, many attempts. Well, I finally figured out it was because I had not selected a default for the USB (autoconnect) on the VM side. No problem I say. So I thought. Now I open the program (Avanquest software) and attempt to sync my phoneto the Mac. It starts to load the program. Then all of a sudden, I get this information window saying "the device I'm trying to use is being hampered by a program already in use with the USB. Try restarting in 5-10 seconds or better yet, go and disconnect the program.'' Well, there is nothing connected to the USB ports. Nothing running except XP! Why I ask? I tried rebooting Parallels and my Mac. I also did a restoring boot..etc.

    I'm in my office this morning and loaded the program to a nasty Dell we have here. We all use Mac, but have had to buy a few PC's for obvious reasons. Verdict, No problem with the software and phone. It connected and works.
    Someone Please help me:confused:

    Thanks in advance,
     
  2. joem

    joem

    Messages:
    1,247
    Parallels will help you when they get full USB passthrough implemented. Between now and then, we will have to use a PC or bootcamp.

    USB improvements have been coming along regularly, but so far full passthrough for USB 2.0 has proved elusive.
     
  3. zbolts

    zbolts

    Messages:
    4
    Thanks

    So there is no solution to getting it to work.
    On the other side. I shouldn't worry about the USB busy message?
    I haven't tried to connect my printer yet.
     
  4. Jerry

    Jerry Bit Poster

    Messages:
    78
    You could try this:

    - open your startup drive window. Go to System/Library/Extensions/
    - in there, find the file named IOUSBFamily.kext
    - right click on that file and choose 'Copy', then right click on the Desktop and click 'Paste'
    This just makes a backup incase something goes wrong.
    - now back to System/Library/Extensions/IOUSBFamily.kext
    - this is not really a file, but a folder with contents. Just right click (or control click) on this file, and choose 'Show package contents'
    - now another window will open with a folder named 'Contents' in it.
    - navigate to Contents/Plugins/
    - inside that folder are the files that you should take out.
    - Move any file with USBCDC in the filename out onto the desktop (I had 8 of them)
    - and that's all. Now just restart, and launch Parallels and enjoy no more 'wait 5-10sec'!

    After doing this, I could load the Moto Phone Tools, connect the V3i, send SMS's via the interface, and even dial or use the V3i as an external modem.

    This is from this thread:

    http://forum.parallels.com/thread3646.html
     
  5. zbolts

    zbolts

    Messages:
    4
    Thanks Jerry!

    I just read you previous post and made a copy of it.
    I just got a Motorola a1200 (ming) phone and I was hoping to get the most out of a crazy $500 inpulse buy in Hong Kong.
    This should get my wife off my back...ha...:rolleyes:
    thanks,
    ron
     
  6. zbolts

    zbolts

    Messages:
    4
    Jerry
    Startup in Parallels right?
    right click is also done by doing control and clicking the pad on my labtop?
    thanks
     
  7. Jerry

    Jerry Bit Poster

    Messages:
    78
    No, you do it all on the Mac side.
    Right click is also control & pad click
     
  8. envycom

    envycom

    Messages:
    13
    has anyone got this to work with a moto q?
     
  9. a_viol

    a_viol

    Messages:
    6
    Please Help!!!
    I followed the instructions of this thread. I removed the files from the IOUSBFamily.kext and backuped them on the desktop. After that I was able to connect to my Motorola V3 in Parallels without any problems, but some days later i recognised that my built in isight cam is not working anymore. When i open photobooth i always get the message that there is no cam connected to the mac or it is used by another program. And the cam isn't recognised by the system profiler.
    I already put the backuped files back to the folder and did a SMC & PRAM reset, without any result. Can anybody help me to find a solution for that problem?
     
  10. Jerry

    Jerry Bit Poster

    Messages:
    78
    Sorry to hear about that. Maybe one (or all) of those USBCDC files are used by iSight - I have a MacMini, so I don't know. Try re-applying the combo updater from Apple. That never hurts, won't break anything, and will probably restore the iSight functionality again. Make sure that those files are back in place though, because I noticed that after doing the 10.4.8 combo updater, the files in the IOUSBFamily.kext folder were also updated, but the missing ones were not replaced.


     

Share This Page