usb flash drive doesn't appear in xp

Discussion in 'Windows Guest OS Discussion' started by ksultan, Sep 6, 2007.

  1. ksultan

    ksultan

    Messages:
    3
    i have the latest version of parallels and xp is guest os,
    using macbookpro
    when i connect flash drive i see it in the bottom right corner of parallel screen at the usb icon,
    it is checked (connected)
    but when i go to windows xp my computer i dont see the drive listed ?
     
  2. sandro

    sandro Parallels Developers

    Messages:
    512
    hi,
    how did you determine that your drive connected into guest OS? Whether did corresponding to your device item from Devices->USB Parallels menu group present and checked sign on it (on the left side of item)? If not you need to select this item in view of attaching device into guest Win XP.
     
  3. ksultan

    ksultan

    Messages:
    3
    the item is checked in parallels devices usb, but i still dont see it in xp
    when i go to my computer,
    devices with removable storage:
    i see : floppy and hard drive but not the flash drive?
     
  4. sandro

    sandro Parallels Developers

    Messages:
    512
    well, what will be happened if you disconnect than connect device with Parallels menu item again (i mean press Devices->USB->your_usb_device item twice)? Will any messages at Win XP occured during these actions?
     
  5. ksultan

    ksultan

    Messages:
    3
    when i click on the usb flash in devices in parallels it disconnects and i see it on the mac, when i click again it disappears from the mac but is still not accessable from Xp,
    i dont know if it is a macbook pro issue , i also have an imac with no problems what so ever
     
  6. sandro

    sandro Parallels Developers

    Messages:
    512
    yes it seems to be so (i mean your suppose about MacBook) because i have Mac mini and can't to reproduce issue that you describing
     
  7. johnv

    johnv Parallels Team Parallels Team

    Messages:
    181
    Hello,

    1. Please check Parallels build. It should be either 3214 or 4560 (5144) (Parallels Desktop menu - About Parallels Desktop). Have you already installed Parallels Tools via the "Actions" menu?
    2. Please click on the start menu and choose "Run...", type devmgmt.msc, click OK. Do you see the disk under the Disk Drives submenu? A screenshot of the window is appreciated (apple+shift+3)

    Best regards,
    John
     
  8. musk

    musk

    Messages:
    18
    I am having the same symptom as ksultan. I'm running 4560. Here's a screenshot:

    [​IMG]

    As you can see, there's a problem with USB. Windows notes that "The drivers for this device are not installed. (Code 28)". I've been wary of changing anything though, because I am currently able to (usually) sync my Treo via USB and that's the one thing that really needs to work.

    Edit: MacBook Pro, OS X v10.4.10, WinXP Pro SP2
     
    Last edited: Sep 12, 2007
  9. JTLaud

    JTLaud

    Messages:
    13
    Often times, I find that Windows doesn't detect the USB drive if it is already connected when you start up Windows. I would have to disconnect the drive and then connect it when Windows is already running so it can detect the drive.
     
  10. jgonder

    jgonder

    Messages:
    3
    flash drives not appearing for several builds now

    I had no problems with USB flash drives until about 2 builds ago - one reason why I bought Parallels in preference to Fusion.

    USB dongles for forensic software (FTK) show up fine, as they always have. Been through all the numbers - many times - and the drive shows as connected on the USB device list - but - no love in my computer. What's up?

    my .o2 for development: I'm more interested in dependability than feature creep.
     
  11. m7792

    m7792

    Messages:
    1
    Hi i just bought a macbook 2.0ghz

    I installed parallels 4568 and am running XP

    I tried to connect my USB jump drive but XP will not read nor detect that there is a drive connected

    I tried going to device manager and enabling usb and it still wont detect it

    I tried to reinstall the usb drivers by putting the XP disc in but it couldnt install the drivers

    what am i doing wrong?
    what should i do?
     
  12. Alicia

    Alicia Parallels Team

    Messages:
    683
    m7792, hello,

    at first try to unplug and plug the device again several times. It it doesn't help, try to do the following:
    1. Start Windows guest OS , go to "Start" -> "Control Panel" -> "System" -> "Device Manager" and uninstall all devices under the "Universal Serial Bus Controllers" (right-click the devices).
    2. Shut down your VM.
    3. In VM Configuration Editor, delete the USB Controller and start Windows guest OS again.
    4. Wait 5-10 minutes until Windows finishes the driver setup.
    5. Shut down Windows.
    6. Add "USB Controller" back to your VM configuration and start Windows again.

    If it doesn't work, please, write me back.

    Best regards,
    Alicia.
     
  13. rizzlo34

    rizzlo34

    Messages:
    1
    Similar Problem

    When I boot up XP, it goes through and says new hardware found, which includes a few items as well as USB. It then pops up a window that says Install New Hardware, and wants me to insert the cd that has the drivers for the USB, but I have no such cd. Do you have any suggestions for getting this to work? Thanks
     
  14. claco

    claco

    Messages:
    13
    Me Three...

    I also had this problem. After installing the parallels tools...I too had the unknown USB controller in the device manager. I simply right-clicked it and select install driver... choose 'install automtically'..let it search..it found the intel usb driver and all is well now.
     
  15. Alicia

    Alicia Parallels Team

    Messages:
    683
    rizzlo34, claco

    have you tried the solutions suggested in this thread?

    Best regards,
    Alicia.
     
  16. VizionQuest

    VizionQuest

    Messages:
    7
    Tried Suggestion, Didn't Work


    I tried this and it didn't work Alicia. Do you have any other suggestions.
     
  17. VizionQuest

    VizionQuest

    Messages:
    7
    my specs

    Oh, and I have the latest build (5160) for Parallels 3. I am using a 4GB SanDisk Micro Cruzer flash drive with U3 technology. Please advise, thank you!
     
  18. VizionQuest

    VizionQuest

    Messages:
    7
    have latest build doesn't work



    I have the latest build (5160) of Parallels 3 and I can't get my 4GB SanDisk Micro Cruzer with U3 technology to even show up on Windows XP. Can you provide a possible solution please? Thank you!
     
  19. Alicia

    Alicia Parallels Team

    Messages:
    683
    Hello,

    VizionQuest, what version of MacOS do you have?

    Best regards,
    Alicia.
     
  20. VizionQuest

    VizionQuest

    Messages:
    7

Share This Page