usb problem

Discussion in 'Windows Guest OS Discussion' started by elsog, Dec 9, 2015.

  1. elsog

    elsog Bit Poster

    Messages:
    6
    Hi
    after the 10.11.2 el capitan upgrade my usb-serial controller don'y work correctly.
    capture device don't work , i must connect and reconnect peripheral

    Have news?

    Thanks
    Elso
     
  2. oztrev

    oztrev Bit Poster

    Messages:
    97
    Which version of Parallels Desktop? 10? 11?
     
  3. AndrewP4

    AndrewP4

    Messages:
    1
    I too have noticed this problem after upgrading to 10.11.2. I spent an hour on the phone with support. First guy not too helpful told me I was using beta software. Second guy seemed to know what he was doing. The problem has been escalated to second tier support. The support ticket number is 2211680.
     
    Last edited: Dec 9, 2015
  4. elsog

    elsog Bit Poster

    Messages:
    6
    Hi
    my version of parallel desktop is 11.1.1 (32312)
    I have the same problem with usb drive , pen ...
    before capture device with parallel desktop , it disappears from the list of device , i need remove and insert the usb device
    Other guy have the same problem , i think need an upgrade of parallels desktop
     
  5. ArjanB

    ArjanB Bit Poster

    Messages:
    5
    This version is not beta anymore, i just upgraded today and experience the same problem. USB is not connected correctly and the device disappears.
     
  6. SteffenF

    SteffenF Bit Poster

    Messages:
    3
    Have the same problem here with different USB-devices (sticks, harddrives) - they are working well under MacOS,
    when I activate them to the virtual machine (Win10) they disappear.
    Parallels 11.1.1 (32312) // El Capitan 10.11.2

    My temp workaround: Settings: USB devices primarily connect to VMs, delete all USB-devices from list under settings, starting first the VM, then connect the device...
     
    Last edited: Dec 10, 2015
  7. TinoB

    TinoB Bit Poster

    Messages:
    10
    Same problem here. usb disappears from list; remove and reinsert do not help in most times.
     
  8. AlfonsoS

    AlfonsoS Bit Poster

    Messages:
    1
    I have the same problem..
    The issue is both on my MacPro and MacBook Pro so it's just not a fluke.
     
  9. Hound1

    Hound1 Bit Poster

    Messages:
    10
    This procedure seems to work for me. Delete any grayed out instances of problem USB devices in Windows Devices and Printers control panel. You might need to restart the print spooler service (administrator login). Shutdown VM. Configure USB Connection Preferences to "Ask me what to do". Delete any permanent assignments for problem devices. Physically disconnect problem devices from Mac. Start VM and login.
    1. Reconnect device to Mac.
    2. When USB connection window opens, hold down ALT key and choose VM.
    3. Open Devices and Printers control panel and verify connection.
    Repeat steps 1, 2, 3 for each device.
    My Problem devices were a Star receipt printer and Ingenico PIN pad device.
     
  10. TinoB

    TinoB Bit Poster

    Messages:
    10
    Until You set the VM into Standby then the usb-device is not recognized. I must put out and put in two times the usb device then it can be used. I use/need an usb-dongle for protected software. The software can not recognize the dongle. I must put out it. Then it do not work. I must put out it again and then after put in it worked until the vm goes into standby.
     
  11. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi, could you please provide the information to investigate the issue faster:1. Do you have connected USB devices directly on Mac or via USB HUB? 2. Is it a USB 2.0 or USB 3.0 device?please create a Problem Report for the virtual machine as described here http://kb.parallels.com/en/9058 and provide us with the Problem Report ID.
     
  12. TinoB

    TinoB Bit Poster

    Messages:
    10
    USB device is directly connected to the MacbookPro. I don't no is it a usb 3.0 device. In System Information the usb device is listed under USB 3.0 bus. I have send a Problem Report. The ID is 83265545. Please note that this usb problem is since El Capitan Update to 10.11.2. Bevor the update no problems like all users have described here in forums in this thread.
     
  13. SteffenF

    SteffenF Bit Poster

    Messages:
    3
    Two older Macs (MBP Later 2011, iMac 27" 2009) with USB 2.0 and the devices plugged directly in.
    The problem occurs, like above, since El Capitan 10.11.2
    ID 83315879
     
    Last edited: Dec 12, 2015
  14. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hi All, Please follow the steps mentioned below to fix the issue USB issue.
    1. Connect USB device to virtual machine and create problem report (Actions > Send Technical Data) and save the ID.
    2. Shut down your virtual machine.
    3. Unplug all possible USB devices from host.
    4. Turn off shared camera, shared Bluetooth, shared printers:
    - Open virtual machine settings ( http://kb.parallels.com/117287 ) > Hardware > USB & Bluetooth > Be sure that Automatic sharing of Web cameras and Bluetooth devices is unchecked.
    5. Go to the Boot Order tab > Boot Flags and type the following flags:
    devices.usb.keyboard=0; devices.usb.mouse=0
    6. Start virtual machine and check how it works.
     
  15. ArjanB

    ArjanB Bit Poster

    Messages:
    5
    This does not help, the USB device still disappears..

    My technical ID is 83403051
     
    Last edited: Dec 13, 2015
  16. auto459811

    auto459811 Bit Poster

    Messages:
    1
    I have the same problem. The solution is disconnect and reconnect the
    I have the exactly same problem. I connect the device, reply if I want to connect to W10. Nothing happens. After I disconnect and reconnect the device is displayed.
    Windows 10: Cumulative Update for Windows 10 Version 1511
    Parallel 11: Version 11.1.1 (32312)
     
  17. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Dear all, we're currently working on it with our Development. Unfortunately we do not have ETA for the fix, it has been prioritized appropriately and you can track the changes in the product at http://kb.parallels.com/123410
     
  18. JonathanN3

    JonathanN3 Bit Poster

    Messages:
    10
    Paul, will this fix be ported down to PD10? This represents basic functionality ....

    PD 10.3.0; OSX 10.11.2 El Capitan; Guest: Windows 8.2 (patched 2016-01-18), USB3.0 driver installed
     
    Last edited: Jan 19, 2016
  19. HennieM

    HennieM Bit Poster

    Messages:
    4
    Hi Paul and Parallels Development team

    I am still struggling with this issue.

    I am following the following process to get my USB Flash Drive to work:
    1. Plug in device
    2. Select virtual machine to connect to VM (Windows 7 and 8.1 - running both on my Mac)
    3. The USB device completely disappears
    4. Unplug device from macbook
    5. Reconnect device to macbook

    I updated this morning to the latest version of Parallels (Version 10.4.0 (29337)), but still not resolved. I have tried all your fixes above, but none work.

    Please advise if this is still being worked on?

    Thanks
    Hennie

    MacBook Pro (Retina, 15-inch, Mid 2015)
    El Capitan 10.11.4
    Parallels Version 10.4.0 (29337)
     
  20. PaulChris@Parallels

    PaulChris@Parallels Product Expert Parallels Support

    Messages:
    3,141
    Hello, please be informed that Parallels Desktop 10 Update 4 (10.4.0-29337) was released and the issue has been addressed. Please update Parallels Desktop to the latest build. Latest version always available here: http://www.parallels.com/directdownload/pd10/ Please note that Parallels Tools also needs to be updated (Actions > Update Parallels Tools) and let us know how it works. Thanks!
     

Share This Page