USB problems in candidate release?

Discussion in 'Parallels Desktop for Mac' started by PhilB, May 21, 2006.

  1. PhilB

    PhilB

    Messages:
    2
    Hello Folks,

    I've been having trouble with USB support - wondered if anyone else hass seem the following problem:

    I've been using some software which requires a USB hardware 'dongle' - for licensing purposes. It's a specialist PC only program and I've been running it fine using the beta4 and beta6 release of parallels (on a Mini Duo 1.66). I upgraded the parallels to the candidtae release yesterday and whenever I connect the USB dongle I get the error "This device is currently already in use... please wait 5 to 10 seconds and reconnnect... if this doesnt work shut down the process acessing the device.." or something similar.

    The problem is that the device isnt being acessed by OSX (no drivers installed) so I have no idea how to kill the process. Could be just my lack of technical experience though.

    I've now 'downgraded' myself to the beta4 release - the only one I had saved - and it works perfectly once more, both with autoconnect and connecting manually. Parallels people: what have you done?? :( :confused:


    Any advice appreciated!

    cheers.
     
  2. joem

    joem

    Messages:
    1,247
    My greatest frultration with this product is the lack of USB simple straight passthrough, coupled with the lack of an explanation of why it's so <expletive> difficult.

    I'd really welcome an explanation, or if, in fact, as I suspect, it isn't that hard, an option to let the guest have total and complete passthrough of selected USB devices (as many as I choose).

    It isn't a virtualization violation or a security risk if I make the choice (or if it is, it's my problem).
     
  3. daveef

    daveef

    Messages:
    24
    I agree fully

    I was hoping to see some improvement in the next release after beta 6. As far as USB support i dont see any difference in this RC.

    My USB creative web cam is not recognised, the USB printer that i share over network is not recognised, and the Delorme earthmate GPS is not recognised. I have prepurchased this program and hope these are features that it will support. If that is not in the plan then i would have ot resort to using bootcamp , which i hate because i have to reboot every time to use the other os.

    I also wish the built in isight in my MacBook Pro would work under the windows. but that doesnt work in bootcamp either so not really something you could take care of.

    I guess i would like to hear from parallels as to whether the USB is going to work , cause if it is not in the works i will quit wasting my time waiting and count the purchase as a donation.

    Not complaining just want to know???

    Also need USB more that worrying about pretty change from osX to windows, that can always be added later
     
  4. Timo547

    Timo547

    Messages:
    1
    Obligatory me too

    I'm having exactly the same issue here. I'm using a USB dongle (the driver refers to it as Keylock 2) for an application. Under the RC I get the '5-10 seconds' message when I connect it, but after downgrading to beta6 all is happy again.
     
  5. staggy1

    staggy1

    Messages:
    10
    I have the same problem upgraded to RC hoping my dongle would be seen, unfortunately not & was wandering if I will ever get to use parralells.
    Very annoying as I only have the one app that needs xp & at the moment have to boot into bootcamp.
     
  6. Traj

    Traj

    Messages:
    24
    I couple of betas back I posted the fact that I was hesitant to pre-order without assurance that USB support would be there. Well, I got flamed for that post.
    I ended up pre-ordering and now that RC is here, still no joy with the USB support.
    My sole purpose for using Windoze is for my GPS via USB. How about some assurances from TPTB?
     
  7. s.cresswell

    s.cresswell

    Messages:
    16
    OUr USB devices are now supported. Which we're thrilled about, and will be ordering a copy of Parallels Desktop
    HOWEVER, I have seen1 blue screen reboot of XP, stating something about USB handling.
     
  8. netdog

    netdog

    Messages:
    117
    I get the same error with my HASP, which worked before.
     
  9. s.cresswell

    s.cresswell

    Messages:
    16
    May have spoken too soon.
    Now getting Blue screen crashes on acquiring the USB device:(
     
  10. ernie

    ernie

    Messages:
    27
    Some USB overservations

    On my Mac Mini when I am running Xubuntu under the Parallels RC2 neither my USB camera in iPhoto or my iPod in iTunes would work last night. Both say there is no device conneced, even though iPhoto did auto launch on pluging in the camera. I quit parallels and all starts working fine.
     

Share This Page