version 4 - copy and paste in VM no longer works

Discussion in 'Installation and Configuration' started by spiffey, Nov 12, 2008.

  1. spiffey

    spiffey

    Messages:
    12
    I have noticed a few threads listing problems with copy and paste; however none of them appears to talk about disabling copy and paste completely within the VM.

    I ran the latest build of Parallels Desktop 4.0 - 3522 and upgraded my existing VM (a fully-patched Windows XP Professional SP3) from version 3. I ran it on a fully-patched Tiger (10.4.11). Machine specs: iMac Core2Duo 2.16Ghz; 2Gb RAM; 10.4.11; 250Gb Hard drive (135Gb+ free space); no BootCamp partition (created purely from VM initially created on Desktop version 2); no beta versions of PD used. Parallels Tools are installed (though they no longer appear to show up under windows like they did in version 3).

    After installation and few hours of tweaks to try and get it working in the same way the old one did (which I discovered was impossible), I tried working on it. Straightaway I found a problem with copy and paste. I was trying to copy the web address from Safari on the Mac and paste it into a Thunderbird email message. It didn't work. I verified that it copied correctly on the Mac by pasting it into a text document - it worked fine. So I trawled all the way through these forums trying to find a similar issue. They suggested checking the Keyboard preferences amongst other things. I tried all of the suggested solutions, but none worked.

    But then I discovered that copying and pasting no longer worked at all under Windows. I copied a web address from Firefox, then tried to paste the same web address into another Firefox tab. It didn't work - no matter how I tried to copy and paste (ctrl-c, cmd-c, right-clicking and selecting copy, and ctrl-v, cmd-v, right-clicking and selecting paste). Nothing worked.

    I reinstalled Parallel Tools - that didn't work. Tweaking every setting under the configuration window didn't work - even with every possible combination.

    I finally discovered that you can copy and paste one item in Windows running in version 4 - after that, it doesn't copy (or paste, or both).

    So ultimately I uninstalled version 4 and reinstalled version 3 (build 5626) - everything works as expected.

    I have to say I was a bit disappointed with version 4. Not only did copy and paste didn't work in Windows (surely this wouldn't be expected to break!), but I found the promised performance increase sadly lacking. I frequently got the spinning rainbow cursor appearing, and the performance was sluggish at best. In fact, version 3 appears quite speedy in comparison to version 4 - it is certainly faster on the tasks that I use it for.

    Also it appears that it is no longer possible to quit PD4 when you shut down the virtual machine. I couldn't find anywhere of specifying this behaviour - is that correct? I tried the 'Close window on shutdown' option, but that wouldn't appear to shut windows down, and the "windows is shutting down' background would remain on the screen, to be progressively removed when new windows were opened, etc. Also if this was checked, PD4 wouldn't quit using the menu bar. In fact, no menu commands would work. The only way to quit it would be to right-click on the dock icon and select 'Quit' from there (which would then quit quite happily - so it didn't appear to have locked up).

    Unfortunately I have been forced to uninstall version 4; until a version of PD 4 appears that works, I'll be sticking with version 3. A great shame.
     
    Last edited: Nov 12, 2008
  2. villox

    villox

    Messages:
    3
    I noticed the same thing

    I had to reboot the VM again to get copy/paste to work. Very strange. Even stranger, CUT/paste still worked even when copy/paste stopped working in the VM.

    Unfortunately I didn't have the space to make a 70GB backup to preserve my V3, so I'm stuck with V4. Very frustrating. And it's definitely slower.
     
  3. unused_user_name

    unused_user_name

    Messages:
    495
    The copy/paste functionality is dependent on having an up-to-date Parallels Tools. You can force an upgrade of the tools by going to "Virtual Machine"->"Install Parallels tools".

    Depending on what OS your VM is running you might have to run the installer manually after clicking this, look for it in the VM's CD drive.
     
  4. KeithT

    KeithT

    Messages:
    5
    Did the upgrade, a full remove of tools then reinstalled many times both via Menu/Virtual Machine/Reinstalled Parallels Tools (was very quick) and via manually going to the image and launching setup once again (took its time and did a complete repair).

    All this to say... the reinstall did not work for me at all.
     
  5. spiffey

    spiffey

    Messages:
    12
    I also reinstalled Parallels Tools by going to Virtual Machine > Install Parallels Tools. The only thing it did was enable me to copy and paste once after a restart. Any time after that it refuses to copy and / or paste - anywhere in Windows (we're not talking about from Mac to Windows or vice versa).
     
  6. DiScO

    DiScO

    Messages:
    5
    Same problem here, just upgraded to V4 :(
     
  7. Isaiah45_2_3

    Isaiah45_2_3

    Messages:
    1
    mine does not copy from mac to parallels XP but from parallels XP to mac it is fine.

    Scenario:
    Mac to XP (no)
    Mac to Mac (yes)
    XP to Mac (yes)

    restarting works but that's not right... must be a bug to fix it on the next release. reinstalling the latest tools didn't work and the only thing seems to be the rebooting.
     
  8. spiffey

    spiffey

    Messages:
    12
    For me it will be:

    Mac to Mac (yes)
    Mac to XP (no)
    XP to Mac (no)
    XP to XP (no – though it will do it once after a restart)

    EDIT: I've sent a problem report through to Parallels - ID is 10448. Whether or not this will come to anything remains to be seen.
     
    Last edited: Nov 13, 2008
  9. davec

    davec

    Messages:
    15
    Same problem here. I can not copy from mac and paste into windows. I am very surprised at Parallels for releasing this buggy version. This needs to be fixed ASAP, along with the "prl_vm_app" chewing up 100% CPU.
     
  10. alurkar

    alurkar

    Messages:
    12
    One more unhappy v4 upgrader.... copy+paste is such a basic functionality.. how can this be so busted!!!! Does anybody have a solution?
     
  11. aaronlyon

    aaronlyon Bit Poster

    Messages:
    10
    Piling on here: Copy from Mac and paste to Windows does not work. In fact, it crashes IE when I try to paste a URL!
     
  12. teknics

    teknics

    Messages:
    19
    tried copy paste on my pd4 setup, everything seems to be fine here, if this helps parallels find the answer.

    I'm running a late '08 macbook pro 2.4ghz with 2gb RAM. cut, copy and paste work every which way.

    kevin.
     
  13. STim

    STim Super Moderator

    Messages:
    942
    Thank you for all inputs.

    The issue will be fixed in nearest update. Which is to be made public within next few days.
     
  14. jmanos3

    jmanos3 Bit Poster

    Messages:
    39
    Copy and Paste between my Mac and a Windows VM is working for me. However, I have only tested it when using a newly created VM in PD4. I have not tested it with an upgraded VM (PD3 to PD4).
     
  15. alurkar

    alurkar

    Messages:
    12
    was this a new VM or a upgraded VM? I upgraded from Parallels 3 to 4 and copy paste went *poof* GRRR
     
  16. alurkar

    alurkar

    Messages:
    12
    Can you suggest a workaround while this gets resolved? not having copy paste just kills productivity
     
  17. STim

    STim Super Moderator

    Messages:
    942
    If you work in Coherence, switch to Windowed mode.

    If this doesn't help, try reinstalling Parallels Tools.
     
    Last edited: Nov 18, 2008
  18. alurkar

    alurkar

    Messages:
    12
    I am in Windowed mode and have already tried re-installing Parallels Tools, but that did not help.
     
  19. spiffey

    spiffey

    Messages:
    12
    Incidentally, I thought I'd have another go and installing Parallels 4. After the installation process completed, I tried to resolve the copy and paste issue.

    I managed to get the copy and paste working from XP to XP, buy turning off an XP utility called Flashpaste Lite. I use it to store oft-typed text strings as a means of increasing productivity. By turning this off, I managed to get the copy and paste functionality back.

    However, Mac to XP or XP to Mac didn't work. What's worse is that copying and pasting from Mac to XP completely disables copying and pasting within XP, even with Flashpaste off, and even after several successful copy and pastes beforehand. This manifests itself by locking up the programs that were being copied into; the only solution is to force quit the affected windows programs.

    Lastly, copying from XP to Mac still doesn't work - even though clipboard is shared in the preferences.

    At a push I could do without Flashpaste. However, I need to be able to copy from and to the Mac, so I once again have moved back to version 3.

    That's good to hear. I'll give it a try when it's released …
     
    Last edited: Nov 20, 2008
  20. alurkar

    alurkar

    Messages:
    12
    I created a ticket #622199 about copy paste not working in build 3522 and was told to upgrade to 3540 and that did not help much at all.. post upgrade copy paste from virtual to host machine worked one time(or maybe i was dreaming) but has since stopped working, I cannot even get copy paste within the virtual machine to work anymore!!! this is extremely frustrating, very very close to switching to vmware when will QA/testing be part of a release process @ Parallels.

    So if you are considering upgrading to 3540 to get a fix for copy paste... I would try not put any money on it.
     

Share This Page