Video resolution change upon full-screen activation

Discussion in 'Parallels Desktop for Mac' started by Ricochet, May 9, 2006.

  1. Ricochet

    Ricochet

    Messages:
    12
    When switching from windowed mode to full-screen mode, currently Parallels will keep the same resolution. Generally when running the VM in a window, you will choose a compatible resolution which is lower than your main screen resolution to allow you to see the entire window, but when switching to full-screen mode I would assume that everybody would like it to change to the native resolution which OSX uses. What is really required is a "windowed" resolution setting, and then the "full-screen" resolution should be assumed to be whatever OSX is currently running at.

    This would also (I believe) help minimise the annoying black screen flicker when switching between windowed and fullscreen modes whilst the monitor/laptop screen changes its resolution. Certainly the black flicker is far less pronounced if i run Parallels in a window at the native resolution of the monitor or laptop screen.

    Any chance of building this type of functionality in to either Parallels itself or the parallel tools within the target OS? A single button/keystroke which would change the windowed resolution to the native OSX res, then switch to fullscreen would be brilliant. Then switching back I guess it should flick back to parallels windowed mode and then change the res back to the "windowed" resolution setting to make it fit comfortably on the screen again. I'm sure you may be able to do this already with a keystroke macro or similar, but an elegant solution within the parallels framework would be great.

    Great product, looking more and more polished as the betas roll in. I've already pre-ordered the final version and can't wait to see how it ends up. Cheers
     
  2. Olivier

    Olivier Kilo Poster

    Messages:
    610
    This is already available. Visit Preferences, User Interface and *uncheck* "Change Mac OS X resolution".
     
  3. Ricochet

    Ricochet

    Messages:
    12
    Thankyou Oliver - I hadn't stumbled across that setting, I'll try that and see how it goes :)
     
  4. ranjeetsodhi

    ranjeetsodhi

    Messages:
    5
    That option simply allows you to switch from full screen mode back to windowed mode - the resolution for both the modes remails the same.

    Is there some way to have Parallels automatically go to the maximum system resolution when switching to full screen mode???
     
  5. Olivier

    Olivier Kilo Poster

    Messages:
    610
    I fear you're wrong about this.
    It works as designed for me. Why wouldn't it work for you?
     
  6. Ricochet

    Ricochet

    Messages:
    12
    Hmm I enabled this setting and the first time it didn't work (i got the VM session displayed in fullscreen but it was the same resolution with a black box surrounding it).

    I disabled the setting and did a fullscreen switch, then re-enabled it and then it seemed to work as I had hoped. I will test it a little more to make sure - it seems a little weird that it worked one time and not the other.

    ranjeetsodhi - I suggest you try doing that as well, it may work for you too.

    One thing to note is that if you are using fullscreen and you restart the VM (in my case it's windows XP so i go start -> shutdown) then it will switch back to a window when it gets back to the VM bios, but when windows loads it will display in a window at the full resolution (ie. the window is too large for the screen) and you have to change it back manually. Perhaps a check on startup to change back to a "windowed" resolution if it is in windowed mode?

    Cheers
     
    Last edited: May 10, 2006
  7. Olivier

    Olivier Kilo Poster

    Messages:
    610
    Strange it tooks such steps to work for you.
    What guest OS are you running ?
    If Parallels Tools are available for your guest OS, did you take care of re-installing them since last upgrade to Beta 6? I understand it is required for the guest automatic resizing at the host resolution.
     

Share This Page