Vista VM crashes and reboots after idle time + other glitches post 5160

Discussion in 'Windows Virtual Machine' started by mprussell, Sep 14, 2007.

  1. mprussell

    mprussell Bit poster

    The guts of this post were added to another thread, but the problem has persisted so I thought I'd start a dedicated thread for it.

    * * *

    I upgraded to 5160 yesterday and since then I've had a couple of problems. I have two VMs running on my nearly new Mac Pro with 5Gb RAM, a Vista installation and Debian Linux.

    The first problem seems to have sorted itself out. After the upgrade the Linux VM had real problems starting. Running Parallels seemed not pause at the configuration screen and would attempt to boot Linux without my asking. It also added a series of "1"s to the name of the VM. Not sure why. It did the same on my Vista VM too and I had to edit the name by deleting the "1"s when things had stabilised. For example the Linux VM was suddenly called "Debian Linux 1 1 1 1 1 1 1 1". A hard reboot of the Mac Pro (a rarity for me and a reluctance) appears to have sorted these issues out.

    The other one continues and seems to affect the Vista VM only. Six or so times now I've left the VM running and the mac has idled for a period of time (more than 15 minutes, less than three hours). I'll come back and Vista will be displaying the login box. It is rebooting itself after a BSOD. After logging back in I get a message about a bad boot saying - 'Problem description: Blue screen.'

    Now, I don't really know much about Windows as I've been Mac only for years now. Usually though, if the Vista VM crashes or is just turned off it will display a Safe Mode boot option screen on restarting. Obviously if I'm seeing the login screen it's bypassing that (or timing out and booting the default?). Maybe it's behaving like the Mac 'reboot after power failure' option?

    Whatever is happening, extended idle time is causing Windows to crash and restart. Other than at idle time the VM seems to run well in all modes and there are no other issues apparent at the moment. I have tested and the crash/reboot happens if Mac power settings are set to screen off after x minutes or screen off never.

    I've tested sending the mac to full 'sleep' with the VM running Vista and Linux and both restore ok on waking up. This reboot problem only happens when the machine sits idle, not when the Mac is sleeping. Sometimes, but not every time, returning to wake the screen up will see the Vista VM 'paused' and a Parallels message asking if I want to un-pause it. When this has happened I myself haven't paused the VM.

    My VM files are in the default location within my home directory 'Documents' folder. This happens to be on a second HDD in the machine which does seem to spin down despite the OS X Power Saving preference pane being set not to 'Power down hard disks where possible'. Is it possible to relocate my Parralels folder and point the app to the new location?

    One thing I changed after the 5160 upgrade was increasing the Windows VM memory allocation to the max 2Gb. I may switch that back to 1.5Gb and see if it stabilises.

    Any ideas or similar stories much appreciated.


    My machine is a 2x 2.66 Dual-Core Mac pro with 5Gb RAM.
    It's running a fully up-to-date Tiger 10.4.10.
  2. mprussell

    mprussell Bit poster

    Ok, having found a preference for the VM file location I've moved my Parallels directory to my main volume, which I think doesn't spin down, to see if this makes a difference.

    I shall report back.

    * * *

    After moving the directory and changing the path in Parallels preferences the app when launched directly didn't recognise the new path. Worse: on running the app you can't access the prefs unless there is a VM installed. This is a bit frustrating. The app quits immediately if you don't wish to install a VM!

    I can obviously launch the VM's .pvs file, so I'm not stuck but this is a problem. The Parallels prefs has the correct path, I checked.
  3. jasonwoodz

    jasonwoodz Bit poster

    I'm experiencing the same problem on my IMac. Can anyone help?
  4. Hugh Watkins

    Hugh Watkins Forum Maven

    suggest VM work best on an external drive

    FW 800 La Cie just restarts as needed if powered down

    do make certain you have plenty of freespace on the VM virtual hard disk and the real ones
    at least 20% empty is good

    Hugh W
  5. mprussell

    mprussell Bit poster

    Ok, I think I have it. I was holding off replying to this thread to see if things stabilise.

    I did two things, but I think only No. 1 is what matters. No 2 is quite a handy tip for general Mac disk spin-down issues.

    1. Power Management.

    I was thinking along the right lines, but the wrong way round. It isn't the Mac Power Saving setting that upsets my Vista VM, it's the Vista ones. I found out that if I manually sleep Vista it dies in the VM immediately.

    So, in Vista go to Start > Control Panel > System & Maintenance > Power Options

    Select 'High Performance' and make sure the 'plan settings' are set to 'Never' and 'Never', then save. Now Vista doesn't hang and reboot during idle time. I have tested it now about five times.

    My Mac Power saving settings are as they always were: Screen off after 15 mins and Sleep after three hours.

    2. Preventing disk spin-down.

    After moving my Parallels folder and redirecting the preferences to the new location I set up a cron job to 'tickle' the volume every five minutes. Like so ...

    My crontab now has the following events ('Chim' being my second volume):

    # Prevent Chim spinning down
    */5 * * * * ls /Volumes/Chim > /dev/null
    */5 * * * * ls / > /dev/null

    Neither volume, my boot volume or the second one, now spin down. And an ls every 5 minutes isn't too system hungry. This has solved another issue I had too, but that's a bonus!
  6. rw712

    rw712 Bit poster

    I'm having the same issue with the reboot. I also just reset my power options in Vista and will see how that goes. The other oddity I noticed was I had check th eParallels option to keep my VM time synchronized with my Mac. That led to a sub-second time adjustment every minute and a note in the event log every time. I turned off the time synchronization option in Parallels. I'm hoping tomorrow I wake to a screen other than a login.
  7. mprussell

    mprussell Bit poster

    Six days later and I can confirm all is happy. My Vista VM is now very stable. It sleeps when the Mac sleeps and wakes when it wakes.

    It might be a nice idea if the Parallels Tools installation switched the Windows Power Saving settings to never sleep, if that's possible. Parallels developers, you listening ...?

Share This Page