VM Encryption not asking for Password on Boot

Discussion in 'Installation and Configuration in Windows and Linux' started by Heathy65, Dec 15, 2011.

  1. Heathy65

    Heathy65 Bit Poster

    Messages:
    11
    I have Parallels Desktop running on my MacBook Pro with a Windows 7 VM.

    Recently I have encrypted the whole VM (using the Configuration / Options / Security / Encryption setting).

    The encryption completed OK and the VM is fine but just prior to performing the encryption there is a warning message which says (something like) "remember this password since you'll need it every time you start this VM".

    My confusion is that I never get asked to enter any password when starting (or resuming) this encrypted VM.

    Also how can I confirm that the VM is actually encrypted?
     
  2. Heathy65

    Heathy65 Bit Poster

    Messages:
    11
    Does anyone have any thoughts on this.

    I can't seem to work out what's going on....

    Sometimes when I shutdown my W7 VM I can see a padlock as its icon in the "Parallels Virtual Machine" list and then when I start the machine it does ask for a password.

    But more often than not this doesn't happen and I can start the VM without any password challenge!
     
  3. Heathy65

    Heathy65 Bit Poster

    Messages:
    11
    I think I'm talking to myself here :)

    Anyway it seems that I need to actually exit the Parallels application itself and restart it to force a password challenge when starting an encrypted VM....

    Is this the expected/designed modus-operandi?
     
  4. Heathy65

    Heathy65 Bit Poster

    Messages:
    11
    I've done further testing and unless I actually quit the Parallels application itself and then restart it, there's no prompt to gain access to a password protected / encrypted VM...

    Does anyone know whether this is correct operation?
     
  5. jaylindell@comcast.net

    jaylindell@comcast.net Bit Poster

    Messages:
    22
    Encryption behavior

    You should be password prompted every time you open your encrypted VM. Once it is up and running, no password prompts will appear. After yo shut down or suspend, the next time you try to access the VM, you'll be pw prompted.

    MY problem is I want to turn encryption off...Parallels crashes each time.
     

Share This Page