Warning: Kensington Mouseworks

Discussion in 'Parallels Desktop for Mac' started by LCPGUY, Mar 25, 2007.

  1. LCPGUY

    LCPGUY

    Messages:
    49
    This does not work under Parallels. If you try to install MouseWorks 6.11 or 6.22 you will have BIG problems. I have a Kengsington Expert Mouse (trackball), and it works fine when using the standard Parallels driver, albeit no additional features.

    I downloaded the Kensington software, tried to install it, and "lights out!" Goodnight Irene!!! NO MORE MOUSE!!! Fortunately, I had a backup of my Mac HD on an external, so I could restore my Parallels from there. I tried again, and once again, no go!!! A totally non-responsive XP.

    I don't know if this is a Kensington problem or not. But it works just fine in Bootcamp.

    Anyone else here experience this?
     
  2. veggiedude

    veggiedude

    Messages:
    100
    Yes, this happened to me about 6 months ago.
     
  3. wesley

    wesley

    Messages:
    396
    In the VM, your mouse is 'virtualized', i.e. it's not really your Kensington mouse in there, but something that's passed through OS X once before and put out as a 'generic' mouse that's fit for VM to control with. Same with the keyboard. These are not treated like the other regular USB devices.

    Therefore there is no point in attempting to install a mouse driver inside the VM - the driver cannot access the mouse natively. It'll likely interfere with VM's intended interfacing with the mouse, anyway, and sure enough, you saw this manifest.

    Of course in BootCamp your mouse is indeed accessed natively, so the driver would work. It's a completely different situation, and this isn't really a Parallels' bug. It's just how virtualization works.
     
  4. ben

    ben

    Messages:
    3
    Kensington expert mouse buttons

    Here's how to get the control-click working on an Expert Mouse using Mouseworks in OSX:
    Set up the button (I'm using the lower right one) to "Right-click" in Mouseworks (NOT Control-click!). That did the trick... only my scroll wheel still doesn't work. Oh well.
     
    Last edited: Jul 14, 2007

Share This Page