"Warning: Your video adapter's (Direct3D HAL) driver is outdated (6.14.1.1282)"

Discussion in 'Windows Guest OS Discussion' started by neu242, Jun 1, 2008.

  1. neu242

    neu242

    Messages:
    4
    I just upgraded from Parallels 2.5 to 3.0 just to play Trackmania Nations Forever from within Parallels. It looks like I should have saved my money.

    Trackmania runs, but the frame rate is horrible -- even if I set the display resolution to 800x600. Trackmania warns that "Your video adapter's (Direct3D HAL) driver is outdated (6.14.1.1282). The performance of the game will increase with driver version 6.14.10.6360 (or more recent)."

    The frame rate is great when I run the game from the same partition/installation within Boot Camp.

    My setup:
    - Macbook Pro with 2.0Ghz CPU and 2GB RAM
    - ATI Radeon X1600 with 128MB video RAM
    - Leopard 10.5.3
    - Parallels Desktop 3.0 5600 with 64MB video ram and DirectX shading enabled
    - Windows XP SP3 on a Boot Camp partition
     
    Last edited: Jun 1, 2008
  2. maztec

    maztec

    Messages:
    60
    Have you updated the drivers? :\

    Also, when you updated Parallels - did you install the latest Parallels Tools?
     
  3. Specimen

    Specimen Product Expert

    Messages:
    3,244
    Did you uninstall 2.5 before installing 3.0?

    You SHOULD uninstall Parallels 2.5 and Parallels Tools 2.5 from the guest machine before installing 3.0 on both.
     
    Last edited: Jun 2, 2008
  4. neu242

    neu242

    Messages:
    4
    Aha! I didn't realize that I had to reinstall Parallels Tools (which includes the display drivers) when I upgraded Parallels. I did that now, and the frame rate is better (but not very good). Thanks for the tip!

    I didn't uninstall 2.5 before upgrading. It was a fairly fresh 2.5 install, though.
     
  5. Specimen

    Specimen Product Expert

    Messages:
    3,244
    Parallels recommends you uninstall 2.5 before installing 3.0, it has, of course, nothing to do with the freshness of the install.
     
  6. neu242

    neu242

    Messages:
    4
    I'm sure they do, but they're just not very articulate about it: http://kb.parallels.com/en/5015
     
  7. Specimen

    Specimen Product Expert

    Messages:
    3,244
    Is this a bit more articulated?

    In pratical terms that means you shouldn't install 3 build 5600 over 2.5 directly.
    It's obvious to me that version 3 operates in a significantly different form from 2.5 to require such a warning.


    So, what's the safest thing to do? Unistall 2.5 (ditto for Parallels Tools too), you seem reluctant to do so but that's your loss and that isn't my problem so I won't insist anymore.
     
    Last edited: Jun 3, 2008
  8. neu242

    neu242

    Messages:
    4
    Not really, I read that message as well. It never says anything about uninstalling and reinstalling. It says:

    1. Upgrade to 3.0 (For me, that is using the 2.5-3.0 DMG that I bought, which was something like v.5585)
    2. Install the v.5600 upgrade

    Anyway, thanks for the help :)
     
    Last edited: Jun 3, 2008

Share This Page