What USB devices work?

Discussion in 'Parallels Desktop for Mac' started by pwmacnewbie, May 5, 2006.

  1. pwmacnewbie


    Hi. Could someone please provide a list.

    In particular, has anyone tried USB MIDI controllers/ keyboards?

  2. bbf

    bbf Bit Poster

    I don't know how applicable this is to most people, but I tested a CCS ICD-U40 USB PIC microprocessor programmer/in-circuit debugger last night, and it seems to work fine, as does the CCS PIC C compiler, so I don't need a PC anymore for microcontroller development!
  3. agrj



    good to know!!! I'm trying to use the ICD2 from microchip, but without success. have you tried this device?

    I already have a ICD from CCS, and I will try it right way.


  4. dan_ee


    This thread looks like it's heading down the embedded development route, so...

    Tech-Tools Digi-View DV1-100 logic analyser is sometimes recognised, sometimes not. Appears to connect to software, but after triggering the s/w crashes. This is using WinXP on PWbeta6, MacMini core duo.

    I'd also like to hear if anyone has success with the ICD2, or any universal USB programmer such as the xeltek. And if USB support improves greatly, I'd like to try the Rowley CrossFire LM3102 eval kit...

  5. planetkingdom


    What USB Devices Work

    USB printer scanner (HP V40xi) is detected and drivers install without problems and device shows up on the USB panel. However, HP software cannot detect the equipment either as a scanner or as a printer.

    I've been able to install a wireless webcam (Linksys WVC54GC) and the windows only software works very well. Viewer shows video smoothly under XP. Recording utility works as programmed and makes recordings as scheduled.

    I am running Beta 6 with WinXP Pro on a mac intel mini and so far it has been stable after 48 hours of uptime.
  6. Andrew @ Parallels

    Andrew @ Parallels Parallels Developers

    USB printers support are already fixed (most likely). Wait for the next public build please.
  7. macrod


    FYI: Tried to get USB JTAGs working for Altera's NiosII environment and Freescale's HC12 (P&E Multilink), but not successful. I also tried to get my Blackberry 8700c working, but this is failing as well. The interesting thing is that the guest Windows machine detects all the above listed devices and allows me to install the drivers, but when I exercise them, they don't work.

    Can't wait to get rid of my Windows box! Looking forward to the next beta to checkout [better] USB support...
  8. e7sharp9


    Edirol UM-1 USB-Midi interface does not work. Diver won't install. VM finds the device but the driver just refuses to install.
  9. Ricochet


    I'd be suprised if you could get a decent latency with the midi controller having to go via an emulated usb port, but I'll happily be proved wrong if I can get mine working. So far it's boot camp for anything more than basic winamp listening audiowise for me.
  10. e7sharp9


    What would be cool is if Parallels could plug into the IAC on the mac so that Midi devices could be driven from the mac interface drivers rather than from the PC.
  11. agrj


    Just an Update. RC version and still ICD2 from microchip don't work. I still get the 5-10 seconds to wait message. Please, this is the main reason I have bought the PW!!! I need to use it in my work!!!

    any idea when it will be fixed?
  12. joem


    USB Question

    I don't get it. What on earth is so difficult about connecting a USB device to a VM. It seems it ought to work like this:

    Data comes in from a USB device.
    If this is one of the devices captured by the VM, send the bits to the VM else send them to the host OS.

    Data sent to a USB device by guest.
    If this is one of the devices captured by the VM, send the bits to the USB device else fail.

    And of course, there shouldn't be a limit on how many USB devices can be captured by the VM.

    Why isn't it this simple? I've written plenty of device drivers (and other OS code) (but not USB drivers) and I've never seen a device where this sort of logic wouldn't work.

    I'd love to see an answer from the Parallels team, or someone else who knows. It bugs my small mind.
  13. n4khq


    Microsoft is still trying to figure out how to upgrade VPC. I would think because of trying to share USB between two OS, there are major issues. VPC would only work if the OS X could talk to the USB device. Parallels is already better than VPC. I believe thay are not trying to share or mount the device on the VM and OS X at the same time. This seems to be a better approach than what VPC was using.
    Last edited: May 19, 2006
  14. miketichon


    I totally disagree! I have the release candidate and cannot get my usb printer to work. I have used the mfg's instructions and Parallels instructions. My HP officejet 6110 shows up, but there is no way it will print. BTW, the instructions in the readme file are too vague for a normal person to understand. You should give examples of what you mean by using a network connection. Since the printer is not connected to a network, but directly to the iMac, how do you connect it in a way that works. Also, the file sharing doesn't work. The vm crashes. File sharing and printing are critical uses for Parallels, at least in my view. For example, I like to use Qimage for printing pictures. How am I supposed to get pictures into the vm and then, how do I print?
    Not a happy camper.
    Mike Tichon
  15. rcomeau


    It would be a better approach if it works. From the sound of it, there is work yet to be done.

    Last edited: May 19, 2006
  16. staggy1



    Just upgraded to RC hoping I would now be able to run the only app I need X.P. for & still will not recognise my u.s.b dongle.
    Looks like Iam still going to have to keep reebooting into bootcamp which works fine.

    Any ideas why still not seeing the dongle.:confused:
  17. snit


    CardScan scanner does not work.
  18. snit


    To be more clear wrt. CardScan, it works for a few scans, then BSOD's the computer, and then the device will not work until I re-install.
  19. rcomeau


    I just tried a USB-Serial adapter Keyspan USA-19HS and it has the same problem as in the alphas, oops, betas. When I run the "Serial assistant" software, it recognizes the device for about 1 second, then dissapears. At that instant Parallels gives an error message that the device is in use and to try again in a few seconds. A couple of seconds later, the device gets recognized again for a second and then goes away again. This cycle repeats as long as the device is plugged in. The Parallel error windows also pile up on one another, rather than just update.

    As the only reason I need Windows is to communicate with a piece of equipment, I need USB fixed or the serial port implementation improved to support using "real" Mac serial ports (which gets created by the USB-Serial adapter on the Mac side). This is what I had using VirtualPC.

    If this RC becomes the actual release, I'll unfortunately be looking for a refund because despite the elegance of the virtual machine over botcamp and the promising work by Parallels, it will not have lived up to its promise and I cannot use it.


  20. turbogeek


    I am trying an Orion Starshoot USB camera and it claims the device is already in use. I disconnected and waited with no result. Also tried reboot and pause as well as doing so with it connected before and after boot or resume from pause.

Share This Page