Why is bootcamp STILL greyed out? Why is it still called 'bootcamp'?

Discussion in 'Parallels Desktop for Mac' started by anomaly256, Jan 11, 2007.

  1. anomaly256

    anomaly256

    Messages:
    27
    Why is the option to use bootcamp STILL greyed out? Why are you guys still calling it bootcamp instead of a more generic and confidence inspiring name like 'physical partition support'? _DO_ you _ever_ intend for this to work with GENERIC hard drive partitions such as linux on ext2 or will you insist on letting people ONLY use XP and ONLY via bootcamp? I need to know the answers to these questions before I ever let go of my $.

    As I've stated in other posts that appear to have gone largely un-noticed by the staff, restricting this sort of feature to ONLY activate via bootcamp really is needlessly crippling the product when it could do so much more if you apply some common sense to it's methods. Do you want to produce a good product? Or a fantastic product? If this is the sort of policy implemented in it's management and design, I'm fairly certain it'll never quite be the completely awsome product it has the potential to be. Good maybe, but definately not fantastic.

    ps: OSX sees all my partitions and presents them as /dev/disk*. Why don't you see them?
     
  2. dkp

    dkp

    Messages:
    1,367
    It's called bootcamp because that is Apple's name for it. Any limitations of bootcamp are from Apple as it's their product. The Parallels team has worked to integrate Parallels with bootcamp to simplify the Windows experience in OS X.
     
  3. alessandrobo

    alessandrobo

    Messages:
    5
    Dkp,

    Right, it's called bootcamp because bootcamp is the name that Apple has given to it. It may change in future. But the problem that the poster above is mentioning is that it seems very limiting to allow access only to "kosher" bootcamp install.
    Many people - more technically savy than the average user probably - have learned how to create muliple partitions using diskutil, have installed other oses etc, and would be very happy to be able to run any os installed on their hardrive, from any partition.
    Again, being technically savy, we could even be happy without a GUI support, actually I would suggest parallels to leave that as an undocumented, unsupported feature, to avoid to deal with less savy users who mount the OS X partition and install windows on it...

    Thanks
    Alessandro
     
  4. anomaly256

    anomaly256

    Messages:
    27
    Exactly. It's unecessarily limiting. Allowing direct access to physical partitions would be much simpler to implement while being incredibly more versatile. I understand they want to keep the 'follow the bouncing ball' routine straight forward for those users who need their hands held (and lets face it thats most of them), but surely this should sit ontop of the partition access code, not under it.

    Specially when using it's current methods it won't let me boot an xp partition on the hard drive -at all-, bootcamp or direct or whatever, and I _know_ they're perfectly valid perfectly fine partitions, one of which even happens to be xp installed via bootcamp... gee it would sure be nice to tell the program what I want, instead of it telling me how it's gonna be...


    tip to the developers: maybe using 'gpt' would be better for verifying an xp partition than relying on whatever bootcamp mechanism you currently use? And if 'gpt' happens to be what you do use behind the scenes, why all the false negitives here? 'gpt' seems to love my gpt+mbr setup.
     
    Last edited: Jan 11, 2007
  5. vineetb

    vineetb

    Messages:
    6
    early adopters facing this issue

    it seems like early adopters are facing this issue. ppl who are starting fresh with bootcamp seem to be able to use it in parallels. is that correct? what do u mean by "kosher" install? whats the process involved to get it working?
     
  6. anomaly256

    anomaly256

    Messages:
    27
    I've managed to resolve the issue myself somewhat after -alot- of trickery. It seems the problem (or my instance of it at least) stems from the fact that, rather stupidly, Intel have specified that Linux partitions get the same GUID in the GPT as XP partitions. The fun part is changing the GUID without losing the said linux partition. I managed to fix this by booting the OSX install dvd, starting a terminal, unmounting all the hard drive partitions, killing the installer and diskarbitrationd daemon (to prevent remounts of the hdd, the gpt tool doesn't like editing mounted partitions, naturally), using gpt to remove the linux partition entry from the table altogether, then use gpt again to add a partition starting at the same sector, with the same size and same index as the old linux partition, but changing the partition type to anything other than 'windows' or 'linux'. In the end I chose to use the 'linux reserved' guid: 8DA63339-0007-60C0-C436-083AC8230908. Now parallels won't complain about multiple bootcamp partitions. (do not try at home, and if you do, don't come running to me when everything stops working)

    But, this was only half my problem. The MBR that exists in the hybrid setup also needs to be altered. EFI says this should contain a single cover-all unknown-type partition entry to prevent overwriting gpt tables, and that a gpt entry should have the 'mbr partition' guid to specify that it be treated as a hard drive in it's own right with it's own mbr at the start of the partition. Apple with their bootcamp assistant violate this specification slightly in that the protective 'unknown-type' partition in the mbr covers just the gpt header+table and the efi system partition, treating xp as a normal mbr partition listed in the mbr. This would be fine except all the /other/ setups out there expect either the full-blocked efi hybrid with individual mbr, _or_ the full-standard mbr without any consideration for efi, and so they tend to leave the efi system partition listed in the mbr as a hidden-type fat32 and thus ending up with a normal run of the mill mbr. rEFIt's gptsync.efi utility will correct this and replace the gpt header+table + efi system partition as a single unknown in the mbr as per the apple way that bootcamp does when used alone and as parallels expects. In the end parted under linux and alot of dd use were also called for to get things straight (I had to restore the gpt portion from the backup at the end of the disk to get started)

    This is however not something one can undertake on their own without extensive knowledge of the inner workings of their computers.

    And again, I don't feel that this is a necessary hurdle to cross with some very minor changes to how parallels tries to access partitions. (Does it even -need- to know what the gpt is if the partitions are already presented in the devfs?)



    ps: If you are reading this expecting to fix your greyed out bootcamp problem, and none of what I said above makes sense, then it's of no help to you anyway. Don't go playing with rewriting mbr's unless you're prepared to take full responsability for losing everything on your hard drive, specially the part that mentions dropping an entry from the gpt then re-adding it)
     
    Last edited: Jan 11, 2007
  7. g2k3000_3000

    g2k3000_3000

    Messages:
    1
    The reason why some many people are getting the bootcamp option greyed out is because they have formated or deleted the 200MB EFI partition that was created when Bootcamp was first installed on the system.

    I had the very same problem when I first tried this and the way I fixed it was to restore my hard drive back to a single partition and then re-partition the drive again. This time I didn't touch that 200MB partition when I was installing Windows XP. After that, the Bootcamp option was not greyed out anymore and I am now having a blast with Parallels 3120. I just love the coherence mode!

    Please note that for some reason, Windows XP will not install and you will end up with a error message if you install Windows on a Mac with more than 2 partitions to start with. I guess this is why so many people, including myself had deleted that 200MB EFI partition so that we could create another partition to use as a swap or backup. Unfortunately, this will cause a lot of greif when trying to use the bootcamp option in Parallels.... Just a heads up for people that did not already know about this issue...

    Hope this helps. Peace!
     
  8. anomaly256

    anomaly256

    Messages:
    27
    g2k3000_3000: NO. Not quite right sorry,

    As I stated in the previous post, it's not due to this partition being formatted or deleted so much as it was still very present on my system (I even use it to boot my custom efi apps from), it was because of how the MBR was structured relating to this partition and to the 'unknown' section before it containing the GPT tables, and how EFI rather fricken stupidly defines linux and windows partitions with the same GUID. It is possible to overcome this -without- reformatting if you just use a partition editor like Ranish Partition Manager (for dos) to create a faked entry overlapping this section and the efi partition marking it as type 'EE', and by altering the partition type listed for the extra partition using 'gpt'. Please read my previous post to understand the how and why of this.

    Also this is not an issue caused by having more partitions visible than the osx and xp partitions, again I have 3 not 2. 4 if you count the efi part. I know it sounds confusing for most people but I did explain this in the previous post, and I now have bootcamp support working in parallels WITHOUT reformatting and WITHOUT cutting down the partition count. It's just real screwy to get right for novices... (and again I feel this shouldn't even be an issue if Parallels would be kind enough to move away from bootcamp specific partition support and towards a more generic and therefore more _useful_ approach)
     
    Last edited: Jan 12, 2007

Share This Page