Why isn't the HAL.DLL / NTOSKRNL.EXE error in the Knowledge Base?

Discussion in 'Windows Guest OS Discussion' started by frankie, Jun 18, 2007.

  1. frankie


    This is driving me batty. I need Parallels (preferably 3) to work smoothly with BootCamp; I don't have room on my MBP's little drive for two separate Windows installs.

    I've been using Parallels for about a week now, and tonight is the 3rd time it's jammed up and wrecked my system32 files. I've tried using Windows recovery console without success, so it looks like I'm facing yet another complete reinstall from SP2 on up, all 75+ windows updates and a dozen apps.

    Thanks to MacFUSE and NTFS-3g I have write access to my Windows partition from OS X, so if there is any alternative fix available I have the ability to try it. Unfortunately, I don't have the knowledge base to accomplish such a task.
  2. nathanhand


    You don't need to reinstall. Boot Windows XP under Parallels and then shut it down cleanly. It will boot properly in Boot Camp again.
  3. frankie


    Ah, now there's something that ought to be in the documentation.

    Unfortunately it doesn't help me. Parallels is also giving me the dreaded "can't open disk image Boot Camp" error. Which also isn't listed in the support site.
  4. nathanhand


    I've found rebooting the Mac often fixes that problem. You also need to enter your password when prompted, or the username/password of an administrator if your account doesn't have admin privileges.
  5. frankie


    Thanks for the suggestion. It didn't work for me though.

    I'm creating a new SP2 installer CD with nLite, adding a couple 3rd party tools, see if that helps.
  6. mindtrip


    Stuck with frankie

    This is *bs*. I ran Parallels 2 for a long, long time without any problems. NOW, however, I'm fragged after running Parallels 3 for two weeks. I too got the 'hal.dll' error, but was able to get back into Parallels by uninstalling/reinstalling Parallels 3. BUT I can't boot into my BootCamp partition anymore; I've tried editing the Boot.ini inside Parallels, but every time I reboot the machine into the BootCamp partition, I get a configurator asking me to pick between Windows XP and the Parallels configuration. Since a) the Parallels configuration is first on the list, it's default, and b) my keyboard doesn't work (MacBook) until windows boots, so I can't pick the Windows XP selection. I've tried plugging in a USB keyboard to try picking the XP selection, but this is not recognized either, and the machine hangs at the 'hal.dll' error.

    Parallels tech support needs to be addressing this problem ASAP. Looks like I'm reinstalling my bootcamp partition and going back to Parallels 2 until they fix this piece of crap. Hell, none of my games ever worked right under 3 anyway, I always had to boot into XP natively, even with the directX option checked. After all, the only video driver/hardware that windows sees under Parallels has a whopping 16MB of shared video memory.
  7. JeromeFromParis


    Same same but different problem

    I have the same problem, just after upgrading to Parallels Desktop 3.

    Just that I can boot using Boot Camp, and get the error message using Parallels.

    Anyone with an idea for a quick fix (not having ro reinstall Windows XP SP2) ?

    Thanks in advance.
  8. mcg


    Hmm, I found myself in a situation where my system booted fine under Boot Camp, but under Parallels it indicated that my ntoskrnl.exe file was corrupt.

    So, I booted from a WinXP CD-ROM, and opened the recovery console. (EDIT: to clarify, I did this within the virtual machine.) I copied ntkopvs_.exe on top of the ntoskrnl.exe that was there, and rebooted---and this time it worked. I shut down cleanly, and rebooted without incident again. I'm about to shut down everything and see if I can still boot with BootCamp cleanly---if I don't post again, you can assume I did. (EDIT: Yes, it works.)

    I make no claims that this will work for everyone, but it worked for me. A similar fix might work for the hal.dll file.

    It seems to me that Parallels would do well to have an option to "reinstate" their booting system in some advanced options somewhere, something that would re-copy their special versions of hal.dll and ntoskrnl.exe somewhere.

    The honest truth for me, however, is that I'm probably giving up on BootCamp. I just don't need it; I only used it because it was cool. This practice of swapping out key system files, however, sounds like a risky practice and I really don't think the risk is worth it in my case. Obviously Parallels doesn't mind my decision at all :) But I know other people depend on being able to use BootCamp sometimes, so they shouldn't get complacent about this.
    Last edited: Jun 19, 2007
  9. mindtrip


    How did you do that??

    MCG, how on earth did you boot to the windows xp disk in the virtual machine?? I would really, really like to not have to re-install my entire BootCamp OS simply to reinstall this file. Would you be able to email me the file? That would save me all manner of headache! Otherwise, I'd appreciate instructions on how to boot into the CD from the virtual machine (or point me to some instructions). Thanks in advance!!!
  10. mcg


    mindtrip: edit the virtual machine. In the OS section, there is a "Booting" tab that lets you change the boot order. Select "CD-ROM, Hard-Disk, Floppy". Go to the CD/DVD drive section and select "Connect at Startup", and make sure it points to the bootable XP install disk.

    Once you've done that your'e good to go!
  11. JeromeFromParis


    Problem solved (for me)

    I just solved my problem by uninstalling and re-installing Parallels 3, following the guidelines from another post.

    The build had changed from 3124 to 4128, so that might be it too.

    I had to re-activate windows on the parallels side, but parallels and boot camp now seem to work fine.
  12. DrangUndSturm


    ntoskrnl.exe crash deleted contents of Mac Documents folder

    A warning to folks (and a question, if anyone else has had this happen to them):

    I was running Parallels 3 using Boot Camp for the VM files.

    I had Shared Folders enabled, and had the Windows "My Documents" folder point to the Mac "Documents" folder.

    When Parallels 3 crashed my VM/Boot Camp install with the associated error...

    "Windows could not start because the following file is missing or corrupt:
    <Windows root>\system32\ntoskrnl.exe.
    Please re-install a copy of the above file."

    ...it took out ALL the files in the Mac Documents folder. If I didn't back up every night, I would be well and truly screwed.

    I haven't been able to restore the ntoskrnl.exe file.

    If you have any advice/wisdom, I'd be most appreciative.

    If not, please learn from my experience: don't have My Documents in Windows VM point to your entire Mac Documents folder.
  13. koolaidman


    Parallels creates a different hardware profile in Windows XP to enable dual booting between Boot Camp and Parallels.

    If your Boot Camp installation crashes in Parallels (or you stop the virtual machine), and you try to boot into Boot Camp natively, it will not be able to change Windows' settings back to the default hardware profile, and therefore give you the 'hal.dll' error.

    The best way to solve this is to boot via Parallels again and shut it down cleanly, as was mentioned above.

    If that doesn't work, you can also boot into Boot Camp, and when the system prompts you to choose a hardware profile (you should see a list of at least 2, one of which will mention Parallels), quickly use the down arrow to select the other hardware profile to boot from.
    It should then be able to boot into XP using the 'physical' hardware profile instead of the virtual one Parallels uses.

    On the flip side of that, if Parallels won't boot your Boot Camp install, make sure that it is trying to boot using the Parallels hardware profile when it's starting up.
  14. wcswcs


    Just telling my success/sob story in case it might help somebody else

    I'm relatively new to Parallels but mysteriously found I'd lost the ability to boot Bootcamp. This occurred after my battery ran out... but I had also installed several pieces of software, so I had no clue what the source of the problem was.

    Being the wise dork I am, I backed up the Bootcamp partition using Disk Utility (bad move!!!) and Norton Ghost to a Mac External Drive.

    My goal was to get bootcamp going again because I need to run software that hits the graphics harder than Parallels allows. So as much as I love Parallels, I still needed Bootcamp bootable.

    Difficulty #1: Bootcamp 1.3 Beta and different size partitions
    I did not read these discussions before I reconsolidated my Bootcamp Partition and upgraded to Bootcamp 1.3 beta at the same time. Oddly, I found that unless I make a Bootcamp partition with the preset 32 GB NTFS setting, I would get a HAL.DLL error during installation, as it seems Windows would try to load from the smaller hidden (?) partitions that Bootcamp makes, and HAL wouldn't be there - the jerk!

    Booting into MacOSX showed HAL.DLL to be in the Windows partitions - hence the conclusion above that the installation process was trying to boot from the wrong partition. This did NOT happen with NTFS at 32 GB as preset in Bootcamp.

    Difficulty #2: Windows Reactivations
    I do not know when Windows wants to reactivate versus when it does not. have a university volume license disk that I slipstreamed and it started complaining of being activated too many times. A call to Microsoft solved that, but it seems to only allow itself to be activated on Bootcamp OR on Parallels, but not on both. Wah!

    I ended up reverting to an older install that did not give me the reactivation woes.

    Difficulty #3: Interrupted Install
    I tried interrupting the install once the partition was formatted, thinking I would simply copy back all of the files (NTFS partitions are writable after installing MacFuse and NTFS-3G - which of course I needed to update MacFink for, and then when the packages weren't on MacFink, I had to compile from source AFTER updating the developer tools, sigh).

    I then copied everything from my drive image over to the newly formatted boot partition as per this article: http://www.macosxhints.com/article.php?story=20061025130528687 AND IT DIDN'T WORK!!!

    Booting with Norton Ghost Rescue shows some kind of Install partition - my guess is it is the EFI versus BIOS boot methods... so even after restoring the original disk info, neither Bootcamp NOR Parallels would boot. To remedy this I had to go back one again and consolidate partitions, make a 32 GB Bootcamp partition and fully install windows.

    Difficulty #4: Even after reinstating the failing drive contents, still no Bootcamp Boot
    When I finally had the Bootcamp partition back AND with a fresh install of Windows, I still didn't have all my applications, including an activated version of the latest Office - like I'm going to let that die with my windoze install. So, I backed it all up using Apple's Disk Utility and then used Ghost to restore the drive I originally had - the one that would not boot into Bootcamp, but would boot in Parallels.

    Now, I was wiser having read these forums to discover some other files were important, namely the ones mentioned in the boot line of boot.ini that parallels uses.

    SO, under MacOSX, I mounted the backup of the working Bootcamp image, and copied HAL.DLL, NTKRNLPA.EXE and NTOSKRNL.EXE to overwrite those that the failing Bootcamp partition was trying to use.

    In the kerfuffle, not only had HAL.DLL become identical for the paralells AND Bootcamp disks, but so had these two Kernel files, Replacing with known working ones (fully patched for windows security crap of course) allowed the system to boot without a hassle. Other files in Windows\System32 had been modified by running parallels (as one can tell by looking at date modified), but I did not touch them. Note that the c:\boot.ini should also not refer to kernel files ending in _.exe as this indicates a boot into Parallels, using the modified Kernel files.

Share This Page