Will build 5584 be OK with XP SP3 next week?

Discussion in 'Installation and Configuration' started by Mike Boreham, Apr 24, 2008.

  1. Mike Boreham

    Mike Boreham Kilo Poster

    Messages:
    281
    XP SP3 is due to appear in Windows Update next week. Anyone know, or is there any official statement about compatibility with Parallels 3 build 5584 which has been rock solid for me on both my macs.

    Thanks

    Mike
     
  2. tintin

    tintin Bit Poster

    Messages:
    24
    I can confirm that there does seem to be issues.

    I have build 5584 running XP Pro (Boot Camp) on a 2.8ghz Alum' iMac. Everything has worked fine with SP2. Then this morning I booted into XP, installed the Apple Boot Camp 2.1 Update, then the SP3 Update. All went fine in Windows. After the required restart I went to the About box and it confirmed that I had SP3 installed.

    Booting back into the Mac and running Parallels, things not so great...

    It starts to boot, comes up with a blue screen with the Windows logo in the top right and says:

    "autochk program not found - skipping autocheck"

    The screen then changes to the classic blue screen of death with some garb at the top and then it reboots. This continues on a loop unless you kill Parallels.

    Unclear to me as whether these problems are caused by SP3 or the Boot Camp update.

    Help!

    TT.
     
    Last edited: Apr 25, 2008
  3. Mike Boreham

    Mike Boreham Kilo Poster

    Messages:
    281
    Thanks for the input.
    I wonder if the problems are related to Boot Camp. My XP is a standalone Parallels virtual machine. No Boot Camp. Was your SP3 a preview version?
     
  4. I have the same question.
    Besides, it is to be noted that Apple is out with an Bootcamp update to accommodate SP3 and VMWare already reacted with an update as well in order to do the same.

    And I would add the question: how long will have user with non-English versions will have to wait?
     
  5. tintin

    tintin Bit Poster

    Messages:
    24
    Yes, its the final build of SP3 (5512), as released to corporate customers on April 21st. You can get it very easily on Bit Torrent now if you don't want to wait until 29th.

    I too noticed that VMware released an update today.
     
  6. DrKarl

    DrKarl Bit Poster

    Messages:
    71
    Clone first to play it safe

    (This thread belongs in the Windows Guest OS forum, but anyway...)

    Mike and others who are not using bootcamp,

    I'd highly recommend either backing up your entire parallels VM or cloning it prior to the SP3 update. Then, if there are problems, it is completely painless to restore your previous SP2 system. ;-) I suppose there are snapshots, etc., too, but a complete clone or backup just feels safer in case something happens to Parallels itself due to SP3.

    People sharing their bootcamp partition like tintin are in a tougher spot, especially given what tintin describes happened to him. :-(

    Cheers,
    Karl
     
  7. tintin

    tintin Bit Poster

    Messages:
    24
    Actually, I do have a previous backup of my XP partition made by Winclone if a fix isn't immediately forthcoming. Hopefully, an update will come before I have to revert. =)
     
  8. FlatDog

    FlatDog

    Messages:
    43
    It is not the boot Camp update causing this. I updated to Boot Camp 2.1 and Parallels 5584 is working just fine with it and winXP. so SP3 must be the problem (I've not tried SP3 yet)
     
  9. Habib

    Habib

    Messages:
    25
    I had the same problem with BC 2.1, Parallels 5592 and SP3. After I´ve uninstalled SP3 I could reboot XP nativly and in Parallels VM.

    I think, parallels must have an update for SP3.
     
  10. Things to note:
    8 replies - even involving emergency cases of users.
    Close to 400 view of the thread.
    ZERO help by the Parallels staff.

    There was recently a discussion on http://lifehacker.com/ about the pros and cons between Parallels and VMWare. And actually the way the Forum is handled by Parallels was cited as a con to Parallels Desktop.

    I do not like saying this. Because more than anything I would like to be proud of the product I am using. But the way this Forum is handled by Parallels makes it difficult!!
    And I could refer to other threads and problems as well.
     
  11. n9yty

    n9yty

    Messages:
    54
    Parallels lost sight of the real goal...

    I used to be a huge Parallels advocate and fan. You'd think with the headstart they had on VMWare (in the Mac area anyway) that the battle was theirs to loose... And it was, and as far as I am concerned they lost it. Yes, there are differences between the two, and if one handles your particular case better then you have little choice but to use it. For general purpose VM support and running programs in it (ignoring all these "mac/windows" cross-app launching/etc features) then I say VMWare wins hands-down.

    Apple and VMWare both produced releases in advance of the public SP3 release, and only a few days after corporate availability. I say that speaks highly of both of them, and Parallels will only slide further down the scale the longer they wait to make an official statement about it.
     
  12. nmdaltp

    nmdaltp

    Messages:
    10
    No problems for me.

    I installed bootcamp 2.1 and then installed XP SP3. Working great for me. It actually resolved the taskbar issues.
     
  13. smccormack

    smccormack

    Messages:
    1
    I fixed the AUTOCHK problem

    I had the same problem with my bootcamp install after updating to SP3 with the missing AUTOCHK and BSOD. I fixed it by opening the hard disk config for the VM, go to the advanced page and clear the parallels info from the boot camp partition (there is a CLEAR button there for this) and when it finishes boot it up. Parallels will show the message about this being the first time using the boot camp partition you can hit ok and everything should boot up like you had it before. I didn't even have to reinstall tools and coherence was even still working. :)
     
  14. Mike Boreham

    Mike Boreham Kilo Poster

    Messages:
    281
    SP3 in pure VM, (no Boot camp) seems OK

    I have installed SP3 in my XP pro VM (5584) and can't find any problems.

    This is all on my Mac Pro 2.66.

    Note this is a pure Parallels VM with no Boot camp.

    I have run Performance Test 6.1 suite, partly to flush out any problems and partly to see what's changed. I ran the suite twice in SP2 just before updating, and then twice in SP3 just after updating. The repeats were consistent.

    Most tests show no significant change between SP2 and SP3. The exceptions are:-

    3D simple test: SP2 scored 30% higher
    3D medium test: SP2 scored 17% higher.....BUT
    3D complex test: SP3 scored 1% higher
    Memory large RAM: SP2 scored 4% higher
    Disk sequential write: SP2 scored 32% higher
    Disk random seek + RW:SP3 scored 63% higher

    Never know whether to believe benchmarks so make what you will of them.

    Mike
     
  15. tintin

    tintin Bit Poster

    Messages:
    24
    Nice job! I can confirm that this fixed the problem for me also.

    TT.
     
  16. Michael Palma

    Michael Palma

    Messages:
    4
  17. jspan

    jspan

    Messages:
    3
    Horrible - don't update! - SP3 crashes parallels and boot camp BSOD

    I can't even get back into windows in boot camp or parallels.
    In parallels it lights the AUTOCHK briefly then BSOD
    I cleared the Parallels info off of it and tried again, no difference.
    I can't boot into Boot Camp, nor Safe Mode in Boot Camp.
    I'm about to wipe it.

    I did the SP3 update yesterday and it crashed in Parallels as mentioned above, but did boot into Boot Camp and let me uninstall SP3, after which I was able to still use Windows XP in boot camp or parallels as before.

    I tried again today after installing the Apple Boot Camp Update and now I have the supreme failure.

    No win for me right now.
     
  18. tintin

    tintin Bit Poster

    Messages:
    24
    My understanding is that you need to install the Boot Camp update BEFORE you install SP3. Thats certainly the impression from Apple.
     
  19. jspan

    jspan

    Messages:
    3
    That was my impression, too. Well, I'm proof that SP3 booted in Boot Camp without the Boot Camp driver software update, and won't at all now, after I've installed the update. SP3 never worked under Parallels with or without the drivers. For the record, I'm on a Jan 08 8-core (2.8 Quad) Mac Pro.
     
  20. uotony

    uotony

    Messages:
    21
    I got SP3 to work in my Boot Camp VM

    Now, this is how I got XP SP3 installed and working:

    1) Boot the machine to XP on the Boot Camp partition.

    2) Install Boot Camp 2.1 from Apple. The URL is:
    http://www.apple.com/support/downloads/bootcampupdate21forwindowsxp.html
    This is essential *before* installing SP3.

    2a) Reboot.

    3) Install SP3. I downloaded the full install from Microsoft.

    3a) Reboot.

    4) Select your OS X partition as your Startup Disk and

    4a) Reboot.

    5) Once OS X boots and you are logged in, start Parallels, but *DO NOT*
    start the VM!

    6) Open your VM configuration, and select 'Hard Disk -> Advanced'

    7) Click on the "Clear..." button under the "Cleanup Boot Camp partition"
    section. This allows Parallels to 'learn' about the changes made by the SP3
    install.

    8) Start your VM.

    9) Once the VM is started and logged in, *RE-INSTALL* the Parallels Tools!

    9a) Reboot the VM.

    Worked for me, anyway!
     

Share This Page