Will There Be a New Release?

Discussion in 'Parallels Desktop for Mac' started by aija_k, Apr 1, 2007.

  1. aija_k


    As far as I'm concerned, I am NOT impressed with this product. Yes, it's "neat" to see Windows or other operating systems running simultaneously with Mac OS X, but that all depends on one's definition of "running".

    First of all, I can't even plug in a simple USB device. I have to use networking just to get files from the mac side of my computer to the windows side. I can do anything on my mac that I want except play specific games. Friends of mine send me links to WINDOWS games that, for some reason, will not run on Parallels. I used to have boot camp installed on my computer, and the games at least ran on that. Which was a beta. That I did not pay for.

    This product has waaaaaay too many bugs and errors and I'm not going to go looking around for the patch and update for every little thing that goes wrong. I really hope a new version of this is released soon, minus the hassle.
  2. SiliconAddict


    Hmm. well I don't know what is wrong with your USB devices but it works find with mine. You simply need to go into the USB Devices menu and selct whatever device you want to connect to windows. If you don't want to dink with that go into the VM's config and turn on auto connect.
    As for Windows gaming. What you are asking for, if I'm understanding correctly is hardware acceleration. Parallels is working on it from what I last read but its simply not ready yet. from what I understand this is NOT an easy thing to impliment. If you need such a setup use bootcamp to dual boot with Windows and parallels to use the Boot Camp partition.
    As for bugs and errors. *shrugs* what's to say? All I know is that the latest build is a heck of a lot better then what we saw last year and what why I finally took the plunge on a purchase last month.
  3. chrisj303


    err... you have installed the parallels tools haven't you? - theres no reason at all that you can't use USB devices with it.

    And if you don't like the current build then thank your lucky stars you weren't around for some of the earlier BETA builds - they WERE a nightmare for some.

    Reading your post again - i'm certain you haven't installed the Tools, or they haven't installed correctly. Either that or your expectations are WAY to high.
    I'm currently waiting for Tools for Linux to be released before i use parallels again - but when i did, i was running XP FLAWLESSLY.

    I would suggest trying VMware Fusion, but you'd probably hate that as well.
  4. aija_k


    The tools are installed properly. When I attempt to install them correctly thinking I did something wrong, the program informs me that the tools are already installed. Parallels doesn't even recognize a 256 mb thumb drive for me. :/

    As for not being able to play certain games I'm almost positive it has something to do with the video drivers. Nothing I install recognizes my drivers, even though these same games ran fine on the same computer when I had them installed on my boot camp partition. Examples are Flyff and Ferentus (Ferentus is no longer around).

    It's really strange.
  5. majortom


    The same OLD story. When will you understand that Parallels and Win on Bootcamp ARE TWO DIFFERENT things (for different purposes)??????????????????????????????????????????????????
  6. tom27


    There are in fact severe problems with the current Parallels version regarding USB keys.

    I can tell this, because I have used every of the last beta version and in them, a USB dongle we use here, has worked just fine. Upgraded to the newest stable version and ... bang ... it does no longer work!

    The USB device itself is recognized and listed but trying to get it online results in an error that the device is already used (which is nonsense of course).

    IMO Parallels should really adress this issue, because besides the fact that our software can no longer be used, the problem has also been reported by several other uses (who all confirm that everything worked in the previous betas).

  7. Hugh Watkins

    Hugh Watkins

    PD >> Menu >> Devices >> Shared Folders >> Add

    a HD is just another folder
    usb or firewire is irrelevant

    Index of file://///.PSF/Mac desktop/

    my HD back up on
    Index of file://///.PSF/Fire wire 1/Desktop Folder/20070310-full macintosh HD/Macintosh HD/Users/******/Desktop/

    it is up to each of us to experient and learn the software

    I have been using PD since June 2006
    even with the beta tests
    I had no serious problems that I did not make for myself

    like losing a months work because I had not backed it up

    Hugh W
  8. dkp


    When you attach a thumb drive both OS X and Windows can use it. Only one can use it at a time, though. If OS X has grabbed it first you need to unmount it so Windows can have it. When OS X has unmounted it you may have to use the Parallels USB menu to hand it off to Windows. That is a consequence of running devices in a VM environment that were never designed for it. It is the same situation for CD/DVD's as well.

    I have several thumb drives ranging from 256 meg to 2 gig and they're all working perfectly. That was not always the case, but at least since RC1 it's been flawless. I'm currently using 3188.
    Last edited: Apr 1, 2007
  9. dkp


    No one in this thread has suggested otherwise.
  10. Stevamundo


    Also, there's no 3D support in Parallels YET.
  11. tom27



    sorry to disappoint you, but there exists a problem in the current USB support in Parallels.
    We use special USB keys (dongles) which worked fine just with each and every beta release before the current final version. Since installing the final, the exact same dongle is no longer recognized. The problem has been pointed out by other dongle users as well and it is not true that the problem persists because OS X grabs the device first. OS X does not even see it since it uses a proprietary windows format and autolaunches only in windows environments.

    Parallels unfortunately does not respond to the reports and I think I need to downgrade to the latest beta (if possible).

  12. wesley


    I think it's a bit of YMMV situation. Stuff like my cellphone now is recognized properly in Parallels via USB. It wasn't the case with early builds'. I have yet to see a problem with USB devices in latest version of Parallels.

    Games... It should be automatically be assumed that games WON'T run in Parallels. At least for the time being. This is a no brainer. Wait until these guys announce 3D support.
  13. pooru



    My USB dongle hasn't worked in any of the betas, but in build 1970 no problem. Still waiting for Parallels support to get their finger out !
  14. tomwojeck


    I have not yet upgrade to 3188, but I've been using SafeNet dongles with every build up to 3186 with no problems at all.
  15. Eru Ithildur

    Eru Ithildur

    Downgrading is possible, and easy.
    Un-install Parallels Tools.
    Un-install Parallels.
    Install Old Version of Parallels.
    Install Parallels Tools.

Share This Page