Win10 start menu no longer works

Discussion in 'Windows Guest OS Discussion' started by JulsS, Jul 23, 2015.

  1. ScottJ1

    ScottJ1 Bit Poster

    Messages:
    2
    Maria - all the work around does is fixes the issues once its happened, it doesn't stop it from happening again which it what people are complaining about on here. This has just happened to me again - I've lost count how many times I've had this issue now. Fortunate my workaround is now so embedded in my mind from having to perform it so many times I'm now able to restore within 2-3 minutes. It's very annoying though!

    I don't understand why we're still waiting for a fix when people first started reporting the issue in July. There are clearly people on here who can recreate the issue so I'm not sure why your testers/engineers can't?
     
    JulsS likes this.
  2. paulb4

    paulb4

    Messages:
    1
    Scott,
    I have the same problem so have been following this thread with interest, however unfortunately your fix does not work for me. I have copied the files you suggest from a 'good' account to the original 'bad' but I see no difference in the account behaviour.

    Any ideas?

    Thanks,

    Paul
     
  3. HockG

    HockG Bit Poster

    Messages:
    1
    I am having the same issue with the start menu not working. Please check this report ID 76677829.
    http://kb.parallels.com/en/123375 KB for this only temporary fixes the issue. Its happening again.
    Please fix asap. Thanks.
     
  4. JulsS

    JulsS Bit Poster

    Messages:
    64
    Has anyone had the bug occur using the latest Win10 patches installed and Parallels 11.0.2? It happened to me twice when Win10 was first released, but I have not had it happen since.

    juls
     
    Last edited: Oct 13, 2015
  5. sgniwder

    sgniwder Bit Poster

    Messages:
    29
    I experienced this again this morning (and yesterday and Monday, and last week). Any news on an update to resolve this? I am tired of creating new accounts...
     
  6. JulsS

    JulsS Bit Poster

    Messages:
    64
    I answered my own question: the bug just happened to me today. Fully patched Windows 10 as of 10/15 and using Parallels 11.0.2. It is clearly still not fixed. Fortunately, I have a snapshot.
     
    Last edited: Oct 17, 2015
  7. Mr. C.

    Mr. C. Bit Poster

    Messages:
    54
    Arg, I was just bitten by this stupid bug. All I did was clone a Win 10 VM, launch it, and poof, No Start Menu. And it corrupted the original too!
     
    Last edited: Oct 22, 2015
  8. AaronP1

    AaronP1 Bit Poster

    Messages:
    2
    This is driving me nuts too. Windows, Parallels and Parallels Tools all up-to-date.
     
  9. PatrickW2

    PatrickW2 Bit Poster

    Messages:
    6
    I have been struggling with this, too (missing icons in task bar, unresponsive start menu, etc.), but just discovered that simply deleting the C:\Users\%user%\AppData\Local\TileDataLayer\Database\*.log files fixes my issues immediately. These files were automatically and instantly regenerated and then everything seems to be working again. I did this while logged into my problem account. I also signed out and logged back in just to make sure it "stuck" and everything is still working fine. I'm not sure how long it will last, but it seems to be a quick fix for now (for me at least). YMMV.
     
  10. AaronP1

    AaronP1 Bit Poster

    Messages:
    2
    Didn't work for me. I ran "del *.log" inside that folder in Command Prompt.
     
  11. CccA

    CccA Bit Poster

    Messages:
    19
    Thanks for that info. When the files were regenerated did the start menu also contain any customisation you had made?
    I think when I have tried messing with those files when windows was running, I was getting lock errors but will try this next time.
    Every few weeks I can cope with!
     
  12. PatrickW2

    PatrickW2 Bit Poster

    Messages:
    6
    It did keep the Start Menu as I had left it. I have a snapshot right before this issue pops up. If I "Go To" that snapshot and sign out or restart, I end up in the messed up state. Out of curiosity, I have now repeatedly gone back to that snapshot, signed out and back in to trigger the issue, and then immediately deleted those log files and I'm back and running fine. I do use File Explorer to manually delete them (not that how you delete them should matter). I tried deleting them before signing out one time to see what would happen, but I ended up in the same broken state after signing back in, and then I ran into a lock issue when trying to delete the log files. Weird. I'm not exactly sure what's going on there.
     
  13. JulsS

    JulsS Bit Poster

    Messages:
    64
    @parallels, is this issue still being treated as a bug? Or is the bug marked as closed because there is a way to fix it after the bug occurs?

    juls
     
  14. ArunR1

    ArunR1 Bit Poster

    Messages:
    5
    @ScottJ1 and @CccA many thanks for your posts. I ran into this exact same issue this morning. Parallels 11, Windows 10 - both up to date with patches.

    I dug into the issue a bit, and it is clear that the cause is because the edb.log file is somehow corrupt. It turns out that this file is the redo log for the Microsoft Extensible Storage Engine - aka database manager. The ESE technology, which has been around for a while and seems to have been used extensively in Exchange and Active Directory, seems to also be in use by Windows 10 for storing information regarding the Live Tiles that make up the Start Menu/Screen. It seems to be used for other things too. On searching for edb.log in the AppData folder I found 9 instances of this file. I surmise that this database/storage technology is being used in these places:

    C:\Users\%USERNAME%\AppData\Local\Microsoft\Windows\SettingSync\metastore
    C:\Users\%USERNAME%\AppData\Local\Microsoft\Windows\SettingSync\remotemetastore\v1
    C:\Users\%USERNAME%\AppData\Local\Packages\Microsoft.Windows.Cortana_cw5n1h2txyewy\AppData\Indexed DB
    C:\Users\%USERNAME%\AppData\Local\TileDataLayer\Database
    C:\Users\%USERNAME%\AppData\Local\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\AC\MicrosoftEdge\User\Default\DataStore\Data\nouser1\120712-0049\DBStore\LogFiles
    C:\Users\%USERNAME%\AppData\Local\Packages\Microsoft.ZuneMusic_8wekyb3d8bbwe\LocalState\Database\anonymous
    C:\Users\%USERNAME%\AppData\Local\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\AppData\User\Default\Indexed DB
    C:\Users\%USERNAME%\AppData\Local\Packages\Microsoft.ZuneVideo_8wekyb3d8bbwe\LocalState\Database\9caa64314892cc5e
    C:\Users\%USERNAME%\AppData\Local\Microsoft\Internet Explorer\Indexed DB

    From my research on the web, it appears that some others (presumably non-Parallels users) are also experiencing this issue - Start Menu not working, Cortana not working, Microsoft Edge not working.
    Among these the following solutions seemed to have helped some:

    1. Resetting the App-Packages
    Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}​
    2. Resetting the Theme
    Change the current Theme to some High-Contrast theme, log out, log back in, and viola the problem is fixed.​
    3. Creating a new user, and using that new user instead of the old one.
    In all these 3, notice that the edb database is involved based on my list of its instances I found above. I think the associated fixes all have to do somehow with fixing this corrupt database.
    In #1 the database that stores the Packages (list of Apps - esp. Modern Apps that make up the Tiles) is being rebuilt through a fix using the Powershell:
    In #2 the database that presumably stores cross-device Settings (Wallpaper, Desktop Theme etc.) probably somehow gets rebuilt by changing the Theme and then restoring it.
    In #3 obviously both the Package List, the SyncSettings and the Live Tiles database all get a nice clean new database. In our case in this thread we were dealing with just the Live Tiles Data Layer (Start Menu/screen), but it could apply to other aspects that use the ESE edb.log file as well.

    Given all this, I find it difficult to believe that this is an issue with Parallels. If it were somehow related to Parallels not writing a file properly, we would expect to see similar issues with a whole bunch of other files. The fact that it has to do with the ESE and the edb.log, suggest that this is a Microsoft bug.

    For what it is worth, my issues started this morning and I first noticed Microsoft Edge icon disappearing. Also the whole system was sluggish. Upon quickly bringing up Task Manager, I noticed that O365 Click-to-run process (forget the exact name) was very busy, consuming a good amount of CPU. Now, I also had customized my Live Tiles to put the O365 apps on them (recently updated to Office 2016). This might well be one of the culprits in causing the edb.log file to become corrupt.

    I think what is lacking is proper control over multiple processes accessing this edb.log file simultaneously. I suspect this because I also see some Errors in my event log indicating that one process was not able to access it because it was in use:

    SettingSyncHost (4924) {09562336-B1FE-4705-AE17-25602A3F0924}: An attempt to open the file "C:\Users\arun\AppData\Local\Microsoft\Windows\SettingSync\metastore\edb.log" for read only access failed with system error 32 (0x00000020): "The process cannot access the file because it is being used by another process. ". The open file operation will fail with error -1032 (0xfffffbf8).

    In my case it could well be that the O365 Click-to-run process was stomping on some other process (perhaps even user click on the Start Menu) that was trying to use the edb.log.

    I hope the Parallels Engineering team in Seattle has an inside line into Microsoft Engineering to be able to pass on this info and report back to us on what exactly the issue is. Please don't use this post as a way to say it is not a Parallels issue. Please follow through on it with your engineering team and Microsoft.

    For anyone encountering such issues, your first step should be to check the Windows logs using Event Viewer. Look for errors relating to edb.log. If you find any, make note of the path to the file, and that should give you a clue to which aspect is corrupt and needs to be reset with a new database or by getting a copy of the folder from a backup.

    There apparently is also a way to repair these database files using a utility called esentutl (you can invoke it in command prompt) and running various commands including checking the health, defragmenting, repairing etc. I didn't dig too much into it, because the best way seems to reset the entire database with new or old backup.

    I ended up using the wonderful instructions that CccA and ScottJ1 provided. I also reset my packages using the Powershell as listed above - this helped reset the icons for Microsoft Edge. I suggest that this is a good option to do - harmless rebuild of the Pacakges database.
     
    Last edited: Oct 29, 2015
  15. CccA

    CccA Bit Poster

    Messages:
    19
    @ArunR1 Thanks for that round up of Info all together. I too believe this has something to do with concurrent access to the "database" and seems more likely during windows update/installing things. I expect it is a windows problem but the parallels tools or disc drivers exacerbate the issue.

    I've just updated to windows version 10565 which I understand may have some improvements so will keep this thread posted if it still happens.
     
    Last edited: Nov 7, 2015
  16. TS-Micah

    TS-Micah Product Expert

    Messages:
    66
    I just encountered this earlier today (Saturday) right after a Snapshot was created it - could that have been the culprit?

    At first, wasn't sure what was going on and it was driving me nuts! After finding some issues that occurred with preview releases I wasn't finding anything satisfactory, until I looked at the Event log, that's when I discovered the TileDataLayer folder. I restored to a previous snapshot where the start menu worked. I opened a File Explorer window, then, using the Task Manager, I killed the explorer.exe (shell) process. There is also a ShellExperienceHost (going from memory) process that should be killed as well. I then copied the TileDataLayer (%USERPROFILE%\AppData\Local\TileDataLayer) to my Mac's desktop. Then restored to broken snapshot, killed the same processes as earlier, and then replaced the contents of TileDataLayer, logged out and back in again and it worked for me.

    I wonder though, could it be something that got interrupted when the snapshot was being created?
     
  17. JulsS

    JulsS Bit Poster

    Messages:
    64
    It will be interesting to see whether this bug reoccurs with Win 10 build 10586 (aka Threshold 2 aka Fall Update) and Parallels 11.1.

    juls
     
  18. CccA

    CccA Bit Poster

    Messages:
    19
    I've had 2 weeks without a problem on version 10565 - but I've had as long with previous versions. My th2 is waiting to load but I'm reluctant to let it!
     
  19. TS-Micah

    TS-Micah Product Expert

    Messages:
    66
    I thought after the new build update that this may have been resolved. But it looks like it isn't. This seems to happen AFTER an automated snapshot while the VM is running. If it runs while the VM is shutdown - no issue.

    This is getting incredibly FRUSTRATING... When the start menu tile data layer goes corrupt, not only does the Start Menu not work, but the search feature (to launch applications) is rendered USELESS as well. Why the app search needs to depend on the TileDataLayer from that Start Menu is beyond me - it should be a separate index and the search feature should work if the Start Menu (Win 10 app) is failing. I have to keep reverting to a previous snapshot.

    I'm wondering if this may be related to the new way that the disk I/O is handled in Paralells 11 and something that isn't working properly with how Microsoft expects things to be handled with the TileDataLayer database. In my research on this issue, it seems to have been a problem that persisted throughout the Windows 10 Beta/Preview.

    IMO this needs to get fixed ASAP!

    <-- Not a happy camper....:mad:
     
  20. TS-Micah

    TS-Micah Product Expert

    Messages:
    66
    Here's the messages from the Application Error Log:

    Level: Error Date/Time: 11/19/2015 9:37:57 AM Source: ESENT Event ID: 477 Task Category: Logging/Recovery
    svchost (2888) TILEREPOSITORYS-1-5-21-1774901099-2585919563-639794216-1006: The log range read from the file "%USERPROFILE%\AppData\Local\TileDataLayer\Database\EDB.log" at offset 1048576 (0x0000000000100000) for 4096 (0x00001000) bytes failed verification due to a range checksum mismatch. The expected checksum was 69990787072000 (0x3fa800004000) and the actual checksum was 1465195633562473889 (0x14556baa70f1d5a1). The read operation will fail with error -501 (0xfffffe0b). If this condition persists then please restore the logfile from a previous backup.

    Level: Error Date/Time: 11/19/2015 9:37:57 AM Source: ESENT Event ID: 465 Task Category: Logging/Recovery
    svchost (2888) TILEREPOSITORYS-1-5-21-1774901099-2585919563-639794216-1006: Corruption was detected during soft recovery in logfile %USERPROFILE%\AppData\Local\TileDataLayer\Database\EDB.log. The failing checksum record is located at position END. Data not matching the log-file fill pattern first appeared in sector 256 (0x00000100). This logfile has been damaged and is unusable.

    Level: Error Date/Time: 11/19/2015 9:37:57 AM Source: ESENT Event ID: 454 Task Category: Logging/Recovery
    svchost (2888) TILEREPOSITORYS-1-5-21-1774901099-2585919563-639794216-1006: Database recovery/restore failed with unexpected error -501.

    Level: Error Date/Time: 11/19/2015 9:38:02 AM Source: Application Error Event ID: 1000 Task Category: (100)
    Faulting application name: ShellExperienceHost.exe, version: 10.0.10240.16515, time stamp: 0x55fa599a
    Faulting module name: twinapi.appcore.dll, version: 10.0.10240.16590, time stamp: 0x563ad512
    Exception code: 0xc000027b
    Fault offset: 0x000000000006646f
    Faulting process id: 0x2584
    Faulting application start time: 0x01d122d7e2233748
    Faulting application path: C:\Windows\SystemApps\ShellExperienceHost_cw5n1h2txyewy\ShellExperienceHost.exe
    Faulting module path: C:\Windows\System32\twinapi.appcore.dll
    Report Id: 3a7d622f-9377-4725-a044-a3d65afae921
    Faulting package full name: Microsoft.Windows.ShellExperienceHost_10.0.10240.16384_neutral_neutral_cw5n1h2txyewy
    Faulting package-relative application ID: App

    Level: Information Date/Time: 11/19/2015 9:38:02 AM Source: Windows Error Reporting Event ID: 1001 Task Category: None
    Fault bucket 133207245823, type 5
    Event Name: MoAppCrash
    Response: Not available
    Cab Id: 0

    Problem signature:
    P1: Microsoft.Windows.ShellExperienceHost_10.0.10240.16384_neutral_neutral_cw5n1h2txyewy
    P2: praid:App
    P3: 10.0.10240.16515
    P4: 55fa599a
    P5: combase.dll
    P6: 10.0.10240.16384
    P7: 559f3aac
    P8: 8000ffff
    P9: 00000000000230e5
    P10:

    Attached files:
    %USERPROFILE%\AppData\Local\Temp\WEREF9.tmp.WERInternalMetadata.xml

    These files may be available here:
    C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_Microsoft.Window_8c75337558dee1a486a675143f5e02ccb8d2c29_21351821_05a40fb5

    Analysis symbol:
    Rechecking for solution: 0
    Report Id: 3a7d622f-9377-4725-a044-a3d65afae921
    Report Status: 0
    Hashed bucket: 0696b42dbdaa3abde8f99c4efb0ce773
     
    Last edited: Nov 19, 2015

Share This Page