Windows 10 Bootcamp not booting - winload.exe Error Code 0xc000000e

Discussion in 'Installation and Configuration' started by MalcolmH2, May 14, 2018.

  1. MalcolmH2

    MalcolmH2 Bit Poster

    Messages:
    3
    Windows 10 Bootcamp - Latest version (10.0.16299.371) - retail, digital licensed version, not preview version, mainstream channel
    Parallels 13.3.0 (43321)
    Bootcamp partition boots fine from restart, hold option, choose partition.
    VM Bootcamp that was working a couple of months ago, now returns BSD:
    Recovery
    Your PC/Device needs to be repaired
    File: \windows\system32\winload.exe
    Error code: 0xc000000e
    [​IMG]

    --
    Have tried bootrec /fixmbr, bootrec /fixboot, bootrec /rebuildbcd from Recovery USB drive. No change.
    Mounted EFI partition ( k ), tried bcdboot C:\Windows /l en-us /s k: /f ALL. No change.
    Think this may be red herring as booting in EFI mode? Don't know much about this though. See bootloader is winload.efi not winload.exe. Why does Parallels look for winload.exe and not via winload.efi? Have tried the vm.bios.efi=0 flag and also vm.bios.efi=1, the true flag results in the EFI shell screen. Maybe this is the issue? somehow the EFI loader is not working?
    [​IMG]
    Using EasyBCD can get the following info:
    Windows Boot Manager
    --------------------
    identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
    device partition=\Device\HarddiskVolume4
    path \EFI\Microsoft\Boot\bootmgfw.efi
    description Windows Boot Manager
    locale en-us
    inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
    default {b33e53c1-57e4-11e8-b408-a73c84e26bbf}
    resumeobject {b33e53c0-57e4-11e8-b408-a73c84e26bbf}
    displayorder {b33e53c1-57e4-11e8-b408-a73c84e26bbf}
    toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
    timeout 10

    Windows Boot Loader
    -------------------
    identifier {b33e53c1-57e4-11e8-b408-a73c84e26bbf}
    device partition=C:
    path \windows\system32\winload.efi
    description Windows 10
    locale en-us
    inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
    isolatedcontext Yes
    allowedinmemorysettings 0x15000075
    osdevice partition=C:
    systemroot \windows
    resumeobject {b33e53c0-57e4-11e8-b408-a73c84e26bbf}
    nx OptIn
    bootmenupolicy Standard

    --
    Disabled SIP on Mac. No change.
    Tried recreating VM, minimal settings - no USB 3.0, directx 9, etc etc. No change.
    Tried turning off Fast Startup in Windows Power Settings. No change.
    Cleaned Windows hard drive of Windows.old. No change.
    System Integrity check, including DISM, all good.

    Seems to be related to Parallels, as it was working a couple of months ago, now just loaded up and no go. So maybe Windows updates have broken?

    If I change the Partition list to just the EFI partition and set the flag to vm.bios.efi=1
    I get a different error, which references the efi, which maybe is an improvement??? :
    [​IMG]
    F8 doesn't do anything.
    Any suggestions? I need this urgently for work...
     
    Last edited: May 14, 2018
  2. MalcolmH2

    MalcolmH2 Bit Poster

    Messages:
    3
    After a whole day of trying to track this @#$@#% down, I found that setting the Hard Drive in the settings to Source: Disconnected (plus both partitions, and SATA 0:1) allowed the VM to boot! urgh...

    EDIT - Nope it's back. Far out. So I'm not sure how this setting affected the boot, but I was able to boot for a couple of times. Trying to setup another VM that boots reliably... seems weird that this setting would work.
     
    Last edited: May 15, 2018
  3. MalcolmH2

    MalcolmH2 Bit Poster

    Messages:
    3
    OK restored the VM that worked.
    I've got two identical VM's, one works the other doesn't. Both have exactly the same settings as below:
    So this seems like some kind of bug.

    After some more experimenting, it seems if I try to change any setting in the VM that is working, it stops working. Sometimes it flashes up a DFInitialiseFailed (or something... grey text on black background... very fast so not sure exactly what it says)

    [​IMG]

    [​IMG]

    [​IMG]
     
    Last edited: May 15, 2018

Share This Page