Windows 11 ARM on MacOS (Parallels) stops functioning properly

Discussion in 'Windows Guest OS Discussion' started by LeventY1, Oct 18, 2021.

  1. CarlosF6

    CarlosF6 Bit Poster

    Messages:
    9
    Is Windows 11 still working after switching back to US-English?
     
  2. L3tron

    L3tron Bit Poster

    Messages:
    5
    Yes, also with Secure Boot Enabled.
     
    CarlosF6 likes this.
  3. AndrewH14

    AndrewH14 Bit Poster

    Messages:
    2
    Thank you @NoelS1 - your solution appears to have fixed this problem (Setup from Windows Start does not open - and other system-to-internet-access issues)
    To recap:
    - in parallels desktop, File/New
    - (maybe out of sequence) - configured to prompt for boot option, on boot, disabled Secure boot, restarted
    - Windows from VDHX file
    - chose 'install OS manually'
    - installed with no networking
    - once Win11 setup complete, installed parallels desktop (clicked the yellow alert symbol)
    - restarted
    - Windows menu/Setup work
     
  4. EdwardW7

    EdwardW7 Bit Poster

    Messages:
    2
    This issue is not resolved with the method, the system runs normally for a few minutes before repeating the same issue. There is something wrong with Parallels Tools and Win11 arm that is causing this.
     
  5. TimoK8

    TimoK8 Bit Poster

    Messages:
    2
    Incredible - but it also works for me! Applying the mentioned powershelgl commands and rebooting the system, I'm also able again to access all menus (including update, settings, etc.).
    By the way: setting the keyboard to German layout seems to work and shows no negative impact to the problem before.
     
    Matthias_22 and halil like this.
  6. MagnusL5

    MagnusL5 Bit Poster

    Messages:
    1
    On Windows 11 ARM version 22483, automatic install managed by Parallels, I had the exact same issue. Settings did not work, right click on some items did not work, etc. However after applying these commands in powershell as administrator and a reboot. All issues where resolved! I did not have to reinstall Windows 11 manually! Thanks a lot!

    For context, I was already on english version of Windows 11 but since my location is in Europe maybe locale was set to en-EN? Or it could be that the above fix works for everyone, even if already installed as en-US? Worth a try since it is super quick to do.
     
  7. L3tron

    L3tron Bit Poster

    Messages:
    5
    I almost suspect that this problem only occurs with users who do not use en-US automatically (through Parallels installer) or manually. This could also explain why there are not many more error reports here in the forum and in other sources (Reddit etc.).

    The Parallels (Auto-)installer is setting on my system:
    Code:
    PS C:\Users\l3tron> Get-WinSystemLocale
    LCID             Name             DisplayName
    ----             ----             -----------
    1033             en-US            English (United States)
    
    PS C:\Users\l3tron> get-WinUserLanguageList
    LanguageTag     : de-DE
    Autonym         : Deutsch (Deutschland)
    EnglishName     : German
    LocalizedName   : German (Germany)
    ScriptName      : Latin
    InputMethodTips : {0407:00000407}
    Spellchecking   : True
    Handwriting     : False
    So to fix the error it is enough to do this in powershell (administrative)
    Code:
    Set-WinUserLanguageList en-US -Force
    Restart-Computer
    It also seems to be no problem to install additional language packs, spell checking, time/date formats in Windows and browsers (e.g. EDGE). As long as the WinUserLanguageList language remains on en-US.
     
    HooksI and MagnusL5 like this.
  8. EdwardW7

    EdwardW7 Bit Poster

    Messages:
    2
    Had to reinstall with en-US default and it seems to be working fine.
     
  9. Matt_Sky

    Matt_Sky Bit Poster

    Messages:
    6
    Thank you so much for your findings!! This was working for me. For me it is even possible to change the Region Settings to my Country and language.
    But CAUTION: DO NOT make the german language pack as the default. When you do this, windows is bricked again. (Settings Windows do no open etc.) Just leave the English (United States) as preferred language pack and change to german everytime after the reboot.
    For now its working for me. I'm patiently waiting for the language fix from either Parallels or Microsoft...

    These are the settings that worked for me:

    upload_2021-11-2_15-39-15.png
     
    halil likes this.
  10. Brent3

    Brent3

    Messages:
    1
    Windows 10: I followed above instructions on selecting boot device on startup; disabled X on secure boot; changed from Standard English to English.
     
  11. halil

    halil Bit Poster

    Messages:
    1
    Thank you
     
  12. FacturealF

    FacturealF

    Messages:
    1
    Thank you so much. It was very hard to even find any information about this topic and I troubleshooted for so many hours. Should've probably just opened the Parallels forums instead of googling the symptoms. Found it through Macrumors.
     
  13. KevinS33

    KevinS33 Bit Poster

    Messages:
    1
    Thanks so much, I thought I could get away with manually selecting US keyboard and Canada locale. Not so much. Nice to not have to wipe the machine again!
     
  14. JimmyBondi

    JimmyBondi Bit Poster

    Messages:
    2
    Same issue on my machine. Even after updating to the newest Insider Build 22494 I cannot change the preferred language to German nor the keyboard layout.

    Currently I'm running Windows in English locale but especially with regard to the keyboard layout it is a bit ugly to use on a German keyboard. Hopefully it gets fixed soon by Parallels or Microsoft.
     
  15. JohanL6

    JohanL6 Bit Poster

    Messages:
    2

    Does this still work four you guys or is it just a temporary fix?
     
  16. JimmyBondi

    JimmyBondi Bit Poster

    Messages:
    2
    This is how I got it running but then I cannot change the language or the keyboard layout to German.
     
  17. Matt_Sky

    Matt_Sky Bit Poster

    Messages:
    6
    It's still working perfectly fine for me.
     
  18. ChristophS16

    ChristophS16 Bit Poster

    Messages:
    6
    The problem really seems to be the language setting: in German Windows is almost completely unresponsive, in US English everything works fine (and fast!).
     
  19. Matt_Sky

    Matt_Sky Bit Poster

    Messages:
    6
    yes, and even after the last few updates I kept trying to switch. Unfortunately, the problem has still not been fixed.
     
  20. MatthiasE5

    MatthiasE5 Bit Poster

    Messages:
    35
    Hello,
    - has this bug been submitted at the Windows Feedback app?
    - is this bug limited to developer channel at the moment?
    - is there a reason why you are using developer channel instead of release channel since you are apparently interested in a stable system?
    - in the release version channel, german language settings work with no issues.
     

Share This Page