Windows 11 on Arm

Discussion in 'Parallels Desktop on a Mac with Apple silicon' started by kundanno, Jun 23, 2021.

  1. Mike Boreham

    Mike Boreham Pro

    Thanks Alexei. Trying to make this work. I ran UUP dump for 22000.160 from my activated Windows 10 VM, using Pedro's preconfigured link in #165 (thanks Pedro) and the process completed, leaving an "ISO folder". I ran setup from there and installation started but it soon wants a Product Key, with no way to skip or activate later. My Windows have all been activated through my MS account for years. I tried various old product keys but none worked.
    I am currently trying again and hopefully (never used UUUP before) will use the UUUP convert tool to get an ISO file and create a new VM, and hope the product key issue doesn't strike again.
    Any advice?
  2. Mike Boreham

    Mike Boreham Pro

    Follow up question. My goal is to have 22000.194 running as ChristopherK has. I already have a Windows 11 Dev build 22471 VM. Am I more likely to succeed by running UUUP from there, and launch ISO Folder/setup from that?
  3. ChristoherK

    ChristoherK Bit poster

    I ended up creating a new VM using the iso for 22000. When it finished setting up and doing all the updates everything seems to be working. Did have a problem with activation, but it finally took. Using this build though, I doesn't show me as enrolled to the insider program. So not sure if that's a good/bad thing. And as previously stated I don't have anything saying that this build was from any of the channels.
  4. Mike Boreham

    Mike Boreham Pro

    I assume that was a Product Key that finally took? My Windows 10 was activated by free upgrade from Windows 7, and now shows activated through MS account. The only Product Keys I have are Windows 7 and Windows 8. Did you have an actual Windows 10 key? Thanks
  5. ChristoherK

    ChristoherK Bit poster

    Yes, had Win10 Pro key
  6. Mike Boreham

    Mike Boreham Pro

    My experience goes against all previous that you can install Windows without activation, and activate later with an MS account or use for a period.
  7. Mike Boreham

    Mike Boreham Pro

    The UUUP method has now worked for me. I have 22000.194 installed and activated. Like Christopher I created a new VM and installed with the ISO made by UUUP in my Windows 10 VM. The installation in a new VM did not ask for a Product Key. I was able to install it unactivated (which is the normal way) and then sign in with my Microsoft Account and activate.
    It wasn't completely straightforward as I had the seemingly common problem of MS account password being rejected. I signed in via my Office account and into the Microsoft Store and then it was happy. I also had to use the Activation Troubleshooter option "recently changed hardware" and replace a previous activation.
  8. ChristoherK

    ChristoherK Bit poster

    Glad it all worked. Thanks to everyone who's replied to me on this subject as well!
  9. Mike Boreham

    Mike Boreham Pro

    And thanks for your help too!
  10. BradB7

    BradB7 Member

    You can download via UUDump the ARM version. It's a bit trickier to make an ISO with a Mac, but I made one with a Windows machine without any trouble or installation of additional software. YOu can use the instructions here to get the ARM 22000.194 vs the 22458 Dev channel release (that is the only one being pushed anymore):
  11. antonio23

    antonio23 Bit poster

    I installed the windows 11 but seems to have not Microsoft Store on it can you guys verify for me ::
  12. RalphB6

    RalphB6 Bit poster

    So far so good. Just performed a Windows Update on my M1 Macbook Pro with Parallels Desktop 17 for Mac. Windows 11 Pro, version 21H2 works fine for mail, YouTube, Netflix, and web browsing so far. More testing to do.
    Windows 11 from the Windows Insider Program.
    Dmitry@Parallels likes this.
  13. Don Awalt

    Don Awalt Hunter

    I see anf understand how to install 22000.160, and it will upgrade to 22000.194. I am in the Insider beta program, and am on 22000.282. Once on 194, am I able to rejoin the Insider program and get beta updates, say to the current 282?
  14. Don Awalt

    Don Awalt Hunter

    Thanks @MichaelH63 ! So once I got on the latest build and joined Insiders again (I am on it now), would I get new updates as I do today on my Intel Mac?
  15. Don Awalt

    Don Awalt Hunter

    Thank you!
  16. jonnyss

    jonnyss Junior Member

    hi - what happens if you don't enter a key and what happens if you do enter a key?
    i'm getting the message on screen that i need to register a key. as others have mentioned, to do that, you have to install the microsoft store app. i believe finally have the store app installed. (it was difficult!) but then what shows up to purchase is windows 10/11 pro "upgrade to workstation" for $199.
    1) is that the product i want? i don't really need any of the pro features. i just want to run the windows program tradestation. but as others have pointed out, what parallels installed was windows 11 arm pro.
    2) will the key work? one of the consultants i paid today to help me download the store app said that the current build shown on my virtual machine can't be registered on arm even if you buy a key. that the arm version is an unofficial beta release and can't be registered.
    3) do i even need a key? the consultant said that even when the "trial period" expires, i will still be able to run my windows program, tradestation, i just won't have access to various other windows features. does anyone have experience with what happens if you don't enter a key?
  17. EvanW3

    EvanW3 Bit poster

    Hello. I am new to this party, first time attempting to use Parallels virtualization on a Mac. I am using a Mac Mini (2020, M1, 16GB RAM, macOS Big Sur v. 11.6). And I am attempting to use Parallels Desktop 17 for Mac (v. 17.1.0 (51516)).

    If I am understanding things correctly, the only version of Window OS that Parallels can accommodate for an M1 machine is Windows 11 Insider Preview through the Windows Insider Program. Is that correct? Or are there other options available? I would prefer Windows 10, since that is the last Windows OS that I have experience with, but it seems that is not possible...

    For those of you who are in this (or a similar) situation and using Windows 11 Insider Preview, how is that working for you? Is it running fairly smoothly? Or any issues I should be aware of?

    I am looking at the Insider Program registration page, and I don't like this line about potentially experiencing crashes, security vulnerabilities, data loss, or damage to my device... But is this actually something to be concerned about?

    My main objective is to use Microsoft Word in its native Windows environment without having to go to the extreme of investing in a PC... the Mac version of MS Word is fine, but it lacks some quality of life features that would help make life more efficient for me.

    Many thanks!
  18. Stephen Van Dellen

    Stephen Van Dellen Member

    I got a Windows 11 21H2 for ARM Home edition version 22000.282 from UUDUMP last night, downloaded it, installed it, and activated it by transferring the Windows 10 Home digital license I had been using on an X86 Mac. I'm ignorant about Windows versions and totally baffled about what UUDUMP does so I don't have much confidence in the system, but I've installed Microsoft Office and 1Password and they appear to be running happily. The remainder of this message is a step by step procedure. It's really long. I apologize if it irritates those of you who already know how to do this but I surely wish I'd found something like it. Maybe Parallels will use it as an outline of a kb article and delete this post.
    1.0 On UUDUMP.NET
    1.1 On the Home page:
    I selected "Windows 21H2" in the row of "buttons" for different versions in the middle of the page but I don't really remember why. 282 is working OK for me so far but, if I was starting over, I'd pick the first (most mature) Windows 11 for ARM version in the Quick Options, currently 22000.160 in "Latest Beta Channel build".
    1.2 On the "Browse known builds" page:
    Click "Upgrade to Windows 11 ( arm64" where is the version you selected. Be careful not to select the AMD version,
    "Upgrade to Windows 11 ( amd64". It's easy to do as I can tell you from sad experience.
    1.3 On the "Upgrade to Windows 11 ( arm64" page:
    I just kept clicked Next without changing any of the defaults.
    1.4 On the next page, also titled "Upgrade to Windows 11 ( arm64":
    Uncheck "Windows Pro" in the "Choose edition" list along the left side. I don't know what will happen if you leave both Home and Pro checked.
    There's nothing to select in the "Additional edition", "Required edition" lists on the right. I think they're just information for people building other editions.
    Click Next.
    1.5 On the "Summary for your selection" page:
    Verify the Update is "Upgrade to Windows 11 (22000.282) arm64" and the Edition is Windows Home.
    I left the default "Download and convert to ISO" and "Include updates (Windows converter only)" options selected.
    Click "Create download package".
    In the new file dialog box that appears, select a folder on your desktop computer where UUDUMP will put stuff.
    "Create download package" doesn't do anything but put a small ZIP file containing command line scripts there. When you run one of them below, it will download all the Windows components and build an ISO file in subfolders of that folder. These took 8 GB for me so pick a location with enough space.
    2.0 On your desktop computer in macOS, Download Windows components and build an ISO file:
    UUDUMP supplies linux, macOS and Windows scripts. The instructions that follow use the macOS script on the ARM Mac where Windows will be installed.
    2.1 In Finder, unzip the ZIP file if it didn't unzip automatically.
    2.2 Start a Terminal session. (Finder -> Applications -> Utilities -> Terminal)
    %cd to the unzipped folder.​
    It should contain the file "" among other things. I've never used UUDUMP before and have no idea what could have gone wrong if it doesn't. All I can suggest is to start all over from the beginning.
    2.3 Try to run the script
    Enter the command:
    You'll probably get something like the following:
    One of required applications is not installed.
    The following applications need to be installed to use this script:
    - aria2c
    - cabextract
    - wimlib-imagex
    - chntpw
    - genisoimage or mkisofs
    macOS requires Homebrew ( to install the prerequisite software.
    If you use Homebrew, you can install these using:
    brew tap sidneys/homebrew
    brew install aria2 cabextract wimlib cdrtools sidneys/homebrew/chntpw​
    2.4 Install HomeBrew
    On the "" web site, follow the instructions to install HomeBrew. Then enter the commands from the previous message:
    %brew tap sidneys/homebrew
    %brew install aria2 cabextract wimlib cdrtools sidneys/homebrew/chntpw​
    These take awhile and produce LOT of terminal messages.
    2.5 Try to run the script again
    Enter the
    command again.
    The script should download the Windows packages and produce LOTs of terminal output. Eventually it shows a list of all the packages and whether they were or were not successfully downloaded. The first time I ran it, a half dozen were not and it stopped with the message:
    aria2 will resume download if the transfer is restarted.​
    So I entered the same command again. It skipped the packages that had already downloaded successfully, downloaded the ones that had not, and went on to create an ISO file with no input from me. I don't know why downloads fail sometimes, how often you might have to try to get them all or how to tell when something's so badly wrong you need to do something other than just keep retrying.
    3.0 On your desktop computer in macOS: Create a new Virtual Machine in Parallels.
    In Finder, navigate to the folder where the script was stored. The ISO file should be there now.
    Right-click the ISO file, select Open With and Parallels.
    Parallels will create the new Virtual Machine as it usually does when you start with an ISO file.
    4.0 On your desktop computer in Windows: Activate it
    Start the new Windows Virtual machine if Parallels didn't start it automatically.
    I'd Exit Coherence so it's easier to find and see Windows programs.
    Select Start -> Settings -> System -> Activation which opens the Activation window.
    I'm working from my memory now. Since my copy is activated, it doesn't display the activation procedure anymore.
    On the window that asks how you want to activate Windows, click "Troubleshoot".
    It will display a dialog that, among other things, give you the option to transfer a license you already own.
    When you select it, it will open a window that shows all the licenses you own that could be transferred to the new installation. Just pick one.

    This makes it sound a LOT easier than it was. I spent a couple of days wrestling with it First it said the license server wasn't working at all. Then it wouldn't display my existing Windows 10 licenses. Then it said they couldn't be transferred. I don't know what I did to fix it or whether Microsoft just finally got the license servers working properly again but last night it all went just as smoothly as I described above. The moral is, if About on the new Windows does say it's a Home edition and if you know you have valid Windows 10/11 Home edition licenses, don't give up too easily.
  19. Mike Boreham

    Mike Boreham Pro

    No. You can install the release version of Windows 11. I was on the Dec Insider channel for several months, and then one Dev build blocked M1 Macs. There were threads here about that, and also about installing the release build with uupdump, which is what I have done and been getting regular updates.

    I don't know if the Dev Insider channel is working again for M1 macs. I also don't know anything about the current Windows 10 ARM situation.

    It certainly is a confusing and frequently changing situation, but this forum has followed the twists and turns and has been the only useful source of info for me, with some great contributors.

    One aspect to be aware of is that the Windows ARM EULA says it is only licensed for use on OEM machines, which means M1 Macs are contravening the EULA. In corporate business contexts they would fail a software audit. I am told that this does not make using it illegal per se, but does mean MS could theoretically sue. Since MS knows I am using an M1 Mac and still activated my Windows 11 release with licenses linked to my MS account, I am not losing any sleep over this. But it is a consideration for corporate users. I think we are probably in a tolerated limbo while MS, Apple and Parallels work out their positions.
  20. Mike Boreham

    Mike Boreham Pro

    Been doing some catchup and re-reading and think the build I was thinking of when I wrote the above was a minor perturbation. I have the impression that the Insider options are now working, though since I made a fresh Windows 11 release VM I have been out of touch with the Insider programme. Apologies if I misled.

Share This Page