Windows 7 Time Sync Problem

Discussion in 'Windows Guest OS Discussion' started by bobbyt, Dec 30, 2009.

  1. bobbyt

    bobbyt Product Expert

    Messages:
    170
    I'm having an issue with time sync under windows 7 & parallels 5.

    I have the time sync option checked, and I just restored a virtual machine. It shows the date and time that the os had when I saved the state a week ago...

    The virtual machine has been actively running for over 20 minutes now, and since I did a clean install of windows 7 when I first set the VM up a couple weeks ago this option has been actively checked and the parallels tools are properly installed and working outside of this...


    For the record I CANNOT actively create a support ticket as your support form allows a maximum Host OS version of 10.5, and a maximum windows guest version of Vista. Being I'm using 10.6 & Windows 7, this means I cannot accurately create a ticket. As much as I want to type an essay to indicate how this major support oversight makes me feel, I'll just ask to please fix this oversight so that I can get the support I need.
     
  2. TigerMe

    TigerMe

    Messages:
    20
    Try picking a different time server from the list. Worked on a regular Windows machine that was having the same problem.
     
  3. bobbyt

    bobbyt Product Expert

    Messages:
    170
    This is more of a work around than a fix...

    Parallels tools has a feature to keep the VM time in sync with the host machine, and in previous versions of parallels in other VM's the feature used to work. The fact that its not means there is a genuine with parallels...
     
  4. TigerMe

    TigerMe

    Messages:
    20
    Agreed - this update isn't the greatest thing in the world. It tanks Windows Live Mail and you have to do a workaround to fix it. I was just trying to help. I suspect another update will be coming sooner rather than later.
     
  5. bobbyt

    bobbyt Product Expert

    Messages:
    170
    Setting a time server didn't turn out to be a great fix. I have verified the time sync problem also occurs if you, say, put your system to sleep for any length of time... I put my system to sleep for an hour and a half & have confirmed the time on my VM is now an hour and a half earlier than current time.

    I also found that there is an issue submittal within parallels that allowed me to submit a bug report, ID 1758454.

    I took the additional step of uninstalling then re-installing parallels tools from the VM, but it had no effect what-so-ever... Again this VM was created from scratch under Parallels 5, and was a clean install of Windows 7, meaning that upgrading parallels or the VM can be ruled out as a cause...
     
  6. Fai Lau

    Fai Lau

    Messages:
    10
    Yes Parallels tools do not sync the time after VM has come out of sleep.
     
  7. I-che

    I-che

    Messages:
    492
  8. KirkJ

    KirkJ Bit Poster

    Messages:
    4
    Similar Problem

    When I allow Windows 7 to "Time Sync" with the MAC OS, it changes the time zone for Central Time - US, to Central America. Unchecking the Sync option solves this, but as I travel often and Like changing the timezone to match, it would be nice if Parallels could fix this bug.
     
  9. bobbyt

    bobbyt Product Expert

    Messages:
    170
    I unchecked the time sync option as step 3 indicated and got the following error message:

    I'm going to try an reboot the VM and quit & re-start parallels to see if it fixes this particular problem...


    I'm not convinced making the changes in the KB will actually fix anything though, as an incorrect time zone doesn't explain how the guest os's date/time can get several DAYS out of sync... Never the less I will post the outcome of implementing the KB's change after I've fully tested it...
     
  10. bobbyt

    bobbyt Product Expert

    Messages:
    170
    OK, I just performed step by step this process, however upon step 4 I confirmed that the time zone WAS ALREADY set to my local time (Pacific).

    I did further testing which again confirms the pattern I've been discussing:

    I paused the VM for around 6 minutes (Virtual Machine -> Pause). I then un-paused it, watched the VM for several more minutes & verified the VM's time stayed exactly 6 minutes out of sync (which is logical since at this point time sync under preferences was still disabled on step 3).

    Following this I shut down the VM, re-enabled time sync under preferences, then booted the VM back up. The VM had the proper updated time once it booted up (time sync does appear to work during boot)...
    Once the VM had finished booting, I again paused the VM (in this case for 2 hours 6 minutes). I then again un-paused the VM & waited several more minutes & verified once again that the VM remained 2 hours 6 minutes out of sync.


    Quite simply, the virtual machine's time is consistently NOT being updated by parallel's time sync feature. Essentially if I pause the VM, suspend the VM or put the host machine to sleep -- once the VM becomes active again,the time in the VM time continues from whatever time it was paused, suspended, or put to sleep at... Parallels tools is NOT updating the VM's time...
     
  11. bobbyt

    bobbyt Product Expert

    Messages:
    170
    Update:

    After glancing at my system a couple times over about an hour to check if the clocks stayed out of sync, however I got busy enough that I ceased looking at my laptop. I just turned over to it in order to pack up & go and I noticed the clock WAS in sync...

    Sometime within the past 6 hours the VM time did re-sync with the host time... It appears that Sync isn't completely broken, just that its not as persistent as maybe it should be... Specifically when coming out of a state of artificial inactivity...
     
  12. Shaddam IV

    Shaddam IV

    Messages:
    626
    One way of getting around inaccurate time in Windows after sleep / suspend is to increase the frequency with which Windows polls its internet time server, using the Windows Registry editor regedit (Start->type "regedit"):

    (via tweaks.com)

    ---

    To change the interval that Windows updates the time using the internet time servers navigate to:


    1. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\W32Time\Tim eProviders\NtpClient


    2. Select "SpecialPollInterval"


    3. Change decimal value from 604800 to some other
    value in seconds. EX: 172800 (2 days)

    Originally posted by Taylor Spencer

    ---

    I've set the interval to 3600, ie Windows is polling the time server every 60 minutes.
     
  13. bobbyt

    bobbyt Product Expert

    Messages:
    170
    One question I'm left with is how low can one go???

    Ideally its not a hugely intensive task, but at the same time there might be other aspects in this process that may make a setting of 10 minutes just way to frequently...

    <sigh> I think I remember a similar issue with time sync in an earlier version of parallels (2 or 3 maybe)... Its not like having the clock off by a few hours would always cause serious issues, but time issues like this can still impact things in negative ways...
     
  14. linuxgurugamer

    linuxgurugamer

    Messages:
    2
    Same problem with XP

    For the record, I'm running build 5.0.9308, and am having the same problem with XP.

    For now, since I don't like the way that the Windows time service works, I'm using a program called Dimension 4, which lets me specify a bunch of options as to how I want the time to be synchronized.


    JBB
     
  15. StephenA

    StephenA

    Messages:
    36
    I have the same problem. Parallels version 5.0.9310 and Windows 7 (32-bit).

    When is this being fixed? It is a major probem for me.
     
  16. JerryD

    JerryD

    Messages:
    4
    Having similar problems as posted here with Windows XP

    I was having same problems posted here w/Windows XP. Upgraded to Build 9344 and did what this article said but that didn't work. Any ideas besides the registry hack one?
     
  17. naven87

    naven87

    Messages:
    9
    Seems to work after reboot

    I have tried cycling the sync checkbox, or restarting Windows and neither seems to fix the problem. If I shutdown and restart the Mac that seems to solve it. The registry fix mentioned above did not help. Does parallels trap the time sync request and not pass it out but respond with the the Mac time as the sync?
     
  18. StephenA

    StephenA

    Messages:
    36
    This problem still hasn't been solved and is really getting to me now. It is currently 8.43am on Thursday 3rd June. My Win7 VM tells me it is 10.48pm on Wednesday June 1st! Come on Parallels, get an update out and fix this already.
     
  19. StephenA

    StephenA

    Messages:
    36
    Still not fixed. Come on Paralles, what is taking you so long? 6 months ago this issue was reported.
     
  20. LUKES

    LUKES Bit Poster

    Messages:
    19
    Still not fixed

    This in June 23, 2010 . . .

    Come on, Parallels. This can't be that hard, and it is very annoying to have to reset the calendar and clock EVERY time I use Parallels.

    I love the program, but this has gone on long enough . . . . already.
     

Share This Page