Windows 8.1, PD9, Retina MBP with External display - completely unusable

Discussion in 'Windows Guest OS Discussion' started by ErnieS, Sep 13, 2013.

  1. ErnieS

    ErnieS

    Messages:
    5
    I am struggling with PD9 and Windows 8.1. It seems that both Parallels and Windows have worked to remove options rather than add them. I am running a 2013 Retina Macbook Pro with external 1900x1200 displays. With previous Windows 8.0 it was impossible to get anything workable as far as resolution goes, so I ran it with scaled 1440x900 for the retina display which would at least make my external displays look better.

    Now with windows 8.1 and it's new per-display scaling it's a nightmare. There is just no way to get any kind of satisfactory font scaling between the displays. Sometimes a window will have gigantic title bar font and little tiny text inside. Moving a window from one screen to another could cause the text to scramble and become unreadable. Sometimes I have gigantic icons on the desk and a tiny task bar.

    I gave up and went back to scaled graphics. Are there any settings or tweaks that can improve this?
     
  2. Jose222

    Jose222 Bit Poster

    Messages:
    18
    Same here. While other images will have 3 options, with Scaled, Best for Retina and More Space, with Windows 8.1 there is only a check box with Enable Retina Resolution. The experience is icons the size of a quarter of screen, applications looking good and windows start bar not, the other way around. What gives?
     
  3. serv

    serv Parallels Developers

    Messages:
    809
    Windows 8.1 has a new feature: automatic per-display DPI scaling. What Best for Retina option does is it forces 199% DPI, which interferes with Windows 8.1 native scaling. This is why the option is not shown for 8.1 guests. To achieve Best for Retina effect right-click on Windows desktop and choose "Screen resolution", then click "Make text and items larger or smaller". Move the slider in the direction of the smaller scale or even tick "Let me choose one scaling for all my displays" and set appropriate scaling percentage.
     
  4. EllwoodN

    EllwoodN Kilo Poster

    Messages:
    104
    Open up device manager in windows and see what it displays as the
    graphics adapter. If it does not display "Parallels Display Adapter (WDDM)",
    you will need to try reinstalling Parallels Tools. If that in itself does not
    resolve the issue, then you may need to do a manual install of the graphics driver.
    Some 8.0->8.1 upgrades have encountered this issue.

    To Manual install (posted by serv from another thread):
    To update display driver right-click on Microsoft Basic display and select Update Driver Software... from the menu.
    Then press "Browse my computer for driver software", then "Let me pick from a list of device drivers on my computer",
    then "Have disk..." button. Click "Browse..." button and navigate to
    C:\Program Files <or Program Files (x86) for 64-bit Windows>\Parallels\Parallels Tools\Drivers\prl_dd,
    then double click prl_dd.inf file and click OK. Then click Next and confirm driver installation.
     
  5. NikolaosT

    NikolaosT

    Messages:
    1
    I have installed Windows 8.1 Pro on rMBP 2013 (latest) and I'm having exactly the same problem. It looks like a Windows 8.1 problem, rather than a PD9 problem.

    To get native resolution on the external monitor with acceptable readability on the laptop, enable "Let me choose one scaling level for all my displays", select 100% and then decrease the resolution of the retina display down to half its native resolution. By doing so, you achieve the minimal artifacts on your laptop's screen.

    Towards a solution now, it looks like Windows 8.1 fails to recognize the DPI of the external monitor and that's not surprising. If you download a software driver of your external monitor for Windows and open the INF file of the driver (using a text editor like WordPad), you will notice that there isn't any piece of information to reveal the DPI of the monitor (e.g. DPI or screen size on the vertical and horizontal axis) Hence, how does Windows 8.1 Pro automatically set up per-display DPI scaling (with existing monitors) is a mystery to me. Probably, they assume that manufacturers will release new drivers - I'm trying to figure out how this will work and do it by myself.

    As a last-resort solution, Microsoft could let us MANUALLY configure per-display DPI scaling. That would allow us to select 100% scaling for a traditional (96 DPI) external monitor and 200% (or another preferred scaling factor) for the retina display.
     
  6. serv

    serv Parallels Developers

    Messages:
    809
    NikolaosT,

    The easiest way to make Windows readable at 100% scaling on retina screen is to disable retina support here:
    VM Configuration > Hardware > Video > Enable retina resolution.

    BTW, monitor INF files have nothing to do with DPI. DPI is read directly from monitor, and virtual monitors in Parallels Desktop report DPI depending on physical DPI and VM retina support setting.
     
  7. SpuriousTuple

    SpuriousTuple

    Messages:
    6
    I was also having trouble with getting external monitors to look nice with Windows 8.1 and Parallels Desktop 9. This is the solution I used to fix my issue.

    1. Uncheck "Enable retina resolution" in the video settings of the VM.
    2. Change the display resolution to the native resolution of the external monitors in Windows Display Settings.
    3. Verify that under "Change the size of all items", "Smaller - 100%" is selected.

    Thanks for the help, guys!

    -Bob Zurad
     

Share This Page