Windows all grey (whole system greyscale)

Discussion in 'Windows Guest OS Discussion' started by derek68, Oct 23, 2017.

  1. derek68

    derek68 Bit Poster

    Messages:
    26
    I have been using parallels desktop for Mac and running Windows OS for years. All of a sudden when I boot up Windows now everything is completely grey....It looks like it should graphically with respect to the icons and application windows etc. except everything is greyscale instead of colour.

    Has anyone encountered this? I am running:

    Parallels - 13.1.1
    Windows - Windows 10 Home 1709 - 16299.19
    Mac OS - High Sierra 10.13

    Thanks,
    Derek
     
  2. Meenakshi@Parallels

    Meenakshi@Parallels Kilo Poster

    Messages:
    450
    Hello derek68, please follow as suggested below to exit from Tablet mode in Windows virtual machine.

    1.Please Click Settings on the Start Menu.
    2.Select System.
    3.Select Tablet mode in the left pane. A Tablet mode submenu appears.
    5.Toggle "Make Windows more touch-friendly . . ." to on to enable Tablet mode. Toggle it off to go to desktop mode.
    6.Select "Don't ask me and always switch" from the "When this device automatically switches" menu if you want Windows 10 to switch modes on your 2-in-1 without prompting you and check if this helps. Thanks!
     
  3. derek68

    derek68 Bit Poster

    Messages:
    26
    Thanks for your response although I'm not exactly sure how this applies? I have tested what you suggested above but it didn't make any difference.

    To clarify my Windows functions exactly as you would expect what instead of everything being in colour, everything is simply shades of grey. Not sure what changed but the rest of my system is as it should be in colour and no matter what monitor I moved the windows VM to, it is grey.

    Thanks,
    Derek

    2017-10-23_05-43-02.jpg
     
  4. derek68

    derek68 Bit Poster

    Messages:
    26
    Solved----not Sure how this happened but somehow my apply colour filter, toggled... Never been this set up screen before

    2017-10-23_08-58-01.jpg
     
  5. Alfena@Parallels

    Alfena@Parallels Kilo Poster

    Messages:
    445
    Hello @derek68 , Glad to know it is resolved.
    Thanks
     
  6. ShaunP1

    ShaunP1 Bit Poster

    Messages:
    3
    Just experienced the same issue as derek68, which happened while using Bluebeam Revu CAD 2017...
    Windows 10 Pro 1709 16299.19
    Parallels Version 13.1.1 (43120)
     
  7. Meenakshi@Parallels

    Meenakshi@Parallels Kilo Poster

    Messages:
    450
    Hello ShaunP1, please shut down Windows (as opposed to simply suspending it; see http://bit.ly/1OfR3td for details), open the virtual machine configuration window (refer to http://bit.ly/1eQU5lF for assistance), navigate to Hardware -> CPU & Memory and allocate 2 processors (or just 1 if the total number of available processors is just 2) and 2 GB of memory for Windows [or just 1 GB if total Mac memory is only 2 GB (or) 3 GB if total Mac memory is 8 GB (or) 4 GB if total Mac memory is > 8 GB]. Then, select 'Graphics' and allocate 512 MB of video memory for Windows. Finally, ensure that 'Vertical Synchronization' is enabled and 'DirectX 9' is selected for '3D Acceleration' under 'Advanced Settings' and close the window.Thanks!
     
  8. CaseyR1

    CaseyR1 Bit Poster

    Messages:
    4
    Yeah, this happens to me quite often. Just with normal development in Visual Studio. I'll cmd+c something to copy, and I"ll loose all my color. I figured out that if you go back to the desktop and press cmd+c again, the color is toggled back on. This must be because of the way Parallels hooks cmd to ctrl but also keeps it as the windows key. Hopefully they can patch this or someone can tell me a way to disable that window features with a policy or registry hack.
     
    LairdO likes this.
  9. yes this happened with me today. I was in coherence mode, tries to get back to exit coherence using ctrl + cmd + c which is incidentally key combination for "Apply color filter" toggle.
     
  10. CaseyR1

    CaseyR1 Bit Poster

    Messages:
    4
    It is driving me crazy. I don't know if it has to do with Fall Creators Update or the last update Parallels pushed, but it happens ALL. THE. TIME. I'm trying AutoHotKeys to try to hack around the issue. I really hope they can fix this.
     
  11. JohnNash

    JohnNash Bit Poster

    Messages:
    42
    Mine just had this happen as well. easy fix though, thanks Derek.
     
  12. CaseyR1

    CaseyR1 Bit Poster

    Messages:
    4
    What is the fix?
     
  13. JohnNash

    JohnNash Bit Poster

    Messages:
    42
    Posted above by Derek68.
     
  14. CaseyR1

    CaseyR1 Bit Poster

    Messages:
    4
    That's not really a fix because the hotkey still triggers it for me.
     
  15. JamieG1

    JamieG1 Bit Poster

    Messages:
    10
    Ditto not fixed. What's worse is that the behaviour is inconsistent. I develop on Win10 and am using Cmd+C constantly throughout the day and it doesn't always switch the accessibility mode to grey, only sometimes. And Cmd+C doesn't switch it back to colour so I now have to have the Win Settings app docked in the taskbar for quick access. I wish I'd resisted upgrading as this is driving me insane.
     
  16. mdrejhon3

    mdrejhon3 Bit Poster

    Messages:
    24
    I am having this problem because the hotkey triggers it but cannot undo it.

    I don't have this problem on a real Windows box because the same hotkey enables/disables it.

    But in Parallels, the hotkey permanently enables this mode.... and I have to do the goddamn 10-click method to fix it.

    So it is a Parallels bug!

    The hotkey is easily accidentally hit on my laptop, because the Fn key is next to my Command and Ctrl key, and when I meant to do a keypress, I accidentally go mono...

    I go into black and white mode in Paralells 3 times a day and it is making me tear my hair out because of the hotkey bug that only happens only in Parallels 11 on my laptop keyboard!
     
    JamieG1 likes this.
  17. JamieG1

    JamieG1 Bit Poster

    Messages:
    10
    I discovered that this registry key changes state from 0 to 1 when the greyscale mode is activated but changing it back to 0 manually doesn't do anything so I guess Windows needs to be told to "refresh" to get back to colour some how?
    HKEY_CURRENT_USER\Software\Microsoft\ColorFiltering\Active = REG_DWORD = 0/1
    More info on that and the filter to be used here : http://www.thewindowsclub.com/apply-color-filters-windows-10-screen
     
    Last edited: Jan 25, 2018
  18. Ajith1

    Ajith1 Parallels Support

    Messages:
    2,720
    Hi Everyone, you can refer to the article and fix the issue.
     
  19. JamieG1

    JamieG1 Bit Poster

    Messages:
    10
    Thank you for the "workaround" which is a big time saver. Note that it is not however a "fix" as the referred article states "Parallels Desktop Engineering team is currently investigating this issue to come up with the resolution." Note too that the oder of the Fn+Ctrl+Cmd+C combination is important. For example, cmd+Ctrl+Fn+C does not work to toggle the mode.
     
  20. Ajith1

    Ajith1 Parallels Support

    Messages:
    2,720
    Yes, Parallels Desktop Engineering team is investigating you can subscribe to that article to know if there are any updates.
     

Share This Page