Windows ARM64 - seems to boot up

Discussion in 'Parallels Desktop for Apple Silicon (M1) Mac' started by DanO3, Dec 17, 2020.

  1. ChristopherG12

    ChristopherG12 Bit Poster

    Messages:
    3
    I've noted since the Christmas Eve update, my shared networking no longer stays connected reliably. Running the Windows troubleshooter can sometimes return it to functionality, but the networking will later fail again. Just since the latest update.
     
    ScottN57 and DavidM84 like this.
  2. kundanno

    kundanno Kilo Poster

    Messages:
    188
    I don't have this issue. The update works well.
     
  3. DavidM84

    DavidM84 Bit Poster

    Messages:
    4
    I have exactly the same problem. Also. @ChristopherG12 - notice that OneDrive and Windows Update are no longer working with the new update and the new Parallel Tools.
     
  4. kundanno

    kundanno Kilo Poster

    Messages:
    188
    Just to be sure, you are referring to the Parallels Desktop update right? And you are running build 21277 of the W10 Insider Preview?
     
  5. DavidM84

    DavidM84 Bit Poster

    Messages:
    4
    Yes and Yes. Latest Parallels Desktop Update on Win10 21277 / Win10 Insider Preview.
     
  6. stufried

    stufried Bit Poster

    Messages:
    18
    I've had a problem connecting to the internet. I manage to temporarily overcome the problems by dropping to a command prompt and doing a "ipconfig /renew."
     
  7. AlexeyY1

    AlexeyY1 Bit Poster

    Messages:
    53
    Just updated to a newer version of Parallels. The internet inside the virtual machine is working fine, Windows update is also working. Maybe because when I updated, the Parallels tools inside the virtual machine were automatically reinstalled as well?
     
  8. ChristopherG12

    ChristopherG12 Bit Poster

    Messages:
    3
    I'm finding it's intermittent. Sometimes it finds its IP address from the "shared" host, sometimes not. Doing an ipconfig /renew will generally make it work again - or sometimes running the Windows troubleshooter on it will correct it temporarily. Sometimes just shutting down Windows and restarting it will get it to pick it up correctly. It seems related to getting its IP info from Parallels (the Mac) is what isn't working consistently since the last Parallels update.
     
  9. ChrisW38

    ChrisW38 Bit Poster

    Messages:
    17
    I have updated to the latest versions of Parallels Version 16.3.1 (50393) Technical Preview seems to be working a lot better.
    Windows ARM is more stable, still having the known ARM32 issues with the Microsoft Store. I did follow the thread to try and replace the incompatible version of the store program with a ARM64 or X86 version without any positive result. If there is another solution or if someone has managed to replace the Microsoft Store with a ARM64 bit version or X86 version please share. On a positive side Office 365 works great with one drive. Again given the early release this combination is still a great achievement.
     
  10. PeterS68

    PeterS68 Bit Poster

    Messages:
    13
    Does anyone else have an issue with no sound from Windows?
     
    RuslanG2 likes this.
  11. kundanno

    kundanno Kilo Poster

    Messages:
    188
    In the parallels desktop VM settings change the default audio device to MacBook speakers.
     
  12. stufried

    stufried Bit Poster

    Messages:
    18
    I've been having that problem. When I do an ipconfig, I get a 167.XXX.XXX.XXX IP address which basically means I am not connected to the net. A quick ipconfig /restore seems to do the trick.
     
    smithsj2318 likes this.
  13. smithsj2318

    smithsj2318 Bit Poster

    Messages:
    2
    I am also having this issue. Seems to have started after the last release of Parallels.
     
  14. AleksandrA1

    AleksandrA1 Bit Poster

    Messages:
    2
    Как можно русифицировать данную версию винды? В настройках там только английская версия.
     
  15. yrygvay

    yrygvay Bit Poster

    Messages:
    2
    зайти в настройки языка и скачать русский языковой пакет
     
  16. RuslanG2

    RuslanG2 Bit Poster

    Messages:
    2
    Installed Windows 10, works fine, even launched half-life 1 :D
    The only problem is no sound. No sound in from mic, no sound out to speakers, just nothing.
    anyone knows how to solve it?
     
  17. io_2000

    io_2000 Bit Poster

    Messages:
    11
    With the Windows 10 window selected, from the MacOS menu bar choose DEVICES... SOUND OUTPUT... MACBOOK <air/pro> SPEAKERS.
     
    Mike Boreham likes this.
  18. RuslanG2

    RuslanG2 Bit Poster

    Messages:
    2
    Didn't work for me. Still no sound.
     
  19. AleksandrA1

    AleksandrA1 Bit Poster

    Messages:
    2
    Я не могу понять, где это находится то, что нужно скачать. Захожу в выбор языка, и там только выбор английский, без вариантов.
     
  20. JatinS1

    JatinS1 Bit Poster

    Messages:
    1
    Ran with Technical preview of windows 10 arm. Worked with tell tale games - monkey island . Only issue I had was installing directx 10, it had to be restarted twice before it recovered itself. I then installed the game itself and this worked with graphics and sound.
     

Share This Page