Windows File Associations Not Working

Discussion in 'Windows Guest OS Discussion' started by joco, Jul 10, 2007.

  1. gary

    gary Bit Poster

    I have the same problem. It could be that file associations are incorrect for many file types but the main ones I use and have noticed are PDFs and Excel XLS files. They show up with incorrect icons and file descriptions (pdf_auto_file and xls_auto_file). I was able to fix those 2 by changing the following in the registry:

    (Default) - change to "AcroExch.Document" (was pdf_auto_file)

    (Default) - change to "Excel.Sheet.8" (was xls_auto_file)

    That gets the association working with the correct file description and icon. I think similar associations are in HKEY_CURRENT_USER; I didn't need to change those in my case.

    It's a workaround that worked for me although I would still prefer this to be fixed so I don't need to change this for other file types.
    Last edited: Feb 4, 2008
  2. Steve Rea

    Steve Rea

    Files get corrupted too!

    We're having a similar problem with Parallels build 5584 with Windows XPS P2, under Mac OS 10.5.2, with Excel 2008 for Mac.

    Browsing the file server (another XP box, we're putting in a Mac server next week) in Windows, opens the files in Excel for Mac, then when saved back on the server, the files get corrupted and cannot be opened again, on any computer, including a regular PC. We're getting either a generic "unable to read file" or it brings up the open box and then doesn't.

    It's leaving behind a file 4k file names "._<filename>" which is also listed as a "xls_auto_file".

    How can we stop the files from getting corrupted, and is there any way to uncorrupt the files that it already corrupted??
    Last edited: Mar 10, 2008
  3. Xenos

    Xenos Parallels Team

    Hello Steve Rea,

    This seems to be Mac Office and Office 2008 compatibility issue. Please ask Apple and Microsoft support.

    Best regards,
  4. Gizzer


    This is my first post, and it's taken me over an hour of searching the internet to finally find the solution to the problem! (I was searching MSDN, Google etc. for 'Office File association', 'Windows file associations not working' and so on...). It was only when I typed in 'xls_auto_file' that the results brought me here, as the last thing I expected was that it is Parallels causing the problem, not Windows.

    At any rate - post #61 by 'Gary' completely solves the problem.

    Initially I thought that it was limited to just Office file associations, but Gary's post highlighted to me that others (e.g. .pdf files) are also affected. Essentially it seems to be all file types that may have a Mac equivalent. In my case, Excel, Word, Powerpoint, Acrobat docs were affected. However Microsoft Access, Publisher, OneNote files all were ok (I guess because there is no Mac equivalent application). Parallels must overwrite the associations to be helpful but it seems to mess things up in the process.

    I would like to add a few points though to help future users:

    If trying to fix Office 2007 file associations as per post #61 I suggest amending all of the following additional registry entries.

    .docx from 'xxx_auto_file' to 'Word.Document.12'
    .dotx from 'xxx_auto_file' to 'Word.Template.12'
    .xlsx from 'xxx_auto_file' to 'Excel.Sheet.12'
    .xltx from 'xxx_auto_file' to 'Excel.Template'
    .pptx from 'xxx_auto_file to 'PowerPoint.Show.12'

    That covers both the main document formats, plus their templates.

    In addition, I've also noticed that things like .doc, .dot, .xls, .xlt and others have also been overwritten to the _auto_file setting.

    Finally I also noticed that if you create another user account in Windows (I'm using XP Professional SP2) then all of the file associations work correctly!!! It only seems to be the Administrator account that Parallels creates that seems to be broken.

    Also, knowing this means that if you find a file association not working and you don't know what the correct entry should be, create another User Account in Windows, then fast switch to it, check it's registry entry, then use that to fix the entry under the broken account.

    Apologies for a long (but hopefully useful) first post!!
  5. Xenos

    Xenos Parallels Team


    Gary and Gizzer, thank you for posting your workarounds here.
    Did you try to update MacFUSE before?
    Just curious...

    Best regards,
  6. Gizzer


    I've not tried the MacFuse solution (couldn't really work out what it was for!)
  7. Xenos

    Xenos Parallels Team

    Hello Gizzer,

    Parallels uses MacFUSE to provide Mac - Windows interaction. When MacFUSE version gets outdated for Mac OS X with the latest updates, file associations problems might occur. So updating MacFUSE helps to eliminate these problems.

    Best regards,
    Last edited: Mar 21, 2008
  8. alexg

    alexg Parallels Developers

  9. alexg

    alexg Parallels Developers

    You may try to create a .bat file and drop the following text into the file, then run it under dos prompt

    REM Restores MS Office File Type Associations
    assoc .doc=Word.Document.8
    assoc .dochtml=wordhtmlfile
    assoc .docmhtml=wordmhtmlfile
    assoc .docxml=wordxmlfile
    assoc .dot=Word.Template.8
    assoc .pot=PowerPoint.Template.8
    assoc .pps=PowerPoint.SlideShow.8
    assoc .ppt=PowerPoint.Show.8
    assoc .rtf=Word.RTF.8
    assoc .wbk=Word.Backup.8
    assoc .xlc=Excel.Chart.8
    assoc .xlm=Excel.Macrosheet
    assoc .xls=Excel.Sheet.8
    assoc .xlt=Excel.Template
    assoc .xlw=Excel.Workspace

    Or you may try to use the attached file and rename it to a .bat file

    Attached Files:

  10. JackC136


    It seems I have the same problem and was wondering if someone can provide step by step instructions on creating the .bat file and running it under dos prompt
  11. Xenos

    Xenos Parallels Team

    Hello JackC136,

    Please sorry for the delay.

    You should create the file in a text editor and save it as a plain text file, with .bat ad-on.

    To run it under dos prompt click Start menu, choose "Run" and type CMD, press Enter. In the prompt type the path to the .bat file and press Enter.

    Best regards,
  12. kevinherring


    still no fix?

    Are we actually ever going to get a proper fix for this? I am using version 5608 and the problem still exists. I have Office 2007 installed on the VM, and Office 2008 installed on OS X. (I just did a new vm, fresh windows xp + office 2007 install)

    Although the work-arounds sort of work, they aren't great. For example although I can associate xlsx with Excel 2007, the icon is wrong and it still describes it as an xlsx_auto_file.

    Before I did the above workarounds, when I selected (for eg) Word 2007 in the SmartSelect->Edit window, there was no option for .docx etc, only .doc (which worked fine). The workarounds did add them to SmartSelect, but the icon and description are still wrong.
    Have installed MacFuse.
  13. John@Parallels


    Yes, we are going to fix this, we are established test case, and if any one can provide information it would be helpful

    1. Was Microsoft Office installed after or before Parallels Tools installation
    2. The same is for pdf
  14. kevinherring


    Thanks for your reply John.
    Office was installed after Parallel Tools. This VM is just for running Office in OS X so I haven't installed anything else.

    It looks like I had a similar idea to you yesterday:
    I created a new VM, and made sure I turned off coherence, application and file sharing.
    Installed windows
    Installed Tools without coherence, and app and file sharing. all good.
    Installed Office.
    turned on coherence, install Tools with coherence.
    turned on app sharing & file sharing, install Tools with app & file sharing.

    So far all looks good. I did take a snapshot at each stage so that I could go back, but the dreaded _auto_file never appeared.
  15. John@Parallels


    Thank you kevinherring, very helpful, it will take some time (3-5 days), and I can create fully documented test case
  16. TonyRich

    TonyRich Bit Poster

    I thought it was me

    I have been following this thread for months, but when the entries stopped appearing (but I still had the problem) I thought it must just have been me! Thanks, Kevin, for letting me know there are others still out there. I have managed to work my way around the problem most of the time (although I shouldn't have to), except when using VBA macros that open xls files (xlsb files work fine). I look forward to the promised fix from John.
  17. John@Parallels


    Tony, I established test case now to identify problem, I haven't promised fix yet, agree that something is out there, but is it a bug I need to clarify it first
  18. Bill


    Any luck

    Hey, I'm late to this discussion but I was just wondering if any progress has been made on this yet. I'm also pulling my hair out over these crazy auto_files. I have a clean install of Windows and Parallels on a couple of machines that are using Sabre, a flight-booking website, that use some Windows-specific Java to get things done. The problem is when I try to download the .jnlp file for the site, Parallels calls it a jnlp_auto_file and then can't open it anymore, even if I associate the file manually to javaw.exe. I don't have any smart select options turned on anymore, I removed and reinstalled Parallels Tools, I can't seem to get it to stop calling these files it's downloading jnlp_auto_files. Is it actually changing the the file that it won't even open when I manually use javaw.exe?
  19. macguy

    macguy Bit Poster

    Still a Problem in Build 5608

    I am late to this discussion but I am having the same problem with xls files. Changing the file association so that Excel will open the file when you double-click on it only partially solves the problem.

    Other applications which access excel files such as Adobe Acrobat can't open the excel files because it sees them as xls_auto_file instead of plain vanilla xls files.

    I am having to use VMWARE FUSION because of this problem.

    Is it EVER going to be solved? Parallels seems to have been working on it almost a year now and I don't see any solution in sight.
  20. John@Parallels


    Delete HKCR\.xls and replace with this

    Windows Registry Editor Version 5.00

    "Content Type"="application/"










Share This Page