Windows File Associations Not Working

Discussion in 'Windows Guest OS Discussion' started by joco, Jul 10, 2007.

  1. wonder_mice


    I'd like to provide temporary solution for people experiencing problems with .lnk/.exe/.com/.bat file associations in guest Windows (conflicts with Wine Helper, Unarchiver or other Mac OS X apps that can open .lnk/.exe/.com/.bat).
    In the attachment you will find fixwinexts.reg file inside the archive.
    1. Extract it and copy into guest OS.
    2. Run it (double-click on it).
    3. Answer "Yes" on question "Do you want to ...".
    That's all, now .lnk/.exe/.com/.bat file associations must be fixed.

    Attached Files:

  2. PeteM


    Yes, wonder_mice is correct in that the file associations can be fixed thru the registry of the Guest OS. For some reason the registry gets confused & file associates with native applications on the local OSX (ie *.lnk with after an upgrade or update of your parallels virtual machine. Unfortunately I cant explain the exact cause for this.

    Here are some links to fix your Win Vista (also tested on Windows 7) virtual machines

    lnk fix
    exe fix
    com fix
    bat fix

    1. Extract it and copy into guest OS.
    2. Run it (double-click on it).
    3. Answer "Yes" on question "Do you want to continue?".
    *.lnk/.exe/.com/.bat file associations should be fixed.

    Hope this helps anyone that experiences these problems. Remember this fix only works for Win Vista and 7
  3. Rob G

    Rob G

    Solution to Office file association problem


    I'm not posting this to help Parallels (whose support seems to quite poor), but to help others who have been struck by the lack of proper file associations when using Office 2007 in the guest OS. After lots of searching, I eventually found that Parallels have added an article to their knowledge base. I followed the instructions, and it solved the problem for me.

    Now, wouldn't it have been nice for someone from Parallels to actually post a link to that article here? Since they didn't, here it is:

  4. Mark Litherland

    Mark Litherland

    Well the last thing I thought it would be is a Parallels issue, but after going around the bend with MS it turns out it IS a Parallels issue. Apparently when I used the quick setup, it associated applications to the Mac which is exactly the wrong thing to do! Now I've got to piecemeal my file extensions back together, what an incredible pain! Please correct this and if nothing else, provide a utility to undo all those ass-backward Mac associations! Many of us use BOTH operating systems and I'll say it, MS Office on Windows is much superior to the Mac version.
  5. SJR


    "open with..." still fails to open Windows files on Mac

    I am disappointed that the latest release (5.0.9308) has not fixed my problem.

    Right-clicking on ANY file in Windows XP VM and selecting "open with..." opens the Mac app fine, but doesn't load the actual file I right-clicked on!

    This was working fine in the v5.0 beta but hasn't worked since the official release.

    Please can someone come up with a fix for this - I have to resort to opening the VM disk on my desktop and selecting the file I wish to edit from there (which works), but I would much rather right-click and 'open with' as I have always been able to do prior to the release of v5.0.

    See the following screenshots for a perfect example of the problem:

    Click for full size - Uploaded with plasq's Skitch

    Click for full size - Uploaded with plasq's Skitch

    Please can we have a fix or workaround for this bug soon? Thanks.
  6. cdenesha


    STILL not working in latest update to PD4

    In reply to post #117 by wonder_mice, this is STILL not fixed in the latest PD4 update as promised, 4.0.3848 (October 14, 2009).

    I'm running Snow Leopard 10.6.2 on a Late 2008 Macbook Pro. I created a VM manually, turned on High Security, and made sure Shared Folders, Shared Profile, and Shared Applications were all off. I then installed Win2000 Pro into the VM and took a snapshot.

    All is well after the install. I did not apply any updates, but immediately installed Parallels Tools. Lo and behold, there are dozens if not hundreds of file associations for xxx_auto_file, plus 64 applications in Programs -> 'Parallels Shared Applications'.

    I'd like to reiterate a common sentiment in this thread - I want my Guest OS totally separate from my Host. By forcing this on your users, perhaps in an attempt to make things 'easier', you remind me of the way Microsoft takes control away from users in their Home products. (This is also evident in the way Coherent Mode is the default even for guest VMs I specifically mark as Windowed and then bring to another install of Parallels).

    Please just make it a custom install option in your Parallels Tools installer if you want to make it 'easy' for the majority of users. I need the ability to TURN THIS OFF PLEASE!

    thank you,


    [Update 2/1/2010] Rereading this, I see I was a little too strident, not to mention sarcastic. I do want to use an application that works the best that it can. I do not see a way to log a bug report on this, just paid support options. If I am missing something, please point me in the correct direction? Also, if I can be of any help in troubleshooting this, please let me know. thanks, chris
    Last edited: Feb 1, 2010
  7. I am now having this same problem. The correct Mac application is launched, but the no file is opened. This occurs for Microsoft Word, Excel, TextEdit, etc.
  8. TonyRich

    TonyRich Bit Poster

    is it fixed in version 6?

    Now that Parallels are trying to get us to buy v6, I was wondering if they have ever gotten around to fixing this problem? It was not fixed in the many updates to v4 nor in v5 and updates. I won't be buying v6 until I can see that they have done something about this problem (which doesn't require the user to fix the problem manually to get around the problems created by Parallels).
  9. SJR



    This bug now appears to have been fixed in Parallels 6
  10. SietseK


    I have Parallels 6 and for me the file association issue is not solved. Testing new software that tries to launch pdf and html-files I find that pdf-files are not launched and html-files do launch well. Trying this on a 'real computer' pdf-files do launch. Trying it in a vm within virtual box (!) pdf-files do launch. So, is it Parallels? I think so.

    The program is written in Delphi 9.
    These are the instructions:
    ShellExecute(Handle, 'open', PChar(myRoot + 'Handleiding.pdf'),nil,nil,SW_SHOWMAXIMIZED); -> does not work with Parallels!
    ShellExecute(0, 'open', PChar(Browser), PChar(URL), nil, SW_SHOWMAXIMIZED); -> does work well with Parallels!
  11. macguy

    macguy Bit Poster

    I am running Parallels Desktop Version 6.0.11994.637263. I recently installed Adobe Acrobat 9 on my VM. Normally Adobe Acrobat recognizes a wide range of file types as supported files (i.e., Adobe can automatically convert those files to PDF's - these file types include all versions of Word documents and Excel documents, plus many others.)

    However, in Parallels Desktop, Adobe Acrobat does not recognize Word Documents and Excel Files as supported file types, and thus one of the most important features in Adobe Acrobat, the ability to automatically convert a set of mixed files types such as word document, excel files, etc, to a single PDF document, is unusable in a VM in Parallels Desktop.

    This is clearly yet another manifestation of the file association problem others are having with the current build of Parallels Desktop.
  12. SietseK


    And now?

    It would be nice to hear from the folks at Parallels whether they recognise the problem and if so, if they are planning to do something about it. It's a strange situation to have to use Parallels and VB side by side. I'd prefer to use Parallels only...
  13. SietseK


    Yesterday I installed Build 6.0.12090. Hmm, the list of improvements doesn't say anything about the File Asscociation problems. But, who knows...
    Alas, all the mentioned improvements are important no doubt about that, but the file association is still not working.

Share This Page