Windows idle but prl_vm_app at 22%?

Discussion in 'Installation and Configuration' started by Shaddam IV, Jan 26, 2010.

  1. skechers

    skechers

    Messages:
    6
  2. ggarcia

    ggarcia

    Messages:
    1
    I'm in a similar boat. Parallels 6.0.11822 with Windows 7 32 bit VM. I have about 20% CPU load from prl_vm_app while Windows is idle. This drains the heck out of my MacBook battery life. Has anyone found a solution to this?
     
  3. Scrubjay

    Scrubjay

    Messages:
    4
    pri_vm_app at 38 percent

    While browsing for instructions on how to install a gutter using Chrome in OS X, I got a warning message that my iMac had been infested by trojans and I should go immediately to my security software. I noticed a little download "inst.exe" dropping to the bottom of the browser window. I looked around and didn't see any way to start up Kasperski to look for viruses, so I just tossed the contents of my download folder in the trash and emptied the trash. Then I got to wondering if I could find any evidence of a hijack in the Activity Monitor. The window showed nothing taking up more than 2 percent. Parallels was there but doing much. Out of curiosity, I started up Windows XP and was startled to see that the little prl_vm_app program (? perl virtual machine app) was using 38 percent. I shut down Windows XP and the CPU usage by Parallels went down to 0. Clicking on the Parallels icon can drive it up to 2 percent, but that's it. I haven't noticed any slowdowns while using ArcMap, which must take a lot of memory and processing, in XP. I haven't noticed excessive disk access, but maybe the disk is just quiet.

    It's nice to know people are working on this.

    3.0 GHz dual core iMac
    6.0.11822
     
  4. rogersss

    rogersss

    Messages:
    3
    I have the same problem here with Build 6.0.11826. I hope they will fix it as quick as possible.
     
  5. iwant2playpc

    iwant2playpc

    Messages:
    1
    Same problem, different version

    Activity Monitor indicates 60 percent CPU usage. Brings my Intel Core 2 duo 2.8gHz with 4 gigs of RAM to a grinding halt. Running Mac OS 10.6.5, Parallels 6.0.11828.615184, and Windows 7 Home Premium. More worrisome, Activity Monitor indicates (and my ears confirm) continuous disk access, for long periods of time. Activity Monitor also indicates my virtual memory is nearly 500 gigs!

    My antivirus software is Security Essentials from Microsoft. The Task Manager indicates almost no activity.

    It would be nice if Parallels would at least admit they have a problem, and they are working on it.

    I have stopped using Parallels due to the fear of frying my hard drive.
     
  6. Shaddam IV

    Shaddam IV

    Messages:
    626
    Hello,

    even a CPU activity of 60% should not bring your Mac to a grinding halt. What's more likely is that your Mac's memory is being swapped to disk (which is why you hear continuous disk activity). In that case, even though the CPU isn't doing much (60% is not much; since you have 2 cores, 200% would be the maximum), it needs to wait for the disk to deliver data.

    Virtual memory 500 gigs is nothing to worry about - it's just an indicator how much memory the individual programs think they have. What's a better indicator of virtual memory usage is a) the swap file size and b) how often the Mac needs to swap memory to that swap file. You can see this in Activity Monitor in the "disk activity" tab. The red line shows how much stuff is being written to disk. If there's a lot of that you're in trouble somewhere.

    The main reason for excessive disk activity with a VM is if the VM's memory settings are high relative to the host's (your Mac's) on-board memory. With 4 gigs of RAM on your Mac, try not to go beyond 2 Gigs of memory on your VM; all in all this will take about 2.5 Gigs or so from your Mac's main memory (VM memory and some Parallels overhead). Since your Mac's system also needs memory (and if you have onboard graphics, that will chop off yet another 256 MB or so), this would leave about 1 Gig of usable memory on the Mac side - enough for email and Safari, but not much else. If you want to do more things on the Mac while running Parallels, reduce the amount of memory for your VM even further. Windows 7 will run ok on 1 Gig of memory (on my 2 GB MBAir, I've been running it in 768 kB of memory and that is still ok. If I go beyond 768 kB, I get lots of swapping and a very slow Mac.)

    Good luck!
     
  7. bizdevguy

    bizdevguy

    Messages:
    1
    Freeze First

    I have had this problem forever but have found it is far less likely to happen if I pause the VM (XP sp3) before putting Snow Leopard to sleep. XP was always awful at the sleep/wake cycle so it should come as a surprise.

    I do wish I knew what it was doing when it jumps to 22% but I don't think it is anything that Parallels can do anything about.
     
  8. James Holcomb

    James Holcomb Bit Poster

    Messages:
    17
    Same problem. Mac OS X 10.6.6, Windows 32-bit, MacBook Pro 2011 QuadCore, 8GB RAM
     
  9. ben_

    ben_

    Messages:
    1
    I have the same issue on my 13" MBA, 2.16ghz c2d + 4gb of ram.

    I've experienced it with a win2008 r2 x64 vpc and a win7 x64. The only things installed on the win7 one is Visual Studio 2010 w/ Resharper and MS Security Essentials for AV, but the problem existed before installing anything at all. The win7 one replaced win2008 after I noticed the cpu usage problem on that vpc.

    I have all updates installed for OSX & Parallels.
     
  10. SefP

    SefP

    Messages:
    7
    Here's what FIXED it for me... but who knows why.

    OK...

    I've been furiously trying to replicate the problem, after having turning down a lot of VM options. And well.... I can't. At least not like before. I turned off everything (CD/sound/ether.etc) but HD access, dropped the VM avail. RAM to about 50 percent of system total. Note: RAM (will become wired RAM in Mac).

    Like everyone else... I had unreasonably high %CPU usage (Mac Activity Monitor) by prl_vm_app, while the XP machine wasn't doing 'jack.' I thought, Antivirus scan? Time machine? Program update check? No, No, No. Xp wasn't doing anything more than 4% CPU at any point.

    But. I am now NO LONGER seeing any of this high CPU activity after Fiddling with settings. I've turned back ON everything, and reconnected all "peripherals" CD/Net,etc. EXCEPT:

    Sharing>SmartMount: NO,
    Sharing>Access Windows Folders from Mac: NO
    Applications>Share Windows Applications with Mac: NO
    One of these settings also prompted that Crystal Mode will be turned OFF.... so it's off.

    I don't know people. I'm much happier using my setup now... the processor is no longer swamped, but I don't know how what I did fixed it. The only final suspect item I wonder about is if Windows Updates was running in the background.... there were many updates installed with the first shutdown.

    If any of the Shared> settings help anyone else out, great. Otherwise, still a mystery.

    Sef.
     
  11. sjt

    sjt

    Messages:
    2
    I'm running Snow Leopard 10.6.7, Parallels 6.0.11994 and Windows 7 with latest patches and the prl_vm_app runs at 5 to 80% CPU even with Parallels not running. Like other users this is frustrating and annoying. The prl_vm_app process significantly impedes my workflow.

    As this seems to be an ongoing issue (I think I read a thread dated 2009) I am going to uninstall Parallels, contact support and ask for a refund. I think others should consider this option as well.
     
  12. James Holcomb

    James Holcomb Bit Poster

    Messages:
    17
    Did you test putting your Mac to sleep and waking it to see if your VM settings changes continued to help?
     
  13. sjt

    sjt

    Messages:
    2
    Thanks for the reply James, yes I did try that. In fact I tried everything the manufacturer suggested, plus what's on this forum plus more. The only thing that worked was uninstalling Parallels and booting Windows in Bootcamp.
     
  14. James Holcomb

    James Holcomb Bit Poster

    Messages:
    17
    This issue seems to be directly related to the number of processes you're running in Windows. Here's how to reproduce:

    1. Clean boot into Windows 7, Task Manager, System Idle at 98-99%
    2. Activity Monitor in Mac shows prl_vm_app @ 6-8%
    3. Start VS2010, Visio, Outlook 2010, Word, Excel, Explorer, IE9, Chrome
    4. Wait until all apps loaded, Task Manager, System Idle @ 98-99%
    5. Activity Monitor in Mac shows prl_vm_app @ 25-35%
    6. Close all Windows apps
    7. Activity Monitor in Mac shows prl_vm_app @ 6-8%

    This is on an 8GB MacBook Pro (4 core i7) Snow Leopard 10.6.7, 3GB allocated to Windows 32-bit VM. I've tried almost every VM config setting (changing memory allocations, CPU allocations, optimize for windows, isolate windows) and it makes no difference.

    Can someone else give this a shot to repro?

    Parallels support, please reply!
     
  15. James Holcomb

    James Holcomb Bit Poster

    Messages:
    17
    I opened a ticket with Parallels support, but I'm not hopeful. So far, they're only remarkable suggestion has been to reduce my # of CPUs down to 1 for the guest OS. Clearly that does more harm than good. CPU utilization is lower in this configuration, and performance along with it. Attached image shows 1 vs 8 CPU configuration using PerformanceTest, purely as a metric (i's probably not optimal to put all CPUs to the VM). However, my configuration demands as much CPU/disk resources as can be had in Windows, not on the Mac side.

    I also tried creating a Windows 7 x64 VM from scratch just for grins, messing around with 1G to 4G memory allocations. Exactly the same results. Each time a new application starts and the VM experiences memory pressure, Activity Monitor shows the Parallels task eating more and more CPU.

    I only really started noticing this because the 2011 MacBook Pros get so hot. Any CPU utilization and the fans start maxing out. The previous MBP did not require as much cooling, so i never noticed it.

    Anyone else out there with a 2011 MBP?
     

    Attached Files:

  16. James Holcomb

    James Holcomb Bit Poster

    Messages:
    17
    I believe I've finally figured this out. The culprit is Google Chrome. Both 11 (and the beta 12) versions have this issue in PD 5 (not sure about PD 6, I won't be upgrading until PD 7 which is in Beta right now). Even though Task Manager shows 99% idle when Chrome is running, CPU util jumps by 40%.

    Quite unfortunate. Looks like I'm back to IE9 :-(
     
  17. RalfZ

    RalfZ

    Messages:
    2
    Solution from the Parallels support

    From the Parallels support I got the following solution to prevent "prl_vm_app " eating most of the CPU resources:

    - Reduce the ram size to 2 GB.

    - Set the 'CPU' value to 1.

    - Make sure that 'Enable Adaptive Hypervisor' and 'Tune Windows for speed' is checked.

    - Choose performance as 'Faster MAC'.

    - Make sure that 'SmartMount' is checked.

    For me it works. :)
     
  18. Scrubjay

    Scrubjay

    Messages:
    4
    Please expand a bit on solution

    Thanks for posting the solution. How does one go about doing all this? Somewhere in the Mac? In Parallels? in Windows?

    ********************
    Solution from the Parallels support
    From the Parallels support I got the following solution to prevent "prl_vm_app " eating most of the CPU resources:

    - Reduce the ram size to 2 GB.

    - Set the 'CPU' value to 1.

    - Make sure that 'Enable Adaptive Hypervisor' and 'Tune Windows for speed' is checked.

    - Choose performance as 'Faster MAC'.

    - Make sure that 'SmartMount' is checked.

    For me it works. :)
    **********************
     
  19. James Holcomb

    James Holcomb Bit Poster

    Messages:
    17
    Yes it works, but your performance in Windows will be dramatically reduced. See the previous post that includes attachments showing a Windows VM benched at 1 CPU vs 8 CPU.
     
  20. RalfZ

    RalfZ

    Messages:
    2
    The entire resolution

    This is the entire resolution from the support:

    .Stop the Virtual Machine.

    .Do not quit the Parallels Desktop application.

    .Right click on the Parallels Desktop icon on dock.

    .Choose 'Virtual Machine list'. Now Virtual Machine list box will appears to you.

    .Choose the Virtual Machine and right click and select 'Configure'.

    .Now configuration Window will appears to you.

    .Choose 'General' Tab.

    .Now reduce the ram size to 2 GB. To do the same move the the slider or pointer.

    .Now set the 'CPU' value to 1.

    .Now choose the Options Tab , top of the configuration Windows.

    .Choose the 'Optimization' in the left pane. Make sure that 'Enable Adaptive Hypervisor' and 'Tune Windows for speed' is checked.

    .Choose performance as 'Faster MAC'..

    .Again open the configuration Windows and choose the 'Options' tab. Now choose 'Sharing' and make sure that 'SmartMount' is checked.

    Now start the Virtual Machine and check the status of the issue.
     

Share This Page