Windows is very sluggish

Discussion in 'Windows Guest OS Discussion' started by AlekseyM2, Dec 3, 2019.

  1. utkarshk

    utkarshk Bit Poster

    Messages:
    2
    There are many reasons behind it. You can disable Windows Defender from your PC to resolve problem
     
    Maria@Parallels likes this.
  2. AlbertoM6

    AlbertoM6 Bit Poster

    Messages:
    11
    I decided to run my Parallels VM in a HFS+ filesystem because of this, precisely.
     
  3. artemsyd

    artemsyd Bit Poster

    Messages:
    1
    I had the same issue. At some point after I updated to v15 (or perhaps after updating host Mac OS, can't say for sure), Windows guest machine started to behave "sluggish": from time to time any operation could take quite a long time, then there would be a period of everything working fine, and then sluggish again. At the same time, Linux guest machine was working absolutely fine.

    I tried allocating only one processor, I tried switching to Apple hypervisor - nothing helped. But then I saw a recommendation here in the thread to add Parallels machines folder to exclusions of Spotlight (Privacy tab), and after that the issue was gone! So I am a happy camper now, big thanks to those who shared this recommendation.
     
  4. utkarshk

    utkarshk Bit Poster

    Messages:
    2
    You can disable it by following article
     
    Last edited by a moderator: May 11, 2021
  5. IanS15

    IanS15 Bit Poster

    Messages:
    1
    I've just tried this and it worked a treat, a big thank you for the tip.
    Cheers
    Ian
     
  6. TheodK

    TheodK Bit Poster

    Messages:
    35
    Dear all,
    This worked indeed >>> Disable Spotlight searching the Parallels VM directory at the Privacy tab.
    Many thanks to the users (!!!) who found this.
    Theo
     

Share This Page