Windows Task Bar Flashes

Discussion in 'Windows Guest OS Discussion' started by JayM, Dec 24, 2009.

  1. JayM

    JayM Bit Poster

    Messages:
    5
    After downloading latest Parallels 5 update, I can't fully remove the Windows Task Bar. I am running latest Windows 7 64bit on latest Parallels 5 on latest Snow Leopard in Coherence (same thing happens in Crystal). I have set View -> Hide Windows Taskbar. The taskbar the sort of hides: I can see only a thin line. After awhile it goes away. And it's not just "auto-hidden" because mousing down to bottom of the screen does not reveal the task bar--so far so good.

    But here's the problem: every minute or so the task bar flashes (just the horizontal line as if it's in auto-hide mode). It happens when I'm not even doing anything. Why would it do that? And can it be stopped?
     
  2. JayM

    JayM Bit Poster

    Messages:
    5
    turning off auto-hide task bar from within Windows seemed to fix it.
     
  3. JeffL

    JeffL Bit Poster

    Messages:
    5
    I have the same issue, but I've never turned on the auto-hide option. Guess I'll try turning it on and then off again to see what happens.
     
  4. petrovv

    petrovv

    Messages:
    38
    Hello JayM,
    it is good that the problem has disappeared. But I want to know some information to understand the cause of the problem. Could you help me? May be some especial programs are installed in your guest OS? What programs are running when you see these 'taskbar flashes'? Can you see these flashes when you've just started your guest OS (and no apps are running yet)? Can you see these flashes in windowed mode if you hide taskbar?
     
  5. petrovv

    petrovv

    Messages:
    38
    JayM,
    Is 'Do not use Dock area' checkbox is set up for your vm? (This checkbox is placed in Configure.../Options/Crystal&Coherence)
     
  6. JayM

    JayM Bit Poster

    Messages:
    5
    Yes "Do not use Dock area" is checked. Flashes do not occur in Windows mode, only in Coherence and Crystal. Flashes occur right after starting Windows (without any other apps running). Only occurs when Windows auto-hide taskbar checkbox is set. When I uncheck it, they go away.

    Also, there is something that is causing this Windows setting (auto-hide taskbar) to get checked automatically. Whenever I restart Windows (within Parallels) or switch modes from Windows mode to Coherence or Crystal, this Windows setting goes back to be being checked and I need to manually uncheck it.
     
  7. JayM

    JayM Bit Poster

    Messages:
    5
    'Do not use Dock area' is checked. Problem does not occur in Windows mode. Problem occurs right after starting Windows (no other apps running). Problem only occurs when the Windows setting auto-hide task bar is checked. I noticed this problem after installing latest update to Parallels 5. I also noticed that the Windows setting auto-hide taskbar gets checked automatically each time I start Windows and each time I switch modes (even if I uncheck it).
     
  8. JeffreyP

    JeffreyP

    Messages:
    16
    he is not the only one. since upgrading 2 computers to the latest 9308 (both running win7) I see the flashing line on both of them. I dont have autohide on but will try that, i can only say that the upgrade did not go well on either machine and hope that parallels can find the time to do some testing before squeezing out the next one...
     
  9. Gene Makarevich

    Gene Makarevich

    Messages:
    2
    I just upgraded today and am now getting the flashing task bar. I have to virtual machines, one XP, one Windows 7. It seems to be happening on the Windows 7 machine only. I've unchecked auto-hide and have found that flashes when in Coherence mode. In Crystal mode, it does NOT go away.

    I had no problems prior to this upgrade.

    Any help Parallels???
     
  10. Gene Makarevich

    Gene Makarevich

    Messages:
    2
    I just upgraded today and now have the same flashing task bar problem. I have two machines, one XP, the other Windows 7 (64-bit). The Windows 7 machine is causing the problem.

    I've unchecked auto-hide and am still having the issue. It was fine before the upgrade.

    Parallels, any help??
     
  11. RodgerB

    RodgerB

    Messages:
    1
    Just wanted to chime in and state that I am also seeing the same behavior. Every minute or so you see a blip of the taskbar show. Regardless of activity or lack thereof. I saw this behavior on a fresh install of Windows 7 x64 with no other installations. Just the base OS as setup by Parallels.

    I disabled the "Auto-hide the taskbar" in the Taskbar and Start Menu Properties. I don't see the flash (at least not yet) after this change. I would like to be able to get the extra space afforded by having auto-hide enabled. My guess would be that the animation of the taskbar hiding is somehow bleeding through sometimes.

    I can also confirm this behavior was not present in previous build. So it's a newly introduced bug of some kind.

    Other than that, Parallels is working wonderfully for me. Just this one annoyance.
     
  12. SandyG

    SandyG

    Messages:
    2
    Same Here

    I see the same flashing problem - a line line flashes every 60 seconds. Turning off auto-hide makes the problem stop. I'm running the latest Parallels 5 for Mac, Coherence mode, and Windows 7 Pro in the VM.

    HOWEVER, each time I restart Windows the auto-hide is turned back on, and the flashing problem reappears. Suggestions?
     
  13. ronningt

    ronningt

    Messages:
    6
    Flashing as well, unable to turn on auto-hide

    In line with the posts above: I am using Windows 7 and started experiencing this problem only after the most recent Parallels 5 upgrade. The flashing occurs in either Crystal or Coherence mode.

    After reading this thread, I turned off the Virtual Machine 'Do Not Use Dock Area' option. After doing this, though, I am no longer able to turn on auto-hide within Windows. When I go to the task bar options, I can apply the auto-hide setting, but as soon as I hit 'OK', the setting is reset and the task bar is always shown. Because the task bar is fully shown, it does not appear to flash.

    This behavior is reversible. I can turn on 'Do Not Use Dock Area' and auto-hide the task bar and the flashing is present. When I turn off 'Do Not Use Dock Area', I cannot auto-hide the task bar in Coherence mode.

    Other factors that may be relevant:
    I use two monitors and since Parallels 5 the virtual machine also uses both monitors in Crystal and Coherence mode. The flashing only occurs on the primary monitor where the task bar appears.
    I keep my Mac dock on the left hand side of my primary monitor.
    I use the Parallels provided Windows theme that makes the OS more Mac-like.
     
  14. RodneyD

    RodneyD

    Messages:
    1
    I'm having the same issue as mentioned above. In addition, when this occurs, it also takes the text entry focus and moves it to Parallels/Windows. So if I'm typing in a Mac window, such as Safari, iChat, or Mail, I can be in the middle of writing something out when it switches the text focus back to the Windows side, often in mid-word. It is especially happening every minute.
     
  15. Patrick Mahoney

    Patrick Mahoney

    Messages:
    2
    Me too. Except mine does not flash, the taskbar simply will not go away. I can temporarily reduce it to a thin blue line by turning off and on the auto-hide feature within windows. This all worked perfectly fine before the update, which I did yesterday. Now, when in coherence mode, I cannot hide the taskbar. Also, the hide and show taskbar options are grayed out in the view menu. This is clearly a bug with the latest update, as evidenced by my experience and those of the other posts here. Parallels, this should be an easy fix, please release an update to the update fixing this problem. Thank you.
     
  16. johncarn

    johncarn

    Messages:
    5
    Same problem

    Only mine only happens on my Windows 7 vm
     
  17. nvrmore100

    nvrmore100

    Messages:
    21
    I have disabled auto-hide (never had it on to begin with), disabled "bring notifications to front". Some extra info, I also have 2 monitors, and I exclude dock area set.
     
  18. johncarn

    johncarn

    Messages:
    5
    Maybe obvious to some, wasn't to me

    Okay, a little more testing, and a loss of patience, led me to this workaround.

    As a previous poster pointed out, it only happens in crystal or coherence mode.

    Another point to make, it appears that every time you enter crystal or coherence mode, the Auto-Hide taskbar gets selected, whether it was selected in window mode or full screen mode.

    So, I would de-select that option in window mode, enter crystal, and have the flashing issue. The way I got around it was to enter crystal mode, click on the parallels icon in the system bar, then right-click on Windows Start Bar. When it displays under the Parallels icon, you can right click on it there and are then able to select Properties. Going into properties for the taskbar while in Crystal mode allows you to de-select the Auto Hide option.

    Also, it appears to de-select it when you exist Crystal mode, so you may think it's de-selected when it really is not.

    Like I said, may have been obvious to some, but it wasn't to me. I didn't realized I could (or would have to) change task bar and start menu options while in Crystal mode.

    HTH
    jc
     
  19. ronningt

    ronningt

    Messages:
    6
    My experience with this issue has only gotten stranger in the intermediate. It's gotten worse in the sense that, as RodneyD reported, when this flash occurs the Parallels app steals focus away from any Mac other application I am working in. It's gotten better in the sense that the problem only seems to occur in the first few minutes after I've opened the Parallels Windows 7 VM. If I just put up with the problem for a while, it seems to stop completely. Perhaps there is something Windows 7 is doing security/update wise that is drawing focus to the VM.

    I did download the last update, so I am working with build 5.0.9310.
     
  20. KennonB

    KennonB

    Messages:
    2
    Just throwing my .02c in.

    I'm having the same issue with the auto-hiding turning itself on and that's causing Parallels to steal focus. Turning off the auto-hide fixes this issue. But it comes back upon restart.
     

Share This Page