Windows time is jumping 2 hours a head for one minute

Discussion in 'Windows Guest OS Discussion' started by tjementum, Jun 20, 2013.

  1. tjementum

    tjementum Bit Poster

    Messages:
    5
    Every hour the time on the Windows VM is changed, so it's 2 hours in-front of OS X time. After exactly one minute the time is corrected.

    Eg. at 08:10 the time is changed to 10:10. After exactly one minute it's changed back to 08:11. After one hour at 09:11 the time is changed to 11:11 and stays there for one minute etc. etc. The first time it jumps is right after booting the VM.

    I've tried all the Time settings in the Parallels Advance option, but this will not correct the problem. I've also tried to disable the Internet Time Synchronization in Windows.

    I'm running Windows 8 on Parallels 8 with all updates. I'm using my Boot Camp partition to run parallels. Which means that I've also installed the Apple Boot Camp drivers on my VM. Except for the Time issue, I have not had any problems with this. I've almost never boot directly from Boot Camp though, but I like the idea. Are there any settings here that could be the cause?

    I've contacted Parallels support (Ticket 1653127), who did a remote session on my machine. But boy... this was a waste of time, which is why I'm asking here. He didn't do anything.. and I'm not sure he fully understood my problem, cause he advised me to boot from Boot Camp to solve my problem - why would I need Parallels then? To please him, I did try to boot from the Boot Camp partition and work there for a few hours.

    I guess this properly has something to do with daylight saving and UTC time. In Denmark we are one hour in front of UTC time (in the winter), and 2 hours in front in the summer time.

    If anyone knows how to fix this, I will be very happy.
     
  2. tjementum

    tjementum Bit Poster

    Messages:
    5
    OK... I found the cause to the problem and a workaround..

    The problem is that when Boot Camp utilities are installed a Windows Registry setting is set, that tells Windows that the system time on the machine is UTC time... because unlike PC's this is how a Mac CMOS time works. When Windows is running in Parallels it treats the OS X time as UTC time and adds 2 hours (cause Denmark is 2 hours in front of UTC time).

    The RegistrySetting is located here HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\TimeZoneInformation\RealTimeIsUniversal (DWORD (32bit)). Setting this value to 0 will fix the problem, because now both OS X and Windows is using the time of the current time zone. Follow this guide... except in step 4 set the value to 0 and no 1: http://yourmacguy.wordpress.com/2008/08/09/boot-camp-clock-sync/. Also in step 3 you should edit the current value instead of adding a new one.

    BUT... if I boot my machine in Boot Camp, the Windows time will be 2 hours behind (that's the problem that the Guide fixes). Luckily I don't do that often.

    This is clearly a bug in Parallels. Parallels should detect the RealTimeIsUniversal setting on Windows, and communicate the time to Windows accordantly (or Parallels Tools should set the RealTimeIsUniversal to 1 and always communicate UTC time). Correcting the time every minute is not good enough. I have some jobs running on my machine and they misbehave when time is jumping like this. I've experience other weird problems in various programs as well. I hope you will address this.
     
  3. GabrielL1

    GabrielL1 Bit Poster

    Messages:
    12
    I had exactly the same concern and found the same solution.
    Neverthless, it seems that PD fixed a part of the problem since 2013 because now the delay (+2h in France) appears only in the logon screen.
    As soon as I'm logged into Windows the time is corrected.

    Is there a solution to have the good time even on the logon screen?

    I cannot modify the registry because I use often Bootcamp directly.
     

Share This Page