Windows VM periodically freezes for 5 to 15 seconds

Discussion in 'Windows Guest OS Discussion' started by DavidH80, Dec 9, 2020.

  1. DavidH80

    DavidH80 Bit Poster

    Messages:
    9
    Version 16.1.1 (49141)
    Model Name: iMac
    Model Identifier: iMac15,1
    Processor Name: Quad-Core Intel Core i7
    Processor Speed: 4 GHz
    Number of Processors: 1
    Total Number of Cores: 4
    L2 Cache (per Core): 256 KB
    L3 Cache: 8 MB
    Hyper-Threading Technology: Enabled
    Memory: 32 GB
    Boot ROM Version: 235.0.0.0.0
    SMC Version (system): 2.23f11

    Note: I have two external Thunderbolt displays.

    With windows 10 Pro 1909 build 18363.1198

    Since upgrading to the latest Parallels version this and similar windows VM's all periodically freeze for periods of between 5 and 15 seconds.
    I'm seeing this at least 70 times a day.
    During this time windows can sometimes appear black - particularly noticeable with Visual Studio

    During the freeze everything running in the VM appears to be suspended.
    With the VM not in full screen mode the CPU usage indicator drop down does not indicate that any particular app is using excessive CPU rather it appears to be the parallels host process itself which is somehow stalling the VM. The VM has been allocated sufficient RAM and CPU resources and does not reach limits where it is swapping or otherwise performing badly. I hesitated before reporting this so I could eliminate all other possible causes first but I'm now confident that this is an issue with the Parallels host.

    This issue happens a lot while running visual studio and while it is true that VS can sometimes use excessive CPU the issue is not only observed while running VS and can occur while very few programs are running. During the freeze the machine is completely unresponsive and even Task Manager stops updating!
    However the CPU usage indicator drop down on the title bar of the (non-fullscreen) VM seems to show CPU usage 0 and reports "No apps using significant CPU" at the time of the freeze.

    There are indications that the freeze occurs during certain disk I/O operations but this is the only possible clue I have.
    Could it be related to the earlier "XCOPY" related issue I reported previously - which was fixed in build 49141?

    This is a rather annoying issue.
    I note a few similar reports from others.

    Also I was trying to open a new ticket but this is taking me round and round in circles and I can't seem to open a new ticket - issue with website or the fact that I still have one open ticket.
     
    BrockD likes this.
  2. DavidS13

    DavidS13 Bit Poster

    Messages:
    23
    Did you ever find a solution for this? I'm experiencing the same problem.
     
  3. JamesBailey

    JamesBailey Bit Poster

    Messages:
    6
    A colleague and I have the same problem. It's almost predictable that a certain action (initiate a build in Visual Studio 2019) will cause a freeze, but it's not the only reason.
     
  4. RandyB3

    RandyB3 Bit Poster

    Messages:
    24
    I'm running Big Sur on a 16" MacBook, just upgraded to Parallels 17, still having the same issue. It happens with an old VM but I've never had the same issue on a newer VM.
     
  5. LazyA

    LazyA Bit Poster

    Messages:
    4
    Same problem here. Just started recently after the last Parallels update a few weeks ago. Big Sur V11.6.4 (20G417), Parallels Desktop For Mac Pro Edition version 17.1.1 (51537).
     
  6. RandyB3

    RandyB3 Bit Poster

    Messages:
    24
    "it appears to be the parallels host process itself which is somehow stalling the VM"
    I have some subjective evidence to support this. Restarting the VM seemed to help some times, but many times it did no good at all and the VM continued to have the same stalling immediately after restart. However, I discovered that if I made a copy of the VM and started it, the stalling was gone. It would return in an hour or two so it was no permanent solution. The point is, how does an exact copy of the VM pvm file even temporarily make the stalling go away but restarting the VM typically does not? This seems to point the finger squarely at the Parallels host process. I also suspect the age and upgrade history of the VM may play a role in the host process issue as I created a new VM with all the same software installed and it does not have the stalling issue at all.
     
  7. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    397
    Turn TRIM off. The VM is trying to auto-recover some of the disk space, which can tie up processing for quite a while if the VM is 60GB or more.
     
  8. Mark Fine

    Mark Fine Kilo Poster

    Messages:
    397
    You can find the setting under Parallels' Windows Configuration: Hardware (tab) -> Hard Disk (item list) -> Advanced (button) -> Enable TRIM (check box)
     

Share This Page