Windows XP and Mac have different ip numbers

Discussion in 'Installation and Configuration' started by countrydj, Mar 16, 2008.

  1. countrydj

    countrydj

    Messages:
    3
    Hi...
    I'm absolutley brand new to this concept of Windows Parallels Desktop and I've been asked to setup the network.
    The existing setup is 3 computers running Windows 2000 all networked together, peer to peer, getting their IP numbers from the dhcp facility of the adsl router (gateway = 192.168.1.254).
    One of the computers has now been replaced with Mac OSx 10.5 running leopard.
    It has Windows XP pro as a VM.

    The current situation is that the Mac IP number is 192.168.1.68 (from DHCP of the router).
    The Windows XP VM IP number is 10.211.55.3 with a gateway of 10.211.55.1 (I have no idea where this comes from, but the network is set to 'automatically obtain IP address')

    Clearly these two IP numbers are not in the same subnet, so will not network with the other two computers..

    We need the Windows XP VM to see the other two computers so that they can all be networked peer to peer.
    I need the Windows XP VM to have an IP number in the same subnet as the Mac and the other two computers.

    The client is 15 miles away, so I could do with some guidance as to how to start on this job before I travel.

    Any advise would be appreciated.

    Thanks,

    John C
     
    Last edited: Mar 16, 2008
  2. itsdapead

    itsdapead

    Messages:
    177
    You probably want "bridged" networking

    Look under the settings for the Network Adaptor in Parallels' VM Configuration section.
    You get 3 choices: "Shared", "Bridged" and "Host Only".

    I'm pretty sure that what you want is "bridged" - this effectively connects your Windows XP virtual machine directly to your network just as if it had its own network card. If you set the network adaptor to "bridged" and re-start the virtual machine it should pick up an IP address from your router.

    Your router configuration may require you to register the new machine's ethernet "hardware" address (confusingly called a MAC address, so I'm going to have to keep writing out Macintosh in full. Grrr!) before it will allow it to connect: your virtual XP machine will have its own MAC address (which you can discover in the usual way for XP) and this is the one you will need to register (as well as the host Macintosh's MAC address).

    The other two modes - "shared" and "host only" create "virtual" subnets inside the host Macintosh with the Macintosh acting as a DHCP server - this is where the 10.*.*.* addresses you are seeing come from.

    In "host only" mode, the subnet is cut off from the outside world and just lets the VM talk to the host Macintosh.

    In "shared" mode, the host Macintosh acts as a gateway/router allowing any Virtual Machines to share the host Macintosh's IP address, in exactly the same way as your ADSL router lets 3 machines share the single IP address you get from your broadband provider.

    To summarise:

    "Shared" is the sensible choice for portable Macs; where you just want basic "outgoing" internet access from your virtual machine; where you have a single internet connection without a gateway/router or anywhere where it would be a hassle to get an "extra" IP address for the VM (I think its the default).

    "Bridged" is more useful where you have a LAN and router under your control - your virtual machine goes on the network as a full peer and you can use your router to set up port-redirections, fixed addresses, firewall rules and all that jazz.

    You can mix/match and customise these to set up fancy "virtual" networks, but that is a bit beyond the scope...
     
  3. countrydj

    countrydj

    Messages:
    3
    Many thanks itsdapead for your advise.

    As I said, the job is some 15 miles away so I will have to go and try it.
    I will let you know what happens.

    Regards,

    John C
     
  4. countrydj

    countrydj

    Messages:
    3
    Hi itsdapead, you said:
    I have been back to this job this afternoon.
    I couldn't find the configurations section and I didn't have any instructions with me. Parallels was setup by the vendor, but he was no help whatsoever in solving this network problem.
    I was told that when Parallells is run, it can be paused at any time. I did see a screen that looked like I should be able to edit netwotk card settings but I couldn't pause the screen to get at it.

    However, I rooted about and found an icon at the bottom of Windows XP and on mouse over it told me that it was the network card. I clicked on this and found that there was 3 settings, 1. default, 2. en0 3. en1.
    The setting was on deafult, which was 'Host Only'. I changed this to en0 and found that this was 'Bridged'.
    I then found that I could get no to the Windows network and setup the network as the client wanted.
    I then left it working and left since I didn't really know what I was doing.

    Does this sound right to you ????

    Thanks for your support.

    John C
     
  5. itsdapead

    itsdapead

    Messages:
    177
    That should do it.

    You need to shut down windows (not just pause parallels) before you can get into the main settings screen, but the icons you found let you change some things "on the fly".

    If you need to RTFM then the manuals should be available as PDFs in the Applications/Parallels folder on OSX.
     
  6. umak

    umak

    Messages:
    1
    Having trouble with IP number on windows, does not match the range of my MAC

    Hi itsdapead, and anyone who can help!

    I was having issues with what the user said and I found this posting and was able to fix it. But for some reason the issue is back again. I have tried multiple times to do what you suggested and I still can not get the IP to sync with MAC's.PLEASE help! I have installed filemaker client on the windows parallels and trying to connect to Filemaker server on a virtual machine in the same range. I just can not seem to have a break. I have spent a lot of time on this already. Your help will be greatly appreciated.

    Thanks,
    Uma
     

Share This Page