Windows XP SP3 and Parallels Desktop 5584

Discussion in 'Windows Guest OS Discussion' started by Birdman, Apr 25, 2008.

  1. Birdman

    Birdman

    Messages:
    64
    Hi!

    Wondering if anyone test the compatibility for upcoming SP3 using 5584 or newer version?

    Any problem and advice on the Mac OS and Windows side for HW and SW?

    Thanks!
     
  2. Tonelux

    Tonelux

    Messages:
    3
    I would be suspect, as it may very well be a driver update to allow less service calls when downgrading to Vista. I have frozen my XP install and don't plan on doing anything to it. It works for the few programs I use it for.
     
  3. cpadave

    cpadave

    Messages:
    5
    And it may take a while before Parallels gets around to it... see for example the MBA problems. :(
     
  4. uotony

    uotony

    Messages:
    21
    Now, this is how I got XP SP3 installed and working:

    0) I have XP on a 'Boot Camp' partition, and not in an image file. If you
    have the VM in an image file, the rest of this won't make any sense at all.

    1) Boot the machine to XP on the Boot Camp partition.

    2) Install Boot Camp 2.1 from Apple. The URL is:
    http://www.apple.com/support/downloads/bootcampupdate21forwindowsxp.html
    This is essential *before* installing SP3.

    2a) Reboot.

    3) Install SP3. I downloaded the full install from Microsoft.

    3a) Reboot.

    4) Select your OS X partition as your Startup Disk and

    4a) Reboot.

    5) Once OS X boots and you are logged in, start Parallels, but *DO NOT*
    start the VM!

    6) Open your VM configuration, and select 'Hard Disk -> Advanced'

    7) Click on the "Clear..." button under the "Cleanup Boot Camp partition"
    section. This allows Parallels to 'learn' about the changes made by the SP3
    install.

    8) Start your VM.

    9) Once the VM is started and logged in, *RE-INSTALL* the Parallels Tools!

    9a) Reboot the VM.
     
  5. MisterE

    MisterE

    Messages:
    6
    Thank you uotony! After updating XP to SP3 I had a problem where XP was in an endless loop of constantly rebooting at startup. XP worked fine when the Mac was started from the Boot Camp partition but not when I used Parallels to run it as a VM.

    Your solution fixed the problem!

    FYI, I'm running Parallels version 5608 on a MacBook 1,1 2GB RAM OS 10.5.4.
     
  6. NoAnxiety

    NoAnxiety

    Messages:
    1
    MisterE, I had the same problem as you described. Did you directly update to Boot Camp 2.1 and that fixed the problem? Or did you have to uninstall Service Pack 3 before updating Boot Camp and then reinstall Service Pack 3?
     
  7. John@Parallels

    John@Parallels

    Messages:
    6,343
  8. MisterE

    MisterE

    Messages:
    6
    Here's what I did from scratch.

    I started by installing XP Pro with SP2 on the Boot Camp partition using Boot Camp Assistant.
    I then installed the Boot Camp 2.0 drivers from the Leopard DVD.
    Then using Apple software update I installed Boot Camp 2.1 drivers.
    I then rebooted into Mac OS X and set up the Boot Camp partition to work as a VM in Parallels.
    After a few more 3rd party software installs I rebooted the Mac from the XP partition again to install SP 3.
    After installing SP 3 I ran Windows Update and installed the remaining updates that were applicable to my XP setup.
    After this I rebooted into Mac OS X and when I opened the Parallels XP Boot Camp VM it was at this point that I had the endless rebooting loop at startup problem.
    The solution was to follow the direction uotony describes in steps 6 and 7.
    I then restarted the XP VM and reinstalled Parallels tools and all is working fine now.

    So, in answer to your question NoAnxiety, it was not updating to Boot Camp 2.1 or uninstalling SP3 that fixed the problem. It was cleaning Parallels off of the Boot Camp partition / VM then reinstalling it so it could deal with the changes of updating to SP3 that fixed the problem.

    If I had done all my updates while booted from the XP Boot Camp partition, both the Boot Camp 2.1 update from Apple and the Windows updates (SP3) from MS, before setting up the Boot Camp partition as a Parallels VM I would have never had the problem.

    The kb John linked to gives a more detailed / technical explanation.

    Hope that makes sense and helps.
     
    Last edited: Jul 17, 2008
  9. Marge44

    Marge44

    Messages:
    10
    Need help! What didn't I do? I have a MacBook Pro OS 10.5.4 Parallels 3.0 Build 5608. I have been running without a problem for a few months (always from Parallels using Boot Camp) Today I booted from Boot Camp for the first time since I installed Parallels 3.0. It worked flawlessly. I needed to upgrade to XP Service Pack 3. So I followed "uotony's 9 step procedure outlined above. All went well thru step 7. When I tried to start VM using Parallels (step 8) I got the msg "Autochk program not found - skipping AUTOCHECK". Then Parallels kept cycling thru windows trying to start up the boot camp.pvs without success. Windows were: 1.) regular begining Windows blue screen, 2.) autochk program not found, 3.) Stop: C000021A (Fatal Sytem Error) The sessio manager initialization system process terminated unexpectedly. etc The system has shut down. 4.) window showing choice of Parallels conf iguration or Windows XP Home Edition. I had to quit VM thru Parallels. I tried starting just from Boot Camp but got same mgs and cycling.

    I have read Articles 5138 & 5447 (but my screen does not go to BSOD) are these my only hope?
     
    Last edited: Sep 6, 2008
  10. MisterE

    MisterE

    Messages:
    6
    If you resort to a clean install of Windows follow my method. Once you have a good install use the Mac program WinClone to make a copy of your bootcamp partition.
     
  11. John@Parallels

    John@Parallels

    Messages:
    6,343

    Nevertheless , you need to perform steps in http://kb.parallels.com/en/5447
     
  12. Marge44

    Marge44

    Messages:
    10
    Well, I tried John@parallels suggestion to follow Article 5447. I can't create a XP Install CD with Service Pack 3 integrated because I don't have a good up & running windows. So I followed Article 5447's advice to perform repair (Article 5138). What a mess! During "Installing Windows" I inserted my product code. Installing started then I began receiving messages that Setup cannot copy the file xxx. I had 99 of these messages of different files that couldn't be copied. I was given a choice to retry (the XP CD in drive) or browse to find the files. Each time I had to cancel the message because the CD didn't work and browsing the cd showed 9 folders and the one file that couldn't be copied. Opening the file didn't work. Finally it finished the install & restarted. It seemed stalled on a screen showing Microsoft Windows XP. Restarted computer in Windows. Windows froze. Restarted again, finally came up with login screen. Logged in and needed to download IE 7 so I could go to Microsoft Updates. Download successful but when I tried to run it got Stop Msg (0x0000007F 0x0000000D 0x00000000, 0x00000000, 0x00000000)

    Started XP from CD (not thru Mac OSX) and ran Install & repair. This time when installing files (41) forty-one files could not be copied. Finished installing and restarted XP. Got log in. Thru Control panel removed Boot Camp. Kept getting message that Microsoft .NET Framework had an unhandled exception.
    Ran IE 7 successfully.
    Only update from Microsoft is XP SP3 so I didn't install at this time.
    Installed Boot Camp from Leopard CD, Restarted computer.
    Upgraded to Boot Camp 2.1, Restarted computer.
    Tried to update to XP Service Pack 3. Received message updates failed to install. Tried this twice, failed 2x.

    I checked Microsoft Support for help, couldn't find it.

    Any help here?
     
  13. Specimen

    Specimen Product Expert

    Messages:
    3,244
    That article should be followed exactly as stated, if you CAN'T slipstream SP3 than you CAN'T follow the article, there's no way around it. Repair Install with a Windows XP CD effectively downgrades XP to the version on the CD! That's why it's important SP3 is slipstreamed into it.

    Secondly, BootCamp 2.1 must be installed BEFORE SP3, not after, you also should install Parallels latest build BEFORE SP3. The kb applies when you installed SP3 before Parallels build 5608 thus creating the errors.

    If you can't slipstream the CD. Then you should repair install natively with the Windows cd you have (with SP2, it's what Apple recommends for Bootcamp, if it doesn't have at least SP2, you're looking for trouble, pre-SP2 doesn't work well on Macs), install BootCamp, upgrade BootCamp to 2.1, only after that should you apply SP3. On the Parallels side, before booting thru Parallels you should be sure you have the latest Parallels build (5608), then go to the Configuration Editor of your VM, in Hard Disk 1 > Advanced > Clear (Clears Parallels information from the Windows disk), then boot it and install Parallels Tools (only after that should you re-activate Windows if it complains about activation).

    If this doesn't work, I suggest you start a fresh installation, this time install BootCamp and update it to 2.1 before SP3 and only start it in Parallels after it has been updated to SP3 and you're running Parallels 5608.
     
    Last edited: Sep 8, 2008
  14. Marge44

    Marge44

    Messages:
    10
    Ok. I see I was too frustrated to realize that I can slipstream SP3 if my XP will stay up while I create the new CD. It is unstable. My new question is:

    If I follow Article 5446, the source for SP3 is at Microsoft's Network & Developers site. I checked and it'll take 4 hours for me to download that version. Microsoft says I can download a one computer version at another site quicker. When I went there it was for auto upgrades. I checked and that site says I already have SP3 on my computer waiting to be run (to upgrade). I searched but couldn't find a file that would be SP3. I "showed hidden folders & files" and did a search of files & folders (including hidden files).

    Does anyone know where that file might be stored by auto updgrade's download program?
     
  15. Specimen

    Specimen Product Expert

    Messages:
    3,244
    You have to download the complete SP3 file to slipstream, not just the incremental update which is smaller, good for upgrading, but incomplete for slipstreaming. Look, you can't cut corners with this, do it EXACTLY like it says in the article, or you end up spending even more time.

    What bugs me is that you're not even asking if you can use the smaller, incremental update, you're already assuming you can completely unaware you're heading for failure AGAIN.
     
    Last edited: Sep 9, 2008
  16. Marge44

    Marge44

    Messages:
    10
    Thanks for the info. The reason I ask for help here is because I didn't know that my update is incremental. My former job (am retired) was a computer ordinator for a K-8 school. I began with the Apple IIe computers without hard drives and thru the 13 years there learned & advanced to the job how of a network administrator with close to 60 Macs, a server, and all staff and students using ID & passwords to access their files. The backup help I had explained what needed doing and I was able to do 90% of it. The other 10% they came on site to do. I didn't have any big problems with the Mac computer setup. My experience with Windows is much less and a lot shakier.

    Thanks for your "patience" and help in getting me this far.
     
  17. Marge44

    Marge44

    Messages:
    10
    Having problems yet!
    Am following Article 5446 "How to integrate (slipstream) Windows XP Service Pack 3 in installation CD.
    I downloaded XP Service Pack 3 using Safari Browser and was able to download the entire file.

    When I try step #7 of Article 5446 to extract the SP3 files I get the message:
    WindowsXP-KB936929-SP3-x86-enu.exe is not recognized as an internal or external command, operable program or batch file.

    I've tried download the file using IE 7 but about 25% into the download my computer quits; and is dumping physical memory to disk.

    Any suggestions other than starting from zero and redoing the entire partion?
     
  18. Specimen

    Specimen Product Expert

    Messages:
    3,244
    That error message is because it doesn't find the file you're asking for (WindowsXP-KB936929-SP3-x86-enu.exe) in the current dir. It doesn't mean the file is corrupted.

    You have to change dir to the directory where the file is in order to execute it ("5. We assume that you downloaded Windows XP Service Pack 3 to C:\SP3\WindowsXP-KB936929-SP3-x86-ENU.exe"), and check via the dir command the exact spelling (case-sensitive, it's probably ENU and not enu).
     
    Last edited: Sep 9, 2008
  19. Marge44

    Marge44

    Messages:
    10
    I'm still having problems and am considering starting from scratch and re-doing my partition and Windows in Boot Camp, then adding Parallels 3.0.

    I followed all the above suggestions in the order stated and am able to get Boot Camp to work for 15-20 minutes. Parallels VM won't work; I get the XP startup screen with the message "Parallels Tools inializing". Then the screen goes black.

    In Boot Camp after 15 minutes or so I get the message Stop: 0x0000007F (0x0000000D, 0x00000000, 0x00000000, 0x00000000) and the computer shuts down XP and begins dumping physical memory to disk. It suggests I run a memory check & check for faulty or mismatched memory or try changing video adapter.

    I've tried repairing XP 4-5 times and each time there are files that cannot be copied (anywhere from 30-99 files).

    Does this make sense to anyone? I don't understand Windows enough to know what I should do. If I had just erased the partition and started from scratch, I hopefully would have spent less time than I already have on this mess up.
     

Share This Page