Workaround for built-in iSight failure in OSX (build 3170)

Discussion in 'Parallels Desktop for Mac' started by arj, Feb 23, 2007.

  1. arj

    arj

    Messages:
    2
    Hi everybody --

    I didn't see any posts on this for 3170 on this, so I thought I'd share a little of my own experiences.

    I installed Parallels 3170 on OS X 10.4.8, on a new dual-core MacBook Pro with built-in iSight. After installation, my iSight camera stopped working in OS X, and in Win XP SP2 also... it was like this under 3150 too.

    Looking in System Profiler, I saw that Built-In iSight Camera was listed under USB Bus, *not* USB High-Speed Bus. A little probing of my system logs showed that there was some kind of overflow either in voltage or bandwidth; I can't remember which. Some light grepping turned up errors that looked like this: "QuickTimeUSBVDCDigitizer: Cannot get enough bandwidth. Desired: 3072, available 1023".

    To get my iSight back, I simply instructed OS X to unload the Parallels USB kernel driver. After logging into my Administrator account (I keep my admin account separate from my day-to-day user acount, I typed this in an open Terminal window:

    sudo kextunload -b com.parallels.kext.ConnectUSB

    The driver unloaded successfully, and presto! I got my iSight back. Not only that, but the iSight is once again listed in System Profiler as a high-speed device. Excellent!

    (If you want, you can verify that the Parallels USB kernel extension is running, or not, by typing this: kextstat | grep USB -- note the vertical pipe symbol before 'grep'. You should see something like this: 81 0 0x97b000 0x4000 0x3000 com.parallels.kext.ConnectUSB (2.5.0) <36 11 6 5 4 3>)

    After going through all this (and it only took a minute or two, really), I started to think about what's going on. I suspect what's happening is that the USB driver written by the Parallels team isn't a high-speed driver, and it somehow can't handle the bandwidth needs of the iSight camera.

    Medium-term, I am sure Parallels will fix this. In the short term, this quick hack will suffice. The downside to this, of course, is that it means you can't use USB devices inside a running VM.

    If this duplicates somebody else's post, sorry to repeat the obvious. If not, I hope it helps some people out there who have been frustrated. I certainly have been, although it doesn't diminish my admiration for what the Parallels team has been able to achieve. It's a great product.

    Andrew
     
  2. sidssp

    sidssp

    Messages:
    182
    It seems most of the iSight problems are happening on MacBook or MacBook Pro. There must be something different in the laptop environment because I am using a 20" iMac and iSight is working fine in both OS/X and Windows XP VM.
     
  3. freedenizen

    freedenizen

    Messages:
    4
    Hmmm I have a similar problem but the iSight doesn't show up at all in OSX even when I unload the driver, not on the usb bus or the high speed bus.... sigh....
     
  4. arj

    arj

    Messages:
    2
    Sadly, this fix might not work after all

    After permanently disabling the Parallels USB kext, my iSight *still* won't work, and is showing up as a USB device rather than as a high-speed device. So it appears that this may be unrelated to Parallels... but then again, I did not have these issues before I installed the software...

    Hmm...
     
  5. alurkar

    alurkar

    Messages:
    12
    One more dead Isight on macbook pro

    I really hope they fix this *soon* I wonder if uninstalling parallels will do the trick and enable Isight in OSX at the very least!.

    :mad:
     
  6. yusufosman

    yusufosman

    Messages:
    19
    Help!!! Isight Gone!!!!

    I am using the new build 3186. My camera was working fine in the previous RC3 build with XP Home. I just installed this new build, and also two new OS, I installed XP Pro and Vista Home Premium. Installed the driver for the iSight in XP Pro which installed fine. I restarted the VM and got the error that it couldn't load the device as it was in use. Since then I haven't been able to gain control of the iSight either in the VMs or in OSX. I've tried both VMs to load the iSight in to!

    Now when I load up my computer, the iSight is not present. I've tried the fix of removing the driver in Terminal, but to no avail. It unloads the driver but I don't get my camera back.

    I don't have my camera listed anywhere in the system profiler.

    Has Parallels has messed up my hardware? Or is this something that can be fixed?

    I'm using a Macbook btw. I didn't have this problem at all in the last build. If I was using the iSight in XP and didn't unload it before shutting down the VM I would usually have to reboot OSX to get it to work again, but it did. This time rebooting doesn't work!
     
    Last edited: Feb 28, 2007
  7. yusufosman

    yusufosman

    Messages:
    19
    fixed?

    Ok ok I just panicked. But I think I managed to fix it, at least the iSight seems to be working the last few times I've shut down and restarted.

    I entered this sudo kextunload -b com.parallels.kext.ConnectUSB in to Terminal and the driver did successfully unload after asking for my password. However iSight didn't work. I tried this and restarted but again same problem. I was restarting my iSight was no listed in the system profiler at all.

    This is what I did to fix my iSight - I entered this command to unload the driver sudo kextunload -b com.parallels.kext.ConnectUSB

    Then using Onyx (freeware from Versiontracker) I cleared all the caches including system application and kernel.

    I restarted my computer. iSight now works, is listed as a high speed device. Went back to XP and iSight works.

    I think the problem occurs when you don't disconnect the iSight in the VM after using it from the devices menu, maybe it keeps hold of the driver and doesn't release it properly?

    If your driver isn't being released in terminal, then maybe you just need to clear the caches and see if that works?

    Try it and let me know, worked for me.
     
  8. alurkar

    alurkar

    Messages:
    12
    I can *supposedly* unload the extension for parallels USB but it does not seem to make any difference. I tried clearing the cache using Onyx as well but no use.

    :-(

    This totally sucks!!
     
  9. alurkar

    alurkar

    Messages:
    12
    So i figured out what the problem was with some assistance from folks at Parallels. Since i was unable to use iSight natively in OSX even when parallels was not running i figured it was something funky with OSX so I rest the SMC and NVRAM as follows:
    to reset SMC:
    unplug all the cables from you machine, shutdown and remove battery for atleast 15 seconds and restart

    to reset NVRAM:
    when restarting press CMD+OPT+P+R till the system seems like its restarting (i.e reading the CDROM) and goes through startup boot "gong"

    This fixed the issue with my macbook pro.

    After resetting SMC and NVRAM i suggest testing that iSight works fine natively before testing it in Parallels.
     
  10. olliewollie

    olliewollie

    Messages:
    1
    An alternative if this fails is to boot up in safe mode (hold shift down immediately when you here the startup chime and release when the grey apple appears). Then restart your machine as normal. Worked for me!

    Enjoy
     
  11. tofergregg

    tofergregg

    Messages:
    9
    Thanks -- this part fixed it for me. I wondered what was going on this morning when Parallels announced, two or three times, that it couldn't connect to my iSight, and then it disappeared from the USB connection list in Parallels. This afternoon, when I went to use the iSight with Photo Booth, it didn't work and didn't show up at all in the System Profiler.

    Now it is back to normal, but I wonder...what is the procedure from here on out?

    -Tofer
     

Share This Page