Anyone having luck with Garmin GPS?

Discussion in 'Parallels Desktop for Mac' started by Traj, Jun 19, 2006.

  1. Traj

    Traj

    Messages:
    24
    Now that the GA is here, I had hoped I would be able to get my Garmin GPSMAP60C to communicate with Mapsource or GSAK.

    The only progress I have is that I can see the Garmin USB in the Hardware Device list. So, there seems to be something happening. But even though it's there, neither programs will recognize the unit.

    Anyone having success here????

    :confused:
     
  2. Larry__Rymal

    Larry__Rymal

    Messages:
    74
    Considering Garmin has a rough time with USB on "real" PCs, don't be surprised when it doesn't work with Parallels. In our GIS classroom in which GPS receivers are used, we had to stop using Garmin USB connectivity to the individual lab computers. 3/4ths of the Garmins would sync. The remaining computers would not. Too unpredictable and a management hassle in a classroom enivronment. The issue was frustrating enough that we decided to not use USB.

    Alternative was to use the far slower, but nearly perfect serial access.

    Likewise, the same situation exists for me with Parallels Desktop. I use a Radio Shack USB to Serial adapter and I have perfect communications. Click on the link below to read a message I posted that included how I use my personal Garmin 76CS with my MacBook. I was all but quaking with excitement as I was typing that message:

    http://forum.parallels.com/post11862-11.html
     
    Last edited: Jun 19, 2006
  3. bredding

    bredding

    Messages:
    4
    60CSx works, 60CS doesn't

    My GPSmap 60CSx works but my GPSmap60CS does not. This seems to me to be a Garmin problem then a parallels/Windows XP problem.
     
  4. Traj

    Traj

    Messages:
    24
    I've never experienced any problem with connecting my GPS to my PC via USB. Your solution wouldn't work for me since the Garmin GPSMAP60C is USB only.

    Same with my Garmin Quest, USB only. Neither will work using Parallels.

    :(
     
  5. Manatee

    Manatee

    Messages:
    50
    I have been able to synchronize, access, and update both my 60CSx and my Edge 305. My older 60C, however, is not seen through Parallels. Maybe it is something that changed when Garmin went to the new SiRF Star III chipset, as both by newer Garmins have that.
     
  6. bobodobo

    bobodobo

    Messages:
    22
    Add me to the list of disappointees... no joy connecting a Garmin Vista C with the USB interface. Again the dreaded "in use by another application" message.

    Just FYI, I can connect using Lismore Systems Guest PC on a Power PC Mac, and download position information, or upload/download waypoints, routes or tracks. Unfortunately, maps and unit software upgrades will not upload. I contacted Lismore and they say it's a problem with the numeric processor emulation and they're working on it. So I'm still left without an option for unit software or map uploads... except going to a real PC.
     
  7. Larry__Rymal

    Larry__Rymal

    Messages:
    74
    Bummer.... wish your Vista C had a serial interface since that works with mine.
     
  8. Danny T

    Danny T

    Messages:
    1
    Garmin 60Csx *mostly* works!

    I've been impressed so far with Parallels, having bought it specifically so that I could send Garmin Mapsource maps to my 60Csx.

    Uploading maps to the unit itself worked fine via USB. I transfered over 950Mb of maps from Topo GB to a 1Gb card in the GPS unit. It took about 2.5 hours, but it worked absolutely fine, which I consider a massive achievement!

    I've also uploaded tracks and waypoints to Mapsource, and to the third-party mapping product TrackLogs, which has (British) Ordnance Survey mapping capability. Again, I'm impressed.

    What hasn't worked is updating the firmware on the 60Csx. I currently have 2.6, and I'm trying to update to 2.9.

    I've tried every combination of USB, with different cables; and serial with a Keyspan adapter. I've tried it both through their Webupdate application, and also through downloading the executable and running it directly on the desktop.

    Each time the unit freezes, and it reports an error.

    Anyone had any luck updating the 60Csx firmware via Parallels?

    Danny
     
  9. Larry__Rymal

    Larry__Rymal

    Messages:
    74
    Updating firmware is risky, under the best of conditions. Until there is a Mac version of the Garmin updater, I would use a real PC to apply an updater. We all know that Parallels USB is not 100% yet. A mess-up while updating firmware on any device can potentially damage that device.

    I wouldn't do it. Parallels USB is still in its infancy.
     
  10. patch29

    patch29

    Messages:
    1

    I was able to update the firmware from my Macbook to my 60CSx. I did both the 2.71 beta and 2.90.

    I used the latest Mapsource and USB drivers from Garmin, with the supplied USB cable from Garmin. I also downloaded the firmware from Garmin first, then ran it. It has worked for me so far.
     
  11. old pal

    old pal

    Messages:
    5
    I, also attach my GPSMAP 60CS as a USB device, but Mapsource can't seem to find it. Too bad, since I hoped to get rid of my Averatec laptop.
     
  12. soybomb

    soybomb

    Messages:
    1
    Yes and No

    My StreetPilot 2720 works perfectly. All functions work great. I can update firmware, voices, maps, routes, waypoints, etc. My Garmin Forerunner 305 does not. They both use the same USB driver. I have to use Boot Camp in order to handle Forerunner 305. Right now I am limited to using MotionBased to manage the Forerunner in Mac OS X. Garmin promised that Training Center would be available in the spring for Mac OS X but hasn't delivered so I am stuck with the Boot Camp scenario. Garmin promised the Mac OS X software back in January. :confused:
     
  13. Xabi

    Xabi

    Messages:
    8
    I see this thread marked as high-rated as if there was a solution for GPS receivers, but please don't mess up things in this issue... Serial USB receivers are reported to work under Paralells, even with serial-to-USB adapters. But USB-only receivers are not working due to the poor Parallels USB support.
     
  14. ciprol

    ciprol

    Messages:
    15
    I have had successes updating the firmware of my Nuvi 350 and eTrex Vista Cx using standalone updater through PD. However, the update for GPS Software v2.60 for Nuvi using Garmin's WebUpdater was a stuff up. I'd suggest people avoid using WebUpdater at the present time.

    I am using PD 1.0, Mac OS X 10.4.6, Windows XP Pro SP2, latest firmwares in Nuvi and Vista Cx.
     
  15. rcomeau

    rcomeau

    Messages:
    42
    Can hyou post a link to someone describing a working USB-Serial adapter? I managed to get one working once but since then, I have not been able to get any Keyspan adapter to work at all.

    Thanks,

    rcomeau
     
  16. Larry__Rymal

    Larry__Rymal

    Messages:
    74
    That's what search engines are for! :) Go here:

    http://forum.parallels.com/post11862-11.html
     
  17. Larry__Rymal

    Larry__Rymal

    Messages:
    74
  18. nigelg

    nigelg

    Messages:
    1
    After installing the latest Garmin USB drivers, I was able to update the firmware on my GPSMAP396 using the WebUpdater application with no problems at all.
     
  19. bredding

    bredding

    Messages:
    4
    This is a little misleading. I have been using a GSPmap 60CSx exclusively with the USB on the receiver and USB on the MacBook Pro (USB-to-USB) without a problem. My 60CS does not work however. This puts some of the blame at the hands of Garmin since some receivers have a usable USB driver and/or USB device on them while others do not. Garmin has always played on the fringe of USB compliance and they use a custom function driver that may do some pretty non-standard things. Without watching the USB bus traffic it is difficult for me to say where the blame resides. I have heard some people have had some difficulty with USB on pure Windows boxes so trying to do the same thing on a virtualized device (that wasn't designed to be virtualized) can sometimes be a problem. BTW, I have had experience with USB devices on Windows and Microsoft USB drivers are some of the worst.
     
  20. rcomeau

    rcomeau

    Messages:
    42
    Hi,

    Thanks for the product link. I use Keyspan adapters because they also work on the Mac, but given all the time I've wasted trying to get that to work, maybe I'll just get one of these and use it for the PC side, and keep the Keyspan for the Mac side. Quite a kludge, but I'm not above kludges at this point.

    Cheers,

    rcomeau
     

Share This Page