Getting Linux to recognize external USB drives - what drive formats work?

Discussion in 'Linux Guest OS Discussion' started by tomath2o, Dec 9, 2008.

  1. I am trying to access two USB drives in Parallels 3 on my MacBook Pro.

    I have tried this both with the latest CentOS (I just upgraded this), and the Fedora Core 10 Desktop Linux Live CD.

    I have two USB drives: a WD My Passport, formatted FAT;
    and an older hard drive transplanted from a Linux box into a portable USB HD enclosure, formatted ext3.

    I cannot get either Linux distro in Parallels to display a filesystem on either USB drive.
    I have the Parallels USB option set to automatically go to Guest OS (yes, I rebooted after setting it).

    For the ext3 drive, I see the list item
    ATAPI-6 Bridge Controller
    in Devices->USB on the Parallels top menu, and it is checked. (This is not there when the USB HD power is off.)

    However, I see no way to mount the drive within Linux - it does not appear anywhere in hardware browser, or disk management, or in /etc/fstab, and there are no sda* devices visible in /dev.

    When I uncheck the ATAPI-6 Bridge Controller list item, the USB HD power LED does blink, and OS X then tries to mount it (which it can’t, being ext3), showing that there is some kind of connection happening.

    (Note that I can mount and see this ext3 USB drive fine on my Linux box in Fedora Core 4.)


    As for the WD MyPassport FAT drive, it’s pretty much the same deal, except in the Devices->USB list it appears as
    External HDD
    and is checked.
    As with the other drive, unchecking it frees it to be mounted automatically in OS X (which it can do, so it does).

    Independent of Parallels, OS X can see the FAT drive fine.


    I have tried to do all this both plugging the drives before and after VM boot, since I read somewhere it won’t work one of the 2 ways (I forget which).


    So the question is, does anyone have experience mounting USB ext3 and FAT format drives in Linux on Parallels?
    If so, how did you get it to work?



    Is it possible that external USB drives must be formatted HFS (the Mac format) to be used in Parallels, even in Linux?

    One would think it should at least be able to mount FAT drives, since their use is widespread - so why won't it?


    In case you are wondering why I would want to do this, I am trying to copy files from the ext3 drive to the FAT drive, which I cannot do in OS X because it does not recognize ext3 drives (at least not natively, and there appears to be no stable tool that does this).
    Yes, I could do this on my old Linux box, but it has USB 1, and a very slow CPU besides, so it takes forever.

    Tom
  2. One of the workarounds suggested for not being able to access USB hard drives directly is to use Shared Folders.

    However, I see from the documentation that the Shared Folders tool in Parallels Tools is not supported for Linux.
    This is confirmed when I select Shared Folders in the Parallels Configuration Editor for CentOS --
    I see the message
    Feature is not available for this type of guest operating system.

    So this is out.
  3. Below is some data from the CentOS /var/log/messages, which show up shortly after I plug in the power for the FAT USB HD.

    Dec 10 14:12:21 localhost kernel: usb 1-1: new high speed USB device using ehci_hcd and address 7
    Dec 10 14:12:33 localhost kernel: usb 1-1: device not accepting address 7, error -110
    Dec 10 14:12:33 localhost kernel: usb 1-1: new high speed USB device using ehci_hcd and address 8
    Dec 10 14:12:45 localhost kernel: usb 1-1: device not accepting address 8, error -110
    Dec 10 14:12:45 localhost kernel: usb 1-1: new high speed USB device using ehci_hcd and address 9
    Dec 10 14:12:55 localhost kernel: usb 1-1: device not accepting address 9, error -110
    Dec 10 14:12:55 localhost kernel: usb 1-1: new high speed USB device using ehci_hcd and address 10
    Dec 10 14:13:06 localhost kernel: usb 1-1: device not accepting address 10, error -110

    Turning the USB device power off results in no new messages.
  4. John@Parallels

    John@Parallels Parallels Team

  5. Thanks for the response, but that issue appears to be only about irritating log messages that aren't really indicating an error, since at the end he states
    To your knowledge, has anyone ever successfully accessed any format USB HD in Linux from within Parallels?
    If so, how did they do it?

    Tom
  6. John@Parallels

    John@Parallels Parallels Team

    Here it is
    External disk using SATA-to-USB

    Dec 14 03:16:50 winsuppot45 kernel: [ 3805.618921] usb 2-1: new high speed USB device using ehci_hcd and address 3
    Dec 14 03:16:51 winsuppot45 kernel: [ 3805.783128] usb 2-1: configuration #1 chosen from 1 choice
    Dec 14 03:16:51 winsuppot45 kernel: [ 3805.843928] scsi3 : SCSI emulation for USB Mass Storage devices
  7. Ok....

    How is this drive formatted?
    FAT? FAT32? ext3? hfs+? ntfs?
    (Disk Utility will tell you, under Partition tab)
    USB drives often come preformatted as FAT, I understand.

    I see your device connected as USB 2, whereas mine is trying to use USB 1.
    Maybe that is a function of the Linux distro....
    Which flavor of Linux are you using?

    Hm, SCSI emulation.
    Why would it do that?

    Tom
  8. John@Parallels

    John@Parallels Parallels Team

    1. FAT32
    2. Ubuntu 8.04
    3. It is always as SCSI emulation for every USB disk I am connecting
  9. OK, here is where I am at with this now:

    Still can't get it to work.

    I installed Ubuntu since that is what you are using - but 8.10, not 8.04, if that matters.

    Attached to this are shots of various Ubuntu screens after I had
    1) Started the Ubuntu VM
    2) Checked Parallels menu: Devices->USB shows no HD
    3) Connected and turned on the FAT device
    4) Checked Parallels menu: Devices->USB shows "External HDD", and is checked
    5) Appears to be no way to access the files on the FAT device: nothing mounted
    6) Ran dmesg; output is the consecutive screens in the attachments to this (*dmesg1 and *dmesg2 JPEGs)
    (Internet access in my Ubuntu VM not working by default for some reason; since no clipboard or file sharing in Linux, this seems to be the only way to record output, through Grab screenshots)
    7) Inspections of /dev/*sd*, /etc/fstab and /etc/mtab led to the conclusions that the system is trying to put the device into /dev/sda2
    8) So I created a new dir /mnt/fat and tried the mount command; didn't work, see attached *mount.jpg
    9) dmesg output resulting from mount attempt is *dmesg3.jpg
    10) When I uncheck "External HDD" in Devices->USB, Ubuntu succesfully releases it and the FAT disk mounts on my Mac OS X Desktop, as expected.

    I don't know enough about Linux to fool around with ehci_hcd and such as suggested by linux forums and such, for example
    http://ubuntuforums.org/archive/index.php/t-38714.html
    which seems to indicate others have problems with Ubuntu mounting USB drives...

    I did run lsmod, and its output is also attached, if that'll help. (*lsmod.jpg)

    Are the IRQ messages in the *dmesg1* indicating an IRQ conflict?
    If so, what do I do about it?

    Is there a fix to the "device not accepting" messages?

    I am at the limit of how much time I want to spend on this, if this message doesn't suggest a quick solution to someone, I am about ready to give up and do without USB access in Linux in Parallels.

    Tom

    Attached Files:

  10. This thread is associated with trouble ticket Parallels #637321.
  11. John@Parallels

    John@Parallels Parallels Team

    Sorry, the problem is Ubuntu 8.10 is not supported in parallels Desktop version 3
  12. I have installed Ubuntu 8.04.1 and ran all the same tests.

    dmesg output was the same.

    Tom
  13. Installed Parallel Tools.
    No change, same tests, same results.

    BTW, I still get the same message about Shared Folders not being supported in the config editor - didn't I read elsewhere here that this works in 8.04?

    Tom
  14. John@Parallels

    John@Parallels Parallels Team

    Sure, it is , but in Parallels Desktop version 4

Share This Page