Grey screen freeze - Update caused problem?

Discussion in 'Installation and Configuration' started by MooneyMan, Oct 22, 2010.

  1. Here is my shot at using the forum. The following is my summary of a problem that just appeared a week ago when I got home. I leave my Mac and Parallels running during the day. They are set for auto updates. I have tried to use the format suggested in the sticky message. And a search didn't turn up much, but then I am not even sure what to search for. I suppose I will invest in a pay-for-service call if no one has any ideas. Here are the details:

    Problem: During an auto update when I wasnt around - could have been a Windows update, a MacOS update or a Parallels update - a restart seems to have been forced. I do not know what forced the restart. When Parallels started up again, it reached the Grey window and the little rotating Windows star simply freezes. Parallels Desktop is identified by the MacOS as not responding. Forcing a quit of Parallels Desktop seems to leave some parts running as my BOOTCAMP partition does not reappear and I am unable to select Windows as the startup partition using the Startup Disk system tool. It does not even appear in the selection window. If I disable the Parallels Desktop autostart, I can restart the Mac and the BOOTCAMP partition reappears. I can then select it via Startup Disk and run in native Windows. So there is nothing wrong with the Windows partition (Vista). It still works.

    1. Mac OS Version: 10.6.3
    2. Parallels Build #: ParallelsDesktop-parallels-en_US-5.0.9376.599993
    3. What kind of computer: iMac, 3.06 GHz Intel Core Duo
    4. Total Physical RAM: 8GB
    5. Hard Drives: 1 TB WDC WD1001FALS-40K1B0
    6. If you are using a BootCamp configuration or not: YES
    7. Did you upgrade from a BETA: NO
    8. With what Build did the problem start: unsure, latest auto update probably
    9. If Parallels Tools are installed: YES
    10. Anything you have tried to get things working:
    
LOTS. I ran the uninstaller that came with Parallels. Then reinstalled using the latest build newly downloaded. Same problem. I then did a full uninstall as identified on the support page. This removes credentials and requires reactivation. Did a full reinstall with a newly downloaded copy of the installer. After reactivating Parallels, it eventually it asked me to re-enter my Vista authentication. This was a bit more complicated as it required that I dig up a USB keyboard since it would not recognize by Bluetooth keyboard. Ultimately, it locked up and MacOS reported Parallels Desktop as not responding. Oddly enough, I can hear the assorted Windows boot-up sounds even after forcing Parallels Desktop to close. So some part of windows is running in the virtual machine.

    11. Anything specific about your set-up you think we should know: Nothing special.
    12. If you are crashing, upload some crash logs: not crashing
    13. If you are getting an error message type it in and then attach a screenshot. no error message
    14. If you are having issues with a specific component (i.e. mouse, keyboard, monitor) tell us what it is. No problems with specific components

    Bottom line is that something has changed - very possibly the upgrade to MacOS 10.6.3, or possibly the latest Parallels 5 update has a problem such that things are incompatible.

    Any suggestions?
  2. Is Parallels Desktop app set to start automatically when your Mac boots (i.e. is it set as a login item in the Accounts preferences)? If so, then maybe it's starting to early.

    The Parallels Desktop app is hanging but the virtual machine is still running because it's run in a different process. While the virtual machine is running, it keeps the Boot Camp partition unmounted so it can be used with the virtual machine.

    The Console.app may show some hang or spin logs for the Parallels Desktop app which may show where it's hanging.

    The latest version of Mac OS X 10.6 is 10.6.4. Try updating to that.

    If you have any third party software that might affect the Parallels Desktop app then try disabling them. Application Enhancer, Virus or disk protection software etc. Also disable Time Machine. Try disabling 3D acceleration in your virtual machine hardware configuration.
  3. No Joy

    You said:

    "Is Parallels Desktop app set to start automatically when your Mac boots"
    No. Used to be before this problem happened - and it worked just fine. But I have removed it from the startup list. The freeze happens exactly the same when Parallels Desktop is started manually after MacOS boot-up is complete.

    The Console.app may show some hang or spin logs for the Parallels Desktop app which may show where it's hanging.
    Console.app shows the following log entry that repeats itself over and over until the Parallels Desktop is killed:
    10/24/10 9:09:40 AM 10/24/10 [0x0-0x22022].com.parallels.desktop.console[331] Qt: internal: -108: Error ATSUMeasureTextImage text/qfontengine_mac.mm: 1097
    Sadly, I have no idea what any of this means.

    The latest version of Mac OS X 10.6 is 10.6.4. Try updating to that.
    My Mac is using 10.6.4. No change whatsoever.

    If you have any third party software that might affect the Parallels Desktop app then try disabling them. Application Enhancer, Virus or disk protection software etc. Also disable Time Machine. Try disabling 3D acceleration in your virtual machine hardware configuration.
    I have disabled time machine, virus protection and any other third party SW I can identify. No change whatsoever. Note that no new 3rd party SW was added prior to the original freeze-up (although an auto upgrade could have happened...). I don't know what "3D acceleration in your virtual machine hardware configuration" is. Regardless, since Parallels Desktop never starts, I have no access to the VM settings. Or, at least, I don't know how to do this.

    Other things tried: I stopped ALL running applications (Mail, Chat, Skype, etc.) before starting Parallels Desktop in case it was some kind of new conflict. Absolutely no change whatsoever.

    Things I will try (again):
    Complete de-install of Parallels and reinstall.
    I'll do some research as to what the console message means - although such cryptic messages are always difficult to investigate without some Unix knowledge - of which I have little. My experience with Unix is that no one person knows everything so it is a matter of finding the person that knows about the bit you are interested in. Not an easy task.
    My amateur interpretation of the console.app message suggests that some file in the operating system has been damaged. But what that is, and how to fix it short of reinstalling MacOS and starting over from scratch, I do not know. It is possible I could simply do a complete Time Machine restore from 2 weeks ago - although I am not sure that it will restore the damaged file.

    Any other advice would be appreciated.
  4. -108 might be a memFullErr. You may have a corrupted font or a font that's making things crash. Use Font Book.app to check your fonts. Maybe move all the fonts out of ~/Library/Fonts (in your user folder).
  5. Accually, I do have the same problem as MooneyMan.

    I tried a lot of things, even reinstalling parallels - but with no positive effect.

    After removing all the fonts out out ~/Library/Fonts, parallels desktops was starting again, and my vm was starting...
    It took a long time for the Windows XP start screen to disapear (5min) and then another 5min for the logon to appear...
    But now it works.

    Thanks

    dirk
  6. good news... sort of

    First I used Font Book to check my fonts. It found a number of damaged ones so I removed them. Still Parallels Desktop locked up. Then I removed ALL the fonts and, as noted by diwa, after re-registering Windows and waiting a VERY long time, it finally started up properly.

    Now comes the hard part of sorting through 63 font files to find out which one (or ones) are bad. Should be able to do it in 6-7 restarts.

    Thank you for your help.
  7. You should check the error log using console.app.
    Opening all the fonts (at once) with font book and check the logs...

    Ciao

    dirk
  8. Well... this has been an "interesting" experience. But the good news is that I am back up and running - although I continue to have nagging problems with Windows Sidebar - but that is for another forum topic some other day.

    Seems that I needed to run Font Book and verify fonts a couple of times to remove all bad fonts since, after multiple starts and restarts, I was unable to identify any one font (other than the one removed the second time I ran Font Book) as being the culprit. Could be that I had too many fonts and a couple of duplicates causing some kind of memory overflow that Parallels Desktop was unable to handle.

    Console still throws up a couple of Parallels errors every time during start-up but I am going to assume "they all do that" and count my blessings. For those that enjoy this kind of thing, typical errors logged include:

    10/25/10 10:32:43 AM 10/25/10 [0x0-0x7d07d].com.parallels.desktop.console[1126] objc[1126]: Class QMacSoundDelegate is implemented in both /Library/Parallels/Parallels Service.app/Contents/MacOS/libQtGui.4.dylib and /Library/Parallels/Parallels Service.app/Contents/Frameworks/ParallelsVirtualizationSDK.framework/Versions/Current/Libraries/libprl_sdk.dylib. One of the two will be used. Which one is undefined.

    10/25/10 10:32:45 AM 10/25/10 [0x0-0x7d07d].com.parallels.desktop.console[1126] Mon Oct 25 10:32:45 Blackcomb-iMac.local prl_client_app[1126] <Error>: CGImageCreate: invalid image size: 0 x 0.


    I assume the first (one of 6 similar errors that appears evert time) is just how Parallels is installed since I reinstalled the application three times each after a full deinstall. The second I do not know.
  9. Interesting indeed. I had a similar problem: coming home today, parallels suddenly wouldn't start any more. I only got the endlessly spinning ball. De-installed and re-installed parallels, still nothing. Stumbled upon this thread, thought it couldn't hurt to try the fonts tip. Duplicated the fonts folder, deleted all fonts from the original folder. Presto, Parallels starts up like a charm. Now comes the really strange part: I moved all the fonts back to the folder one by one to see which one was the culprit. None of them caused any problems at all.
    Well, as long as it works, I won't complain...


    Cheers,
    Xaver
  10. It is very possible that the act of copying the font files, deleting the old ones and replacing with the copied ones fixed whatever was wrong with the damaged file. When copying a file, the finder does all the normal file checking. Could have been something in one of the headers of one of the fonts that got corrected when copied. Hard to say as there is no real way to objectively check.
  11. I do have a lot of these too.
    This includes applications from Adobe like Acrobat 8 Pro or Photoshop CS3...

    Ciao

    dirk
  12. Same issue here: Parallels stuck with startscreen and spinning ball,
    log floated with "Error ATSUMeasureTextImage text/qfontengine_mac.mm: 1097" messages.
    Clearing font caches didnt help, then i stumbled into this thread.
    Deleted all Fonts, and voila! Works again.
    This seems to be a bug in Parallels, imo.
  13. I am experiencing the same symptoms where I am stuck at the start screen with the spinning ball. I copied the fonts into a temp folder and then I deleted the fonts in the library/fonts folder. It still does not work. Please let me know if there are any other options that I should try. Should I also delete the fonts in the temp folder?
  14. iMac Boot Fails at com_parallels_kext_prl_vnic:created vnic1

    lost the HD on my iMac and got it replaced by Apple.

    Did a full restore from time machine without error, but on the subsequent boot it hangs at the subject message.

    No idea where to go from here. thanks.
  15. What Finally Happened?

    Eventually Parallels so damaged the Bootcamp partition that I had to delete the partition, recreate it, reinstall Windows, reinstall Parallels and start all over. Fortunately I keep all my documents on the Mac partition so it only meant reinstalling all of the applications. I also upgraded to Parallels 7. I also no longer keep Parallels running if I don't need the PC functions. That is, I only start Parallels when I need to operate from the Windows environment - which is becoming less and less as time goes by.
  16. Hmm. Well, I run Parallels as an app under OSX Lion, so it is "all one partition" as far as the Mac is concerned. I'm thinking it is time to try to get Parallels support involved.
  17. bilber, try uninstalling Parallels, and then reinstalling it. It's possible the time machine backup was not sufficient in reinstalling Parallels.

    Follow these instructions to uninstall Parallels Desktop 7 (incase the Parallels uninstaller app doesn't get everything)
    http://kb.parallels.com/112189

    If you've ever had older versions of Parallels, then make sure they are removed as well. At the top of that kb is a list of links for removing older versions.

    Then restart your Mac.

    Then reinstall Parallels Desktop 7.

    Also, in the future, please create a new forum thread when making a completely unrelated post.

Share This Page