Import from Boot Camp partition problems

Discussion in 'Installation and Configuration' started by skopch, Dec 1, 2010.

  1. I recently got a new iMac and I'm having an issue with a VM that I imported from a Boot Camp partition on my old Macbook Pro. I upgraded the laptop from Parallels 5 to 6 in order to take advantage of the import from Boot Camp partition feature and also the reported speed boost (which are great btw). After the import process completed, I moved the new VM to the iMac and started Parallels. Everything is working fine within Parallels, except for the fact that there are 4 partitions on the virtual hard drive (see attached disk management screenshot), including the GPT partition and what was the rest of my hard drive on the MBP. Because of this, my Windows C: partition is a fixed size and isn't affected by increasing the size of the VM in the Parallels config. The drive is set as an expanding drive, but all it changes when increased is the unallocated space before the Windows partition and once set, it's not possible to decrease the size of the VM (only increase). Because of these residual partitions, Parallels is not able to "Resize file system" (see other screenshots). The actual PVM file however is only the size of the existing files in the Windows partition, so that is working correctly.

    I think I understand what is happening - on import, Parallels is copying the entire MBR from Boot Camp, which includes all the other partitions on the Mac. I've tried to delete and merge the partitions using Gparted and PartitionMagic. Gparted completed the merge, but because the Windows partition was moved, I couldn't get Windows to boot again (even after fixmbr and fixboot in the Windows recovery console). PartitionMagic gave an error (117) saying it couldn't find a valid drive letter for the system. Any attempts to edit the partitions using the disk management console resulted in an unbootable VM. I also tried the import process with Fusion 3.1.1 and the exact same thing is happening.

    I basically just want a single, expanding partition with Windows on it. Has anyone else had this problem, or is it something odd with my Boot Camp setup? Is there some proven way to either delete and merge these other partitions or to import from Boot Camp without grabbing all the other partitions?

    My specs are:
    iMac 2.93 Core i7, 12GB RAM, 1TB HDD, OS X 10.6.5, running Parallels Build #6.0.11828 with Parallels Tools installed

    Attached Files:

  2. Winclone?

    Alternatively, is there a way to do this using Winclone? I already made a Winclone backup of the Boot Camp partition when I started this process, but I'm not sure how to properly import that into a Parallels VM.

Share This Page