Inventor 2013, Parallels 8 Graphics issues...

Discussion in 'Windows Guest OS Discussion' started by nanoplane, Jan 4, 2013.

  1. nanoplane

    nanoplane

    Messages:
    4
    I'm running on an MBP core i7, 10.8.3, 16G ram..

    Running Inventor, the graphics displayed in the content windows for 3D graphics is mangled.. (example attached.)

    this appears to happen randomly, sometimes everything displays fine but there are times when it's mangled regardless of how many times I restart, shut-down of both the VM or MAC environments...

    Any thoughts on how to make things work all the time??
     

    Attached Files:

  2. Andrew@Parallels

    Andrew@Parallels Parallels Team

    Messages:
    598
    Hi nanoplane,

    Does this issue happen only in Coherence view mode, or in Window as well?
    Have you tried to assign more video memory to your VM and play with the video settings at Configure > Hardware > Video?
    The next time when you see the problem, hit Help > Report a Problem and post the ID here.
     
  3. nanoplane

    nanoplane

    Messages:
    4
    Inventor Graphics issues

    Yes it happens in all window modes.

    I've tried multiple combinations of Graphics memory allocation (up to 1GB), Video configurations in Parallels and Inventor Graphics preferences configurations, etc.

    I have 3GB and 3 processors assigned to the VM.


    I have submitted a problem report # 21254346
     
  4. Andrew@Parallels

    Andrew@Parallels Parallels Team

    Messages:
    598
    Please try these steps:
    1. Temporarily uninstall AVG
    2. Reinstall Parallels Tools: http://kb.parallels.com/4841
    3. Restart VM and run Inventor

    Does this help? Need to find out if Parallels Tools corruption is the case and we need to take off AV for the "clean" test.
     
  5. martl80

    martl80

    Messages:
    3
    Hi,

    I also have a problem with Inventor 2013 and Parallels 8. The VM crashes when I run Inventor and open a part or click the windows enlarge button on the inventor window. I´ve the same error running a Windows 7 professional installed right in Parallels as on a installtion with boot camp. Sometimes it takes only seconds, sometimes a minute till the crash occurs. I´ve tried different settings at Parallels -> Hardware -> Graphics and have tried different settings in Inventor. It seems to work well when a deactivate the drirectx acceleration but this is not satisfying because it´s too slow. My machine is an iMac i7 3.4 GHz, 8GB RAM and NVIDIA GeForce GTX 680MX 2048 MB. I have 4GB RAM 4 cores and 1GB Graphic memory (maximum) assigned to the VM. I´ve installed parallels tools again.

    One thought to the graphics driver: In boot camp the nvidia driver has been installed. When I start the boot camp system with parallels there is no nvidia card detected. Is this normal?

    What can I do further?
     
  6. serv

    serv Parallels Team

    Messages:
    752
    Try adding line "video.no_depth_load=1" (without quotes) to VM Configuration > Hardware > Boot order > Flags.

    NVIDIA graphics chip is controlled exclusively by OS X driver. Windows running in a VM talks to virtual graphics adapter, which resorts to serious magic to convert DirectX to OpenGL and ask OS X to render pixels.
     
  7. martl80

    martl80

    Messages:
    3
    I´ve added the line and started the VM again but I can´t see any changes. The VM shows that there is no NVIDIA Chip. Do I have to do anything else?
     

    Attached Files:

  8. serv

    serv Parallels Team

    Messages:
    752
    This boot flag is meant to help with VM crashes when you run Inventor. Does it still crash?
    As I already explained, NVIDIA chip will not be visible in a VM. That's normal.
     
  9. martl80

    martl80

    Messages:
    3
    First time I´ve restarded the VM it crached again. I have then turned off the 3d acceleration to be able to work with the system even when it is slow. Yesterday afternoon the Autodesk support called me and we checked the Inventor installation and settings. Everything was right. We turned on the 3d acceleration and switch to directX 9. In Inventor we use "power" mode for graphics (not "quality" which uses directX 10). Now we have to observe the system if it crashes again.

    Thanks!

    Martin
     
  10. I had exactly the same rendering issues as the original poster (with Inventor 2012 and Parallels 8). Re-installing the Parallels Tools and insuring that the latest version of Parallels was installed didn't fix the issue. What did work was going into the VM configuration and changing the video mode to DirectX9 instead of 10. That's not ideal, but it did work.
     
  11. mgreig

    mgreig

    Messages:
    1
    I didn't have rendering issues, but the display response was so slow as to be unusable. I went to DirectX9 from DirectX10 and it's helped, though honestly it's still much slower than my old Core2Duo running an earlier version of Parallels. This is running Inventor 2013 on Parallels 8.0.18615, Revision 948847.

    I will reluctantly pay to upgrade Parallels to Version 9 in the hope that it may fix this graphics issue.
     

Share This Page