"No device drivers were found...." Can't finish Windows 7 install in 2010 MacBook Air

Discussion in 'Installation and Configuration' started by ChristinaA2, Nov 19, 2010.

  1. ChristinaA2

    ChristinaA2

    Messages:
    2
    I get the following error message a few seconds after the language selection screen on the Windows Install.
    "No device drivers were found. Make sure that the installation media contains the correct drivers, and then click OK."

    I have been unable to get through the Windows 7 installation process. I installed Parallels and get to the part of the Window 7 install where it reads, "Install now". I click on that and it reads, "Setup is starting". A few seconds later I get a pop-up that reads:
    Load Driver
    A required CD/DVD drive device is missing. if you have a driver floppy disk, CD, DVD, or USB flash drive, please insert it now.
    Note: If the Windows installation media is in the CD/DVD drive, you can safely remove it for this step.

    I copied the Windows 7 drivers using Boot Camp Assistant onto both a CD and a USB drive.

    I downloaded the Windows 7 Home Premium 64bit installation files as three separate files and as an ISO file. I tried installing with both options after specifying a CD/DVD image in the initial install screen.

    What I have:
    MBA 2010 4GB 1067 MHz
    1.6 GHz Intel Core Duo
    Mac OS X 10.6.5
    MacBook Air SuperDrive

    Legitimate registered version of Parallels
    Legitimate license for Windows 7 Home Premium


    * Please help. What am I missing?
     
  2. ChristinaA2

    ChristinaA2

    Messages:
    2
    "Authentic" disk necessary for MBA/Windows 7 install?

    Has anyone been able to install Windows 7 via Parallels on a MBA using an ISO file? That is, using the disk image option vs. having an authentic install disc from Microsoft? I downloaded the files off the Microsoft website and am wondering if the reason why the install won't work is because I am not using an "authentic" disk.

    Please advise!

    Thanks.
     
  3. DavideM

    DavideM

    Messages:
    1
    Same problem with macbook pro & win7PRO original windows image... no problem installing ubuntu 10.10
     
  4. BassAtl

    BassAtl

    Messages:
    10
    Found a Fix

    I had this exact problem installing Win 7 -64-bit on my new MacBook Air. I believe my Windows DVD is damaged or corrupt. After nearly a full day of frustrating efforts, I downloaded the ISO image for free. It's a 3GB file, so it takes a while to download. Afterwards, install your VM pointing to the ISO image instead of the DVD, but use the key code from your DVD. Installation using that method went smoothly and much faster than using the DVD. I downloaded the ISO image from mydigitallife.com, but I think there are multiple sites where it is available. Good luck and I hope it works for you as well.
     
  5. PaulFrost

    PaulFrost

    Messages:
    1
    I'm getting the same error about device drivers on my new iMac.
    Any solutions?
     
  6. BassAtl

    BassAtl

    Messages:
    10
    If you read my post, then that is "a" solution that will work for you, whether you are on a MBA w/no DVD drive or on an iMac. Download the ISO takes about 45 minutes, depending upon your connection, and once you point to that ISO during the installation process, it is very fast from that point forward.

    Additionally, one solution that actually did work for me, partially, was to simply eject the DVD when the error message first comes up, asking you to supply the driver. When you see that message, use the button on your keyboard to eject the DVD, then put it right back in. That might get you over the hump and get the installation process moving. But, in my particular case, it hung during the "expanding files" stage after getting to about 88%, as a result of a faulty DVD.

    Those are two good things to try. The first should work without a hitch; the second is a crap shoot, but should work if your DVD is good.

    Good luck.
     
  7. geraldp

    geraldp

    Messages:
    3
    Mba 2010

    I've installed W7 pro 64bits with // 6 last week on a MacBook Air (2010 edition), and it told me It encountered a problem with drivers. I've just rebooted it and launch almost fine. The // tools fixed few issues but not the graphic one. And windows is running with very few colors.
    Why do I post you that message ? Because I did the entire installations with an External DVD Player. So I don't think it's your ISO which cause the problem.

    I'm still working on making this VM runs better.

    DVHawk
     
  8. BassAtl

    BassAtl

    Messages:
    10
    I must not be making myself clear. After being frustrated for nearly a full day with the DVD/driver issue, I downloaded and used the iso image and it worked perfectly. Quick and flawless installation of Windows 7 Pro, 64-bit on a new MBA. No problems of any kind running parallels and Windows 7 on this machine.

    Best of luck to you in solving your issues.
     
  9. SkipM

    SkipM

    Messages:
    1
    Possible Solution

    I saw that the tools were not installed, in a message that said install tools, while Win 7 was installing. Big mistake, that took me 4 hours to figure out. I got caught in the driver loop, kept removing Virtual Drives - finally FINALLY I uninstalled Parallels, reinstalled, put my 64bit disk in, and voila, Win 7 64B up and running, and the drivers all fix themselves after Win& is up and running, install Parallel tools and they fix it all from there. I wasted my own day from rushing the process. Picture great, and smooth as silk, though I havent taxed it yet.
     
  10. AigarsJ

    AigarsJ

    Messages:
    1
    Simple solution

    Just change CD-ROM interface to IDE before starting up your vm and everything should be ok.
     
  11. TonmoyG

    TonmoyG

    Messages:
    1
    Thank you!! This worked and took 2 seconds!
     
  12. dblakesley

    dblakesley

    Messages:
    1
    Thanks, AigarsJ! Your solution worked beautifully (just wanted to confirm). I created an ISO image of my Win 7 Ultimate Upgrade 64bit disk, then before starting the installation of the VM in Parallels 6, I changed the interface to IDE 0:0, and it worked without a hitch.
     
  13. Rickfdez

    Rickfdez

    Messages:
    1
    The answer!

    Found this on the Apple Discussions Forum and it works (thanks g-d):

    For anyone in the future, you have to change the drive setting from SATA to IDE in the virtual machine settings. Setup will work as normal once the drive image is set to IDE.

    You have to do this before you start the install of Windows! Go to Virtual Machine:Configure:CD/DVD 1 and make sure you pick IDE 0:0 under Location. Then start the install.

    Don't install the Parallels Tools till Windows is all done.

    Why doesn't Parallels tell people this??
     
  14. VagelisB

    VagelisB

    Messages:
    5
    Still doesn't work for me ... any other ideas ?
     
  15. jpalmucci

    jpalmucci

    Messages:
    2
    I had the same problem

    The iso file, in my case, was fine. I disabled the floppy drive and everything worked.
     
  16. RusselJ

    RusselJ Banned

    Messages:
    25
    I am getting the same error about device drivers on my new iMac. What is the best solution?[​IMG]
     
  17. jpalmucci

    jpalmucci

    Messages:
    2
    my solution

    The floppy issue turned out to be a distraction. Install got further, but still died. What fixed it for me was upgrading to the most recent version of Parallels: 6.0.12092
     
  18. dhavalp

    dhavalp

    Messages:
    2
    All, i had the exact same issue and tried all possible solutions listed on the web. CD-ROM changed to IDE, USB install, using the Microsoft USB tool, trying to eject and just stopped short of some very convoluated VM creation solutions.

    Eventually turned out that the ISO itself was faulty. I was trying to use a DVD-RW but it all worked like a charm when i used an original Microsoft DVD. That is the only solution that worked.

    I am puttting this here as it is a very frustrating problem and i did spend a lot of time trying to find a solution including downloading some very dodgy software tools online. I have a MBP 2011. Cheers!
     
  19. shishirc

    shishirc

    Messages:
    3
    dude how to change cd rom interface to ide ?
     
  20. shishirc

    shishirc

    Messages:
    3
    dude how to change cd rom interface to ide ?
     

Share This Page