No network connectivity under Windows 2000 Guest OS

Discussion in 'Windows Guest OS Discussion' started by KlausR, Nov 9, 2009.

  1. KlausR

    KlausR

    Messages:
    5
    - I started using Parallels 3.0 18 months ago with 2 VMs on my MAC Pro.
    - One XP Boot Camp VM .
    - One Windows 2000 VM generated by Transporter on my old physical W2K machine.
    - Both VMs worked as expected, without any problem.
    - 7 weeks ago I upgraded to 4.0.3846 in anticipation of my Snow Leopard upgrade.
    - The XP VM continued to work without problems.
    - In the Windows 2000 VM, I can not get network connectivity, even after trying several alternative settings and after applying Article ID 5664.
    - In the meantime, I upgraded to MAC OS X 10.6.1. But no different behaviour of my troublesome W2K VM.

    - I also tried :
    http://kb.parallels.com/en/4855
    http://kb.parallels.com/en/4885
    http://kb.parallels.com/en/4841

    Anything else I should try ?
     
  2. Elric

    Elric Parallels Team

    Messages:
    1,437
    Please make sure that Win2k VM is in Shared Networking mode. Then boot the Win2k VM and:

    click Start -> Run and execute cmd.exe. Type in the appeared window command "ipconfig /all" (without quotes). Stretch the window to make all the output fit and without closing the window, click menu of Parallels Destkop "Help"->"Report a Problem", send a problem report (it is not necessary to provide description) and post here the report ID.
     
  3. KlausR

    KlausR

    Messages:
    5
    Problem Report id 782128

    I just send the problem report id 782128.
     
  4. Elric

    Elric Parallels Team

    Messages:
    1,437
    I believe it is Windows2000 issue. To fix it, please execute cmd.exe one more time and type in it
    netsh interface ip reset resetlog.txt
    netsh winsock reset
    then reboot the VM and check whether it have helped
     
  5. KlausR

    KlausR

    Messages:
    5
    DOS commands did not work due to syntax.

    Thanks for your immediate response.

    I tried to execute the suggested commands :

    netsh interface ip reset resetlog.txt
    netsh winsock reset

    which both led to error messages. Obviously these are not in line with W2K syntax rules.

    In addition, I don't think this is a W2K only problem, since everything worked perfectly under Parallels Desktop 3.0 . The problem only started after upgrading to 4.0 .

    What else could I try to get connectivity back.

    Thanks in advance for your support.
     
  6. Elric

    Elric Parallels Team

    Messages:
    1,437
    Please try the command "netsh interface reset all".
    We believe that it is some Windows 2000 issue and not the Parallels Desktop 4.0 one.

    The corruption likely occured before the upgrade and upgrade to PD4 just revealed it out.
     

Share This Page