Parallel Tools Outdated

Discussion in 'Linux Guest OS Discussion' started by LeslieM, Apr 28, 2012.

  1. I installed Ubuntu from the Parallels control panel. Since starting Ubuntu for the first time, I get the message that the Parallels tools are out of date and to manually install. I have opened the disk image on the Ubuntu desktop and clicked the install button, have tried both Run and Run from Command Line with no success. I know nothing about Ubuntu or Linux. Where to I go to find the updated tools and how do I install them? Also, the automatic update in the lower right of the status bar doesn't do the job, either.
    Last edited: Apr 28, 2012
  2. 1) Mount Parallels Tools -> Virtual Machine | Reinstall Parallels Tools
    2) Open a terminal window -> control-option t
    3) Goto the Parallels Tool directory -> cd /media/Parallels\ Tools/
    4) Run install -> sudo ./install
  3. JEarles,
    Are you referring to the Parallels installation software via OS X or from from within the Ubuntu VM? If from Mac OS, I am working with a downloaded drive image, not a physical disk (although the backup disk should be arriving in a week or so) and this doesn't seem to work with the disk image. It also does not seem to work from within Ubuntu.

    Thanks.
    Last edited: Apr 28, 2012
  4. From within the Ubuntu VM.

    Start Parallels Desktop, and open your Ubuntu VM. Once you are on the Unity desktop click the 'Virtual Machine | Reinstall Parallels Tools' menu option (in the Mac main Parallels Desktop menu). It should ask you to confirm, say 'Yes'. This will mount the Parallels Tools image (on my computer it opens the Parallels Tool folder in Nautilus). Then open a Ubuntu terminal window and follow steps 3 and 4.
    Last edited: Apr 28, 2012
  5. Ok, I think I understand it now.
  6. Hmmm. I have an option to Update the tools, no option to reinstall. Any idea why? Or what I can do to get around this?
  7. At what stage in the process are you seeing this? Is this after running 'sudo ./install'? If so that is expected, click update and the installer will update your Parallels Tool.

    If not, where exactly are you seeing this? What version of Parallels are you using?

    All we are trying to do is get you back to the point you were at in your original post. You wrote 'I have opened the disk image on the Ubuntu desktop'. However you did this previously should be fine. Then rather than 'and clicked the install button' you should open a terminal window, so you can run the installer manually (steps 3 and 4)
  8. I am still stuck on the first step:

    I have an option to update the tools, not reinstall them.
  9. >> I have an option to update the tools, not reinstall them.

    Okay... so take that option and see where it get us. Updating is the same thing as reinstalling.
  10. Hmmm. Previously, the CD command got me an error message that the directory location didn't exist. This time everything worked.

    Thank you.

Share This Page