Parallels 5, Windows XP Bootcamp BSOD on boot.

Discussion in 'Installation and Configuration' started by devilcat, Nov 15, 2009.

  1. devilcat

    devilcat

    Messages:
    7
    I am getting BOSD with Parallels 5 with Window XP sp3.
    The VM is based on functional Bootcamp Partition.

    I am running in on iMac 27' i7 with 4G of RAM.

    [​IMG]

    [Edit]
    Forgot to mention, CPU number *is* set to 1.
     

    Attached Files:

    Last edited: Nov 15, 2009
  2. voom

    voom

    Messages:
    10
    I have exactly the same issue. Things that I've tried:

    1, Changing to 1 processor
    2, Removing the floppy disk
    3, Reducing the memory to 1Gb
    4, Booting into bootcamp and removing the parallels tools, then rebuilding the Parallels VM

    None of these make any difference. I've also tried to open a support ticket, but as I got it as a free upgrade I don't have an order number so I can't get a support code.

    I've searched all of the forum and whilst there are a number of people who obviously have the same problem, there are no working suggestions on how to fix this particular BSOD. The 'single processor' option does not work!

    In the end, I've removed Parallels 5 and gone back to v4. Of course, I now need to re-license all of the software installed in the virtual machine.

    Considering how difficult it was to get my 'free upgrade' (confirming eligibility given the mass of conflicting information on the website and with Parallels sales staff - took over a week) and then this problem, the whole upgrade has, so far been an utter waste of time.

    So, to be clear about what I know of this problem:

    It seems to only affect users that have a boot camp partition
    It is limited to Windows XP guests
    None of the existing published fixes for other BSOD error messages make any difference

    Please can this be looked into as quickly as possible!

    Thanks,
    Ian
     
  3. devilcat

    devilcat

    Messages:
    7
    Hopefully, we will get some reply from the devs.
     
  4. voom

    voom

    Messages:
    10
    Has anyone heard any update on this problem? The forums seem quiet about this topic, so is there a solution that I've missed or has everyone just accepted that Parallels 5 doesn't work with XP and bootcamp and gone back to v4 (as I have)?
     
  5. devilcat

    devilcat

    Messages:
    7
    Has anyone find solution for this?
     
  6. spsmyk

    spsmyk

    Messages:
    2
    Same issue 0 tried the checklist nothing worked...
     
  7. I-che

    I-che Parallels Team

    Messages:
    493
    Hi, we are investigating the issue. Give us some time, please.
     
  8. Sol

    Sol

    Messages:
    9
    Same issue here

    Have XP SP3 installed in bootcamp ... virtual machine configuration tool stalls, and eventually locks giving an option to siwtch to manual config. I accept, the VM tries to start and I get BSOD.

    Tried removing Parallels 5, and reformatted bootcamp, tried to install from slipstreamed SP2 disc using parallels and again it failed. Bootcamp drive is not mounted or some such!!

    Very frustrated!
     
  9. spsmyk

    spsmyk

    Messages:
    2
    Reverted back to 4.0 works fine again...
     
  10. Sol

    Sol

    Messages:
    9
    Still waiting for an update on this one ...

    ... I've purchased Parallels 5 so have no option to revert to Parallels 4.

    Option 1: Wait for Devs to respond

    Option 2: Could I download a trial version of Parallels 4 from somewhere, and then use the Parallel 5 licence key? Would that work?

    Option 3: Does anyone think that I could use a trial version of VMWare, and assuming that works then use Parallel 5 to migrate the VM across?

    Option 4: Install a VM direct from disk and run two versions of XP - one bootcamped, and one via VM?

    Anyone have any ideas how I can get a VM running on my Mac Pro 8 Core in the interim to the Dev responding with a fix for this obvious issue? Has anyone found a solution/work around - I have a functioning Bootcamped XP SP3, Parallels 5 installed, but unable to create a VM over the bootcamp version.

    Thanks
     
  11. devilcat

    devilcat

    Messages:
    7
    Well, I have bit more info on this problem.
    Here's how you can work around it.

    Step 1. Create a non-bootcamp VM. Any version of Windows will do. If you already have working VM you can use that too.
    Step 2. Assign the Bootcamp drive as Hard Drive 2.
    Step 3. Boot into VM you used in Step 1. and go into Hard Drive 2 and rename \WINDOWS\system32\driversAppleMNT.sys to AppleMNT.off (any other name would work).
    Step 4. Shut Down (You can no longer suspend the VM you use for this).
    Step 5. Boot the bootcamp VM.

    Of course, if you want to actually boot into real Bootcamp, then you will have to reverse the change before you do.
    Alternatively, you can do the rename process in real Bootcamp, but it's really pain to to boot into Bootcamp, just so you can boot back into Mac to use bootcamp VM.
    I believe AppleMNT.sys is responsible for allowing Windows to have read access to Mac drives in Bootcamp. You can leave the file renamed if you don't need this function (or you use MacDrive, which I don't).
     
  12. devilcat

    devilcat

    Messages:
    7
    Anyone found any better way to get around this issue?
     
  13. devilcat

    devilcat

    Messages:
    7
    Has this been fixed yet on new version?
     

Share This Page