Running Parallels Desktop 8 for Mac on Mac OS X Mavericks 10.9

Discussion in 'Installation and Configuration' started by luke666s, Jun 11, 2013.

  1. luke666s

    luke666s

    Messages:
    4
    hi...
    with 10.9 Mavericks as host system paralles 8 desktop is not working... no virtual machine can be started...
    first there is an error that vt is not activated... then an error, that drivers are not installed...
     
  2. Caesium

    Caesium Bit Poster

    Messages:
    16
    Parallels in OSX 10.9 host

    Hello!

    Obviously can't say too much without breaking developer NDA, but Parallels (7.0.15107) doesn't seem to work in the OSX 10.9 beta.

    The list of virtual machines appears, but I have varied results trying to resume a machine; some of them just plain never appear, no window - some of them appear but claim virtualisation is disabled so the guest will run slowly (problem id: 507), but then fail to load the parallels driver (id: 352, leading onto id 41).

    At any rate no guests will start. Anyone have any other experiences, does PD8 fare any better? Will we see a fix for 7, or shall I just wait for PD9.
     
  3. madamm

    madamm

    Messages:
    5
    it is the same with parallels 8 --> is there a parallels' representative to tell us if there is a solution for that in the near future,
    or is it easier to switch to vmware ( vmware 5.03 is reported to work, not to expensive ... ).
     
  4. MatGailes

    MatGailes

    Messages:
    2

    Here's something I worked out earlier for Parallels 8 Desktop.

    ......


    So, Parallels 8 doesn't run natively under Mavericks, as it doesn't seem to be able to load the kernel extensions.

    Load them manually via kextutil:

    Terminal - go to Applications/Parallels Desktop/Contents/Library/Extensions/10.6

    sudo kextutil prl_hypervisor.kext/
    sudo kextutil prl_vnic.kext/
    sudo kextutil prl_hid_hook.kext/
    sudo kextutil -d ./prl_hypervisor.kext prl_netbridge.kext/
    sudo kextutil prl_usb_connect.kext

    Then start Parallels Desktop, and your guests should start up again.

    You may need to re-set networking within the guest.

    Not sure how stable this is going to be, but appears to be working at the moment.

    Have fun now,
    Mat
     
  5. PelleR

    PelleR

    Messages:
    1
    Same issue here.

    First I get this message:
    http://cl.ly/image/1E1r2k3b183Y

    After I get this message:
    http://cl.ly/image/1p3O1P0D2X3o

    And lastly I get a bug report form to fill out, but forgot to copy the ID for reference this issue (sorry).
     
  6. luke666s

    luke666s

    Messages:
    4
  7. MatGailes

    MatGailes

    Messages:
    2
  8. msurtees

    msurtees

    Messages:
    2
    Same here. Bummer :(
     
  9. Specimen

    Specimen Product Expert

    Messages:
    3,007
    Is this after a clean install of PDM8 in 10.9 or 10.8 was upgraded to 10.9 with PD8 in place? I suggest uninstalling and reinstalling PDM8, have you guys tried that?
     
  10. luke666s

    luke666s

    Messages:
    4
    hi... it was an update... pdm8 running on 10.8 updated to 10.9.... i'll try uninstall and reinstall later...
     
  11. luke666s

    luke666s

    Messages:
    4
    how to do a proper uninstall? only moving to trash?? cause the the problem still exists....
     
  12. bradhs123

    bradhs123 Bit Poster

    Messages:
    7
    Wow, this works!

     
  13. Specimen

    Specimen Product Expert

    Messages:
    3,007
    Yes, just moving to the trash, but in another similar thread a user found the problem, PDM8's kernel extensions have to be manually launched.

    http://forum.parallels.com/showthread.php?287726-Parallels-in-OSX-10-9-host

    Why this is happening, I have no idea. But I'm sure Parallels will sort this behaviour for PDM8, for PDM7 I'm not so sure, depends if it's 2 year support has ended or not.

    Or maybe Apple will fix this. It's still a developer preview, remember that.
     
  14. Specimen

    Specimen Product Expert

    Messages:
    3,007
    Be sure to also report this problem to Apple.
     
  15. JohannP

    JohannP

    Messages:
    4
    Thank's a lot Mat! This does the trick. Now Parallels starts on Mavericks

    Now, I have fun
    Hans
     
  16. Caesium

    Caesium Bit Poster

    Messages:
    16
    Doesn't work for 7 since it doesn't have that Extensions directory as far as I can see :(

    Edit: I tell a lie! Found them in /Library/Parallels/Parallels Service.app/Contents/Kexts/10.6 and it seems to work :)
     
    Last edited: Jun 11, 2013
  17. AlexMBento

    AlexMBento

    Messages:
    6
    Doesn't work for me!

    No kernel file specified, using '/mach_kernel'

    Any idea!?
     
  18. Specimen

    Specimen Product Expert

    Messages:
    3,007
    Follow the instructions carefully, you have to know your way around the terminal, you have to change dir to teh one specified and only then issue the commands.
     
  19. Specimen

    Specimen Product Expert

    Messages:
    3,007
    Anyone experiencing this problem should report this to Apple, that's what the Dev preview is for anyway.
     
  20. Caesium

    Caesium Bit Poster

    Messages:
    16
    But we don't know that it's a problem with 10.9 yet. It might be a problem with Parallels, and trivially fixable by them, so we'd just be wasting Apple's time.

    I'd rather wait for confirmation from Parallels rep that the problem lies with 10.9.
     

Share This Page