The virtual machine cannot be used because its files are corrupted.

Discussion in 'General Questions' started by John Harrold, Mar 19, 2010.

  1. John Harrold

    John Harrold

    Messages:
    2
    Ok I just upgraded to version 5 (specifically I'm running Build 5.0.9344). I converted over my virtual machines, and spent a couple days installing new software. I came in to work today, fired up the virtual machine on parallels and got the following message:

    The virtual machine cannot be used because its files are corrupted.

    And my options are to either delete the files or cancel. Is that really the answer here? If I have no options other than to delete the virtual machine, I'm seriously going to consider using VMWare.
     
  2. John Harrold

    John Harrold

    Messages:
    2
    This is really odd. I just moved the pvm package/file associated with this virtual machine to a different location on the same file system and now it works. While this solves this problem, is there anyone from parallels that can explain what happened? This type of thing makes me feel kind of concerned.
     
  3. Helio Creative

    Helio Creative

    Messages:
    7
    Same issue

    My virtual is on an external hard drive - it works on one machine not another - last night it worked on both - whats the deal?
     
  4. joevt

    joevt Kilo Poster

    Messages:
    1,196
    Get Info on the disk in the Finder. Make sure "Ignore ownership on this volume" isn't selected.

    Check the permissions of the .pvm and the files inside the .pvm.
     
  5. Simon Kemp

    Simon Kemp

    Messages:
    5
    I have the same message when I booted up yesterday (so I had to force s shutdown on my Mac) and today. "The virtual machine is corrupted. The virtual machine cannot be used because its files are corrupted. With button "Remove" So if I hit remove I lose all my files correct? Any other answers? I did command-info on my HD and there is no sign of 'not sharing" or whatever the last post was. Does Time Machine back up the PC as well?
     
  6. joevt

    joevt Kilo Poster

    Messages:
    1,196
    Parallels does not delete or erase files. It will just remove the virtual machine from the Virtual Machine List window. It may also move files to the Trash. Files are not deleted until you manually empty the Trash so always check the Trash before emptying it.

    The "Ignore ownership on this volume" option is only available on external disks (FireWire or USB or whatever).

    Time Machine may or may not backup the virtual machine files, depending on your Parallels or Time Machine settings.

    Check the permissions of the virtual machine files with the following commands:

    Code:
    ls -ld ~/Documents/Parallels/*.pvm; ls -lRA ~/Documents/Parallels/*.pvm
    
    The only part of the virtual machine that you really need is the .hdd file. The rest of it you can recreate by making a new virtual machine which you can then set it's Hard Disk 1 to the old .hdd file. So check that the .hdd is not corrupt by opening it with Parallels Mounter.
     

Share This Page