Ubuntu 12.04 support

Discussion in 'Linux Guest OS Discussion' started by SilvrDrgn, Apr 26, 2012.

  1. SilvrDrgn

    SilvrDrgn

    Messages:
    47
    Obviously, as of this writing, Ubuntu 12.04 is very new, but I tried installing it anyway in a VM on Parallels Workstation Build 6.0.13950 (Revision 714087; November 24, 2011). Is Ubuntu 12.04 support coming soon?

    Host OS = Win 7 Home Premium 64-bit
    Guest = Ubuntu 12.04 Desktop 32-bit

    As I expected, Parallels Tools failed to install. Here is the relevant parts at the end of the install log:

    Thu Apr 26 19:05:48 CDT 2012
    Start installation or upgrade of Guest Tools
    Installed Guest Tools were not found
    Perform installation into the /usr/lib/parallels-tools directory
    cat: /usr/lib/parallels-tools/kmods/../version: No such file or directory
    Start installation of prl_eth kernel module
    make: Entering directory `/usr/lib/parallels-tools/kmods'
    cd prl_eth/pvmnet && make
    make[1]: Entering directory `/usr/lib/parallels-tools/kmods/prl_eth/pvmnet'
    make -C /lib/modules/3.2.0-24-generic-pae/build M=/usr/lib/parallels-tools/kmods/prl_eth/pvmnet
    make[2]: Entering directory `/usr/src/linux-headers-3.2.0-24-generic-pae'
    LD /usr/lib/parallels-tools/kmods/prl_eth/pvmnet/built-in.o
    CC [M] /usr/lib/parallels-tools/kmods/prl_eth/pvmnet/pvmnet.o
    /usr/lib/parallels-tools/kmods/prl_eth/pvmnet/pvmnet.c:391:4: error: unknown field ‘ndo_set_multicast_list’ specified in initializer
    /usr/lib/parallels-tools/kmods/prl_eth/pvmnet/pvmnet.c:391:4: warning: initialization from incompatible pointer type [enabled by default]
    /usr/lib/parallels-tools/kmods/prl_eth/pvmnet/pvmnet.c:391:4: warning: (near initialization for ‘pvmnet_netdev_ops.ndo_open’) [enabled by default]
    make[3]: *** [/usr/lib/parallels-tools/kmods/prl_eth/pvmnet/pvmnet.o] Error 1
    make[2]: *** [_module_/usr/lib/parallels-tools/kmods/prl_eth/pvmnet] Error 2
    make[2]: Leaving directory `/usr/src/linux-headers-3.2.0-24-generic-pae'
    make[1]: *** [all] Error 2
    make[1]: Leaving directory `/usr/lib/parallels-tools/kmods/prl_eth/pvmnet'
    make: *** [all] Error 2
    make: Leaving directory `/usr/lib/parallels-tools/kmods'
    Error: could not build kernel modules
    Error: failed to install kernel modules
    2012-04-26T19:05:54-0500: execCmd: ./install --install [143]
    2012-04-26T19:05:54-0500: Error: An error occurred when installing Parallels Tools. Please go to /var/log/parallels-tools-install.log for more information.
    2012-04-26T19:05:59-0500: Exiting with code 1
     
  2. JakubL

    JakubL

    Messages:
    10
    I've had the same error while installing parallels tools on Ubuntu 12.04 guest.
    I was able to come up with a solution.
    Tested in my case and it works. Can't give any guarantee but I thinks it's worth of checking:

    Here's what I did:
    1. Unpack the kmods/prl_mod.tar.gz
    2. Edit the file: kmods/prl_eth/pvmnet/pvmnet.c
    Change in line 391,
    from:
    .ndo_set_multicast_list = pvmnet_set_multicast_list,
    to:
    .ndo_set_rx_mode = pvmnet_set_multicast_list,

    3. Repack the prl_mod.tar.gz and launch the installer.
    Run the install and now it should pass just fine.
     
  3. SilvrDrgn

    SilvrDrgn

    Messages:
    47
    I followed your instructions, and the install of Tools did proceed successfully. It looks like everything works, except for the mouse. There is no mouse access, not even a pointer, in my Ubuntu 12.04 guest at all. Any way to fix that?
     
  4. JakubL

    JakubL

    Messages:
    10
    Great to hear. But I'm afraid the mouse problem will need to wait for official update of mouse driver from the parallel dev team. It seems that the current one won't work with the Xorg server version in Ubuntu 12.04. I've filed a problem report, you might do the same thing to speed things up.
     
  5. SilvrDrgn

    SilvrDrgn

    Messages:
    47
    Done. Thank you.
     
  6. JakubL

    JakubL

    Messages:
    10
    No problem. Glad I've could help.
     
  7. jmine83

    jmine83

    Messages:
    6
    How do I install the Parallels Tools for Ubuntu 12.04? This new version of Ubuntu has completely disabled the ability to login to the root user through the opening GUI login screen, and root access is required in order to install Parallels Tools. The other alternative method that I have tried but failed, was in my normal user account, open the terminal and navigate to the "media/Parallels Tools" directory and then try "sudo install". But it just complains that there is a "missing file operand" and won't run the install file. What am I missing?
     
  8. JakubL

    JakubL

    Messages:
    10
    Open the terminal and type in:
    sudo -s -H
    then if asked enter Your users password (not root's).

    EDIT: Also remember to copy files from the media/Parallels Tools/ to somewhere on your disk.
    From my understanding it needs rw access to disk to unpack some tools it needs.
     
  9. jmine83

    jmine83

    Messages:
    6
    Sorry, I have tried this but does not change the result I reported originally. In the past versions of Ubuntu that would allow me to login to root user through the opening GUI screen, I could simply mount the Parallels Tools iso, double-click on the "Install" file in the main directory of the iso, then click "Run in Terminal", and I would get an easy to follow wizard install program that does the job. I've never had to manually execute the Install file from the terminal first and that's where the problem is.

    The error "missing file operand" to my understanding implies there is some needed extra command I need to type in order to launch that same wizard program. Right now, even when logged into root user in the terminal, regardless of if I type "sudo install" or just "install" while in the correct directory, I still get "missing file operand".
     
  10. JakubL

    JakubL

    Messages:
    10
    In console:
    /media/Parallels\ Tools/install
    or
    cd /media/Parallels\ Tools/ && ./install

    EDIT: Your error means You forgot to add the "./". install is a linux command that's why You get this message. If You give the dot and slash it will launch the file called install instead of linux command.
     
    Last edited: May 2, 2012
  11. CarstenD

    CarstenD

    Messages:
    6
    Hey, I tried your solution JakubL and modified the c-file, repackaged it. However, I'm having trouble executing the installer if it is not in the mounted Parallels image.

    If I do a "sudo sh '/home/me/pt/install' (or a 'sudo sh ./install'), I get an error that I do not have permission to execute the 'installer.x86_32'. That's weird, since I called the install script with sudo. Do you have an idea?
     
  12. JakubL

    JakubL

    Messages:
    10
    Try without the "sh" in commandline.
     
  13. CarstenD

    CarstenD

    Messages:
    6
    Hi,

    I tried, but then I get a "sudo ./install": command not found" error. It only works with sh. If I don't use the terminal, i.e. double-click on "install" on the mounted Parallels image I get asked if I want to launch the file or open it with an editor. I don't get ask if I double-click on the local "install".
     
  14. ryanrk

    ryanrk

    Messages:
    2
    Do we know if this is going to get fix anytime soon? (with out having to do the hack)
     
  15. CarstenD

    CarstenD

    Messages:
    6
    I'm not aware of any progress.. I'd love to have better Ubuntu support too, without working Parallels tools it's not very comfortable to use.
     
  16. Lars-EivindB

    Lars-EivindB

    Messages:
    17
    Seems like the Mac version has it (http://forum.parallels.com/showthread.php?t=259301).
    Maybe that counts for something.

    Just got an answer for customer support where I asked about plans for Ubuntu 12.04 and just got an answer that Ubuntu 12.04 isn't supported. Seems like the support guy didn't really read my question :p
     
  17. CarstenD

    CarstenD

    Messages:
    6
    Well, I can install the Tools again, but it's not really working. If I go to Lion full-screen the resolution is not adjusting etc. A shame :( It worked so well in the beginning...
     
  18. Lars-EivindB

    Lars-EivindB

    Messages:
    17
    CarstenD:
    Strange..are you running Parallels Desktop on Mac or Workstation on Windows/Linux?
     
  19. CarstenD

    CarstenD

    Messages:
    6
    I run it on an iMac 27" 2011. I don't know.. I updated Ubuntu to the latest packages just before installing the new Tools, maybe it's broken again. Or there's some old stuff in the way.. is there a way to completely remove the old Parallels Tools and start from scratch?
     
  20. Lars-EivindB

    Lars-EivindB

    Messages:
    17
    I don't know :-\
    However - the Mac version (Parallels Desktop) is at version 7, which has experimental support for Ubuntu 12.04.
    The Windows/Linux version (Parallels Workstation) is at version 6, which does not have Ubuntu 12.04 support yet :(

    These are two different product that do not necessarily support the same things, unfortunately.
     

Share This Page