Unable to "Check for Updates" in Parallels

Discussion in 'Installation and Configuration' started by jerryc, Jan 5, 2009.

  1. I'm running Parallels for Mac Desktop Build 4.0.3540 on an XServe 10.5.6.

    I generally use a NAT system behind a managed router, static addresses. The Parallels adapters are green and connected using the built in Shared networking and DHCP server.

    Windows is able to connect to the internet and I can run Windows updates.

    However, when on the Mac side and I pull down HELP/Check for Updates I get:

    "Unable to connect to the Parallels Update site. Please check your Internet connection and try again."

    Therefore, I dnload full updates from the Parallels site to do updates.

    Anyone have a thought of what I'm doing wrong??

    Many thanks
  2. John@Parallels

    John@Parallels Parallels Team

    Are you using proxy in network settings, or is there any software limiting access, firewall on mac OS?
    here is some testing steps:
    Output for the following command from Terminal from /Applications/Utilities
    sudo ipfw list

    networksetup -listallnetworkservices
    Command above will return output of your network connections
    similar to one bellow
    VPN (PPTP)
    Parallels Shared Networking Adapter
    Parallels Host-Only Networking Adapter
    Bluetooth PAN

    Using your default connection to Internet, in My Case it is AirPort perform following commands

    networksetup -getwebproxy AirPort
    networksetup -getsecurewebproxy AirPort
  3. Here's my Terminal results:

    Output for the following command from Terminal from /Applications/Utilities
    sudo ipfw list

    I get: 65535 allow ip from any to any

    networksetup -listallnetworkservices

    I get: cp: /Library/Preferences/SystemConfiguration/preferences.plist.old: Permission denied
    An asterisk (*) denotes that a network service is disabled.
    Built-in Ethernet 1
    Built-in Ethernet 2
    *Built-in FireWire
    Parallels Shared Networking Adapter
    Parallels Host-Only Networking Adapter
  4. John@Parallels

    John@Parallels Parallels Team

    Do you have some kind of proxy on your router?
    Are you able to check for updates from another location?
  5. I DO NOT have a proxy on my router. Is there a solution??
    Last edited by a moderator: Feb 12, 2009
  6. Check for Updates fix

    I got the same message. My MAC defaulted to the download folder for the update file and tried several times with no luck. I changed it to the parallels directory and it worked.
  7. Thanks but it's "apples & oranges". My Parallels never gets to the internet to check for an update, much less as where to put it. As I mentioned above: "Unable to connect to the Parallels Update site. Please check your Internet connection and try again."

    Once I start up Windowze, I can surf just fine, no access issues. This is JUST a Parallels Update issue.
  8. John@Parallels

    John@Parallels Parallels Team

    Please post ticket id here, I can check,
    meanwhile if it is laptop, the very easy steps to check that it is not router , is to try update Parallels from any public network
  9. has this issue been resolved?

    I have no other connection issues whatsoever, and have tried directly connecting by wire to my cable modem but still can't update.

    The KB article says to look for a preference file - com.parallels.updater.plist - but this file does not exist. Was that the ver 3.x name and it changed?

    I've been using - and updating - since ver 3.x and never had a problem.
  10. com.parallels.updater.plist does not exist

    I am also encountering the "Unable to connect to Parallels update site" error, and the file referred to in the KB article does not exist: com.parallels.updater.plist

    I have experienced this error ever since I upgraded to 4.0. Isn't there a way to manually download the necessary update from your website? It's quite frustrating to be reminded every time I open Parallels desktop that an update exists, only to be denied every time a download is attempted.
  11. I have the same issue - same message and the updater.plist file mentioned in the KB article does not exist.
  12. I was able to successfully download and install the update by changing the destination location of the download to the parallels installation folder (as noted by Rob17 earlier in this thread): \Home Drive\Applications\Parallels

    If I recall correctly, the default location for the download shows up as: \Users\<user>\Downloads
    For some reason this location must cause the Parallels update application problems.
  13. Thanks Lance.
    I did try that and it does seem to get me further (appears to download something, asks for admin password) but then fails almost immediately with "Unable to Install Update". But it has gone beyond the "Unable to Connect" situation.

    It keeps finding a 'maintenance' upgrade PDMU4021 to build 3810 (I'm already on 3810), but fails each time.
  14. Re my message from a few minutes ago about the PDMU4021 patch, I see that there is a separate thread on that problem, which I will check into.

    FYI - unmounting my backup disk as suggested by one member in the PMDU4021 thread did work for me as well (I've posted that success in the other thread as well).

    So - pointing the download at applications folder solved the 'unable to connect' message and unmounting backup disk solved the 'unable to install update' message.... for me anyway.
    Last edited: Mar 3, 2009
  15. Sorry, can anyone provide a little help? I'm having the same problem re: Check for Updates. Forgive me for being thick, but where do I change the default download folder? I don't see that option at all in parallels (or osx in general - I tried changing Safari's default, but that didn't help, which I suspected it wouldn't).

    This is frustrating - hopefully someone here can elaborate a bit for me?

    Thanks very much.
  16. I'm having a different problem, but falls under the category of unable to check for updates.

    When I turned on my XP guest OS today (more specifically, I resumed the session), I got a Mac window pop up to tell me that there were updates to parallels desktop 3.0. I moved this notification to the background as I needed to access my XP programs.

    I was unable to type in any of my XP windows, but my mouse still worked.

    I went back to the update screen and told it to update, and it said it was downloading something to users/[username]/desktop, and it told me to remember to reinstall parallels desktop tools in the guest OS. It looked like an OS X update window, so I didn't give it much attention. The progress speed suggested it would take a number of minutes to download the update, much less actually install it.

    Since my programs still weren't accepting the keyboard, I quit Parallels and restarted it (the "quit parallels" option in the file menu was greyed out when the "updates available" screen was up; it became available again when I told it to start updating), only to discover that the "now downloading updates" screen disappeared as well. I had thought it was a separate process.

    When I restarted Parallels, the "now downloading updates" screen did not reappear, and when I go to Help>check for updates and click on "check now", the "checking for updates" scroll bar fills up, the screen goes away, and nothing happens. There is nothing new in users/[username]/desktop.

    This update behaviour is only *very slightly* less annoying than the previous behaviour, which told me that my registration was invalid and therefore it couldn't check for updates. (Which I posted about at the time. And the next time the same thing happened.)

    So now there's apparently an update to my Parallels Desktop and I can't get at it. Again.
  17. I can't check for Updates either, get: "Unable to connect to the Parallels Update site. Please check your internet connection"

    I am on a MacPro desktop, using ethernet so no wireless.

    Checking thread previous suggestions are:

    A) Moving com.parallels.updater.plist - like other people I don't seem to have this file
    B) Changing the destination location of download - how do i do this - all I get is the above error message - no dialogs or anything.

    Tried on another Mac and same prob.

    Build Version 4.0.3049

    Anyone got any ideas?

    Have big problems getting WindowsXP running - hoping that updating Parallels will cure
  18. Hi,

    I'm having same problem, my Parallels Desktop 4 can not update.

    Clicking on Help->Check for Updates gives the follwoing error message:

    "Unable to connect to the Parallels Update site. Please check your internet connection"

    I am on a MacPro desktop, using ethernet, connection works fine for everything else.

    Checked forums - people suggesting changing where preferences file com.parallels.updater.plist (but I don't have this file) OR changing the destination location of download (but can't see how to do this - just get error message - no file dialogs)

    Tried installing on another Mac machine, same prob.

    We are having big problems with getting Parallels to run Windows XP - crashes on install and running if install successul. Hoping that Updating Parallels will cure.

    Build Version 4.0.3049
  19. Parallels Desktop 5 too

    I am getting this with the latest Parallels Desktop 5.
  20. Problem with version 5, MacBook Pro

    Similarly with 5.0.9308. Followed everything in this thread with the same result as others.

    No plist file, no ability to change folders. Just frustration.

Share This Page